Non Stop CTDs After SU8

Anyone else had constant CTDs nonstop lately. I seem to get it every flight now, where I have gone the last year and a half with maybe three or four CTDs. This is getting immensely aggravating, as this most recent update was meant to add stability. It seems as though, they made the game stable for others, but broke the game for everyone else not experiencing CTDs lol (I know that is not actually the case btw).

I only have a few mods, the toolbar pushback, some sceneries and the most recent FBW experimental build, which shouldn’t have any effect on the sim, but I’m sure Asobo can find a way to mess things up for third party developers when they are trying fix Asobo’s shortcomings.

3 Likes

And this is where you’re wrong. Even a single faulty livery can prevent the sim from loading entirely. Before you blame Asobo at least run the sim completely vanilla to rule out the mods. I’ve heard multiple reports of the latest Experimental version of the A32NX causing issues. That’s why it’s called Experimental. FBW suggest using the Dev version for your day to day flying.

9 Likes

You say you have “a few mods” and “some sceneries” but many CTDs have been caused by those two things. I’m fine with laying some blame with MSAsobo when it’s warranted, but you have to rule out those mods first. Drop the mods and try again, then add them back individually until you find the culprit.

CTD Investigation 101.

1 Like

I guess I understand, it’s just that Asobo’s base product is sooo lackluster, I refuse to try to fly a vanilla anything that Asobo produced. I guess this is what we have to put up with in the sim world when we mod. It’s just so frustrating as the sim seems to become less stable as new updates are released.

1 Like

It’s never been more stable for a lot of people.

You need to understand though, if YOU decide to mod your game. YOU are responsible for the stability issues these may cause. Going on a rant aimed at Asobo is not an option anymore.

12 Likes

It’s just so frustrating when all of these mods are tried and true in the past that all of a sudden don’t work on the “new and improved” version. Especially after more than a year after release. To have to reconfigure everything and see what works and doesn’t every update, is tiresome when you just want to fly a little here and there.

it’s called ‘experimental’ for a reason you know

Additionally, I had the same result on the Dev version as well.

1 Like

What’s crazy (and I admit it must be frustrating for you as well) is that for many many simmers here, the sim has NOT become less stable as new updates have been released. I’ve been asking for a log file to be created when starting the sim (like “that other” sim) since the day MSFS came out. If we could see what was happening in the background, maybe we could determine where these failures are coming from.

Until then, if your hardware meets the specs, then all you can really do is what so many other people have had to do on these forums (reload, change settings, drop mods, etc).

…but to answer your question, I have not had constant CTDs since SU8. My only suggestion is that you try with no mods, and if it works, add them back in until you find what’s breaking it. If you still get fails without mods, then post back with that info and your system specs and settings and people will be glad to help you.

another tip, if you ever in the past had a certain non-bing maps addon installed, read here;

Do Not Use Google Map Mod - Community / General Discussion - Microsoft Flight Simulator Forums

Even with no mods installed I am crashing way more than usual in SU8. For me it’s development mode with a project open. I’m finding it very difficult to update the mods I’ve developed because of the crashing and freezing. I didn’t have this problem prior to SU8.

2 Likes

I did not mess with this mod at all as I didn’t want to make the sim less stable.

Is the worst SU ever. I have them everyday when I had no CTD during months. There´s a clear memory leak in the SU. I have 32Gb and game uses 15Gb after 1 min of gameplay, when normally it used less than a half of it with previous SUs.

Cheers

Just out of curiosity, for the OP, do you happen to have Capture One installed on your computer. If you do, perform a search of this forum using the “Capture One” search term and you will find a fix for your issue.

I had a couple of CTDs in the two days post SU8 (unusual for me). I found others on here who recommended using latest NVidia driver (511.79), was sceptical but installed it and no CTDs afterwards.
Other things though-

  1. Like others say try vanilla FS then add in mods.
  2. I have used the FBW A320NX but use the stable version v0.7.4. Try it instead.
  3. If you update your NVidia driver make sure to clear your direct X shader cache.
  4. Have you cleared the rolling cache? I do this after every SU or WU or even scenery install.

All in all I’m finding SU8 very smooth and stable now.

mine’s working fine with all my mods enabled.

I’ve had a couple freezes and CTD’s since SU8.
Never had any since SU5! Overall it’s pretty stable except for a sound issue now. Sometimes sound drops out and I must reboot.
Still need to hit CTR-0 to use mouse in VR, an old bug that somehow didn’t get fixed for last two updates. Still very buggy for me.
(i9-12900, RTX3080, 32G)

I have just completed my first flight, which I did not enjoy btw, as when I was landing, the sim came to a crashing halt (0.5-1 fps)! Somehow, even though I was being sabotaged by the sim, I had a firm but acceptable landing. I cycled the views around and then everything was fine again, performance back at the locked 30fps. I just am at my wits end with this sim!! How can I still be worried about whether or not I will be able to complete a flight after over a year!

My settings are mostly med with only buildings and trees at high. Photogrammetry off (as I do not like melted buildings). LOD at 150 and Object LOD at 100

Processor: Intel Core i7-9700 CPU @ 3.00GHz
Video Card: NVIDIA GeForce GTX 1660 Ti
Video Card #2: Intel(R) UHD Graphics 630
Operating System: Windows 10
RAM: 16 GB

1 Like

Can’t fly at the moment at all as long as I have scenery mods installed.

Interestingly enough I didn’t have any problems during the BETA SU8, but since this weekend I’ve been getting a CTD every time I try to load a flight from the World Map. None of those mods have ever made any problems before.

Having restarted the sim about 30 times now, I’m down to only 15 payware aircraft. No scenery, no liveries, no ui mods. Nothing.
MSFS still crashes upon loading a flight every time.
Even if I get it to run with only a handful of aircraft (no scenery) installed, the game crashes intermittendly.

The only way to be able to load a flight reliably is a totally empty Community folder. By now I have completely reinstalled MSFS (including the complete Official folder).

:frowning:

Never had any problems remotely like that before. All drivers are current. OC is off on GPU, CPU and RAM.

Event Viewer:

Fehlerbucket 1747402328503340138, Typ 5
Ereignisname: MoAppCrash
Antwort: Nicht verfügbar
CAB-Datei-ID: 0

Problemsignatur:
P1: Microsoft.FlightSimulator_1.23.12.0_x64__8wekyb3d8bbwe
P2: praid:App
P3: 1.23.12.0
P4: 00000000
P5: FlightSimulator.exe
P6: 1.23.12.0
P7: 00000000
P8: c0000005
P9: 0000000000771bc3
P10:

1 Like