Not responding on app startup initial window: resolved

My update to went smoothly and fortunately have not been impacted by any performance issues. Unfortunately this morning, after several successful flights yesterday, the sim will no longer start. Just loads the initial window, doesn’t get as far as the xbox logo. Showing cpu usage and allocated 1.5gb of ram, internet is working fine. Have rebooted, logged in and out of the store and also xbox account. Been using it since tech alpha and never experienced this before.

I9-10900K, RTX3090, Evo980 nvme, 64gb .

Update 1: On further investigation I have identified that the app is stuck in a loop accessing the registry keys in HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\MMDevices\Audio\Render. Have tried uninstalling/installing audio drivers but not resolved, so have raised a Zendesk ticket #96940.

‘Fix’: I found that Windows didn’t have a default sound device selected, on selecting one, I then managed to go through the startup until I got to the ‘New Activities’ screen where the blue bar took ages but did eventually allow me to select a flight. Again loading the flight was extremely slow and checking the processes the sim was continuously trying to resolve the registry entry mentioned above for both slowdowns.

Finally I tried disabling all sound devices in Windows and that fixed the sim load issue. I’ve now reenabled them and the sim now loads without issue. There is clearly some state that is cached and survives Win reboots but is cleared once there are no sound devices. Possibly more of a Windows issue than the sim, however this demonstrates there is limited defensive coding in the sim for such issues, and this overhead of continuous registry requests brought my i9-10900K to its knees. Having been a software developer/architect/programme director for nearly 40 years my experience tells me there are probably many similar issues resulting in random sim performance.

Edited: Solution Option not available to original poster. For those reading this thread, please refer to the first post in this thread for the solution.

Thanks. You can mark your own post as solved using the hamburger menu icon (three dots) and edit the title as you see fit so others searching for answers can see your status.

I can’t see the option to mark my own post as resolved, only appears on your reply?

Gotcha. Not sure why it’s not showing on your post. It’s okay, I’ll edit my reply to point the reader back to your first post. Thanks!

To Note: The first post (main topic post) can not be marked as solution. Only posts below it. I’ve marked @CasualClick post as solution. The one that points back up to the main topic post.

1 Like