Num keys don't work when cursor over ATC panel window (SU8)

The number keys that correspond to ATC options don’t register when you accidentally leave your mouse cursor hovering over the ATC panel window in VR.

Not a showstopper, but a significant quality of life issue.

The air traffic controllers don’t like me much as it is.

Yes very annoying. This must have something to do with the
previous bug with the throtlle and rudder not working when mouse was over an open toolbar window. That was fixed in SU8 beta but this new behavior was introduced. I use a third party program Voice Attack to speak the commands. When the mouse is over a panel window the program is not listening.

This is a really stupid bug that needs to be fixed ASAP

This is seemingly still not fixed even on SU10 beta.

I have this issue even when hovering the mouse over a GPS screen. I just took a flight in the Just Flight Hawk and when I had left my mouse pointer over the GPS screen in the centre console (where the hud should be) I couldn’t use the joystick buttons I have assigned to ATC selection 1,2,3, etc.
Didn’t try on the keyboard (I’m in VR :slight_smile: ) but I imagine it’s the same.

Can’t believe it’s SU8 bug and still not fixed. Not that it isn’t obvious to anyone who flies in VR.

Fortunately, they at least partially fixed the positioning issue so you can at least move the panels out of the way.

In some previous iterations, the panels spawn at the center of your vision where the cursor was also defaulting to so it was constantly blocked.

1 Like