NVIDIA 466.11 drivers released (MSFS VR fix included)

Yeah I’ve recently also noticed that low latency OFF is actually smoother (for VR) , which makes sense according to what the CPL description says (“maximizes throughput”).

@CptLucky8 Any idea why this is? Has something changed? Do you still recommend low latency for VR?

It would be interesting to know alright. I forgot to mention I’m running with 32Gb @ 3200mhz and averaging around 35fps in VR

1 Like

Vrflightsimguy on YouTube only changes power management to max performance, and texture quality to performance, leaves everything else. I’m having much better results with this approach than with all the fettling I was doing before! Not sure where he gets his info, I think he’s part of a MSFS VR fb group.

Also agree with game mode off, hags on, it’s been the best combo for me.

I’m exactly the same spec as you - 5800x, 3070, 32gb 3200mhz ram, x570 mobo

1 Like

I’m not sure this still needed, I need to make some tests. As now Windows have below the HAGS settings a list of game you can choose to prioritize Performance or power saving, even on a desktop. So possibly it have the same impact? or it’s just to choose with graphic card to use (cpu integrated or discrete). Not sure, only my RTX is enabled on my machine, and I’m on desktop so battery saving seems useless. Tests needed (as always).
Sorry, thinking out loud :thinking:

From what I’ve seen and from my own experience most of those settings in the Nvidia control panel have minimal effect on things. At the end of the day we’re so reliant on Asobo to have the sim optimised and running well. We could spend hours mucking about with settings but if their coding isn’t best optimised then its likely we’ll get no where. That optimisation patch that was released just before the recent world update killed performance for me. We just have to be patient and wait for them to fix things.

With the G2, I was recommending different NVidia CPL settings for Motion Smoothing:

This is post #2 in the topic :slight_smile:

With the Index, I still keep: Low Latency ON | Threaded Optim. ON | Vertical Sync FAST

Using Max Performance can lead to lower fps because you can hit the GPU Temp Limit faster and make it throttle back more often. This requires a good temperature control (i.e. fans and air flow or liquid cooling). Using Optimal Power instead makes the GPU adjust the power consumption the closest to sustain a certain perf vs temperature/power, contributing to stabilizing the perf and reducing stuttering as a side effect (flat graph vs saw tooth) but also gives a higher average fps over time. Given how this setting is working, I’d recommend you’d use Max Perf. on 2D with GSync, but Optimal Pow. in VR.

Like you’re saying, this is meant to tell whether the application would be using discrete or integrated GPU. And even if you do, the application can be exporting two functions with a special name (1 for AMD and 1 for NVidia), which the discrete video card driver detects automatically in order to render on the discrete GPU instead of the integrated. I believe this mechanism also overrides the Windows setting.

1 Like

If you didn’t make any mistake here it mean the Windows DWN.EXE process take the hand when HAGS is ON (at least on your system, didn’t checked on mine).
This is the same thing which happen when the (in)famous “Fullscreen Optimization” is ON on your executable (right click on exe->Compatibility Tab), Windows let the game believe it have the full graphic power and it run on fullscreen, but instead make it run in bordeless and take the hand between a game and the display (Big Brother) to do its own cooking (like adding overlay) before displaying the game. That’s why I recommend to turn this “fullscreen optimization” off.

What I read on your graph seems to say the same things here.

1 Like

This driver is slightly better than 457.3 for me, which is great. All other drivers in between gave me a lot stutters.

But I am down 20% in FPS since WU4 which is frustrating.

I feel like I’ve lost a few fps too, more like 10% though

Here is my quick comment about 466.11:

Yesterday I’ve finally took the plunge and installed it on my test system for a few flights with the Index. So far, so good, with similar perfs as with 457.30. I’ll have a few more specific comparisons to do but it looks fine to me for now.

4 Likes

After a long hiatus due to defective Reverb G2, I am back to flying in VR. 3090, i9-10900K, and updated to the latest driver 466.11. I read mixed reviews but nothing really bad from folks using similar hardware.

My take after a couple days of flying it is that there is little to no difference from 457.30. I plan to keep it. Would be nice to see some actual improvement in the future!

1 Like

I’m running i9 3080oc G2. Got higher LOD settings at same frames than 457 after turning Low Latency off, Threaded Optimization off, leaving Vertical sync fast. HAGS and Game mode still off.

1 Like

I agree! Seems to be the first one that’s actually a viable alternative to 457.30! Amazing

2 Likes

My first flights today with 466.11, best performance ever for me.

Followed some new advice and just left default settings in NVIDIA control panel, didn’t change anything at all.

Game mode and HAGS both on.

Quest 2, beta, debug tool 0.8x0.8 fov, ASW off.

TAA100, glass cockpit, clouds, reflections all high, texture quality and synthesis ultra. Everything else roughly medium/high.

5800x, 3070, 32GB 3200mhz, 500GB NVME

I am curious what experiences with this driver have users of scary cards than 30 … e.g. 1080Ti

Further feedback from today with NVidia 466.11 and FS2020 1.15.8:

  • NVidia CPL: none of these make any major diff either (I only tested these 2 combos):
    Low Latency OFF | Threaded Optim. OFF | Vertical Sync OFF (HAGS ON)
    Low Latency ON| Threaded Optim. ON | Vertical Sync FAST (HAGS OFF)

  • NVidia CPL: this one seems overall better in the end
    Low Latency ON| Threaded Optim. ON | Vertical Sync FAST (HAGS ON + Game Mode OFF)

  • NVidia CPL: however with 466.11 I might have slightly better perf with:
    VR Pre-Rendered Frames 4 (instead of 1)

  • Extra: I don’t see much perf diff with Texture Filtering Quality vs High Performance
    I’m therefore using Quality

  • SteamVR 1.17.6 beta (latest) is crashing a lot more often and has a hard time when using too large rendering resolution compared to 1.16.10 (release).
    I’m reverting to SteamVR 1.16.10 for now.

The most dramatic performance hit with my test system on a 2070S + 9900K is buildings and Photogrammetry. This seems consistent with my reports since WU3 UK where I find the game over subscribing VRAM and causing CPU/GPU stalls. However thanks to SteamVR Fixed Rate motion smoothing which can go down as much as 6:1, I can actually raise a lot of settings compared to “My VR” topic and still maintain a good experience.

In short here are the settings I’m currently using:

SteamVR
Motion Smoothing enabled
SS 124, 90Hz + Fixed 18fps + 33.3ms

FS2020 .
TAA 100
Terrain LOD 100
Terrain Vector Data ULTRA
Buildings MEDIUM
Trees ULTRA
Grass and Bush MEDIUM
Object LOD 100
Clouds MEDIUM or HIGH
Texture Res. ULTRA
Aniso. 8x
Texture SS 4x4
Texture Synth. ULTRA
Water Waves HIGH
Shadow Maps 768
Terrain Shadows 256
Contact Shadows LOW
Windshield HIGH
Ambient Occlusion LOW
Reflections HIGH
Light Shafts HIGH
BLOOM OFF
Glass Cockpit Rate HIGH

NB: Bloom OFF otherwise it is also blurring integral lighting (illuminated button text)

NB: Clouds depends on the aircraft and the region. I can push HIGH in rural regions but MEDIUM is freeing some resources just to keep rendering perf at the limit.

NB: TAA100+SS124 is my goto setting suitable for any aircraft. If I’m using an analogue cockpit only like the DR400 I can use TAA70+SS200 or TAA80+SS150 with the 2070S and Motion Smoothing, but there are more wobbles sometimes.


Updated: Nvidia + HAGS ON best combo, Texture Res. HIGH → ULTRA!

4 Likes

Trying on my 3080oc G2. Reset Nvidia Control Panel to default adding 4 pre-rendered frames, your sub settings with LOD 125 runs very nice and smooth. Frames just under 40. Thanks.

1 Like

@CptLucky8 - Thanks for the sleuthing! I applied your settings and did a couple of quick test flights. There is indeed a noticeable improvement in smoothness. I don’t have any quantifiable measurement tools but I can say I will keep these settings until something better comes along!

I do still have Game Mode set to Off - I did not see that listed.

1 Like

@SpanHorizon5 Thank you for your feedback! I’m glad this is helping!

I’ve updated the post: Game Mode OFF

4 pre rendered frames is a showstopper for me with 2080ti and G2. Had to revert back to 1.