Nvidia DLSS in VR

Because VR and the people who view it, we humans, are sensitive to behavior around these performance thresholds, if the overall performance and graphics configuration of a given PC is around a threshold below a certain FPS, a small change can significantly change the user’s experience.

To give an example, assume that Quest2 is unable to maintain 36 FPS, half of its default frame rate of 72 FPS.
The two cases are 10% frame delay time, or large frame time loss at irregular intervals, and stable frame delay time of less than 3%. The former is probably unbearable. In the latter case, the user will feel comfortable.
Between the former and the latter, the difference in processing speed is less than 10% back to back compared to the base 27.78ms. The difference is probably less than 2 ms.
Although it is a 2ms difference, the experience can be very different.

In this case, the DLSS may sound better to a user with the relevant criteria who previously used a different AA and switched to the DLSS.
Conversely, users who have conventionally maintained a stable 36 FPS will not feel any difference. They will judge that the image quality is just worse.
Of course, we know that not all people will experience the effect equally.

I’ve spent the morning testing after SU10 and whilst I’m pleased with how my sim is performing in VR, I’ve abandoned DLSS for now.

I tested all the different settings of DLSS and all at 100% render scale, 100% terrain setting and 150% VR resolution in my Valve Index.

I did get good performance boost in terms of framerates - 45fps instead of 30 that I usually get with TAA, plus notable improvements in CPU and GPU frametimes (as good as halved with performance DLSS).

But none of that matters because inside and outside the cockpit the textures are way too blurry - I even upped the scales to 200% and then on DLSS Quality, though the performance was back to normal TAA rates, the view was terrible. Trees in woodland blurred together into a horrid mush - an unreadable cockpit in the default PC-6 that I used for testing along with the AS Twotter. It was so bad it started making me feel sick - something I have never had in VR flight sims before.

So I went back to TAA but left the settings at 200% and got back my solid 30fps, no stuttering and nice looking scenery but above all, legible instruments!

So I’m happy with SU10 - but won’t touch DLSS for the next year or so. See what it looks like after a few optimisations :slight_smile:

edit: this was with the new studio driver 517.40 on an RTX2080Ti and i5 9600k @ 4.5GHz with 32GB DDR4.

1 Like

DLSS won’t help if you’re CPU limited.
Although you probably know that already, perhaps others don’t.
I’m using a 12900K at 5.3 and a 3080TI overclocked as well.
I’m getting beyond 10+ fps more compared to using TAA.
Everything Ultra except Ambient Occlusion on High.
LOD 300.
About the blur… my solution is OpenXR Toolkit, where I dial FSR Sharpness at 100, scale at 100%.
It’s not as clear as TAA, but to my eyes it’s quite close.
I’m happy :blush:

Edit: I forgot to mention…
The reason for choosing DLSS Quality in my case, is so I can now have Clouds at Ultra :drooling_face: which has a 10 fps hit on my system.
So I’m getting the same performance as with SU 9, but Ultra clouds and a bit blurry displays, oh well.

1 Like

In my case, according to fpsVR my cpu is well under-utilised. In fact, all of my kit is. No doubt things will improve when I update my graphics card (thinking of a 4080/16) but current usage hovers around 80%. My cpu is around 50+% on all cores.

What gets me is the miserly RAM usage, regardless of settings. It’s never used more than 5 of the available 11GB VRAM and never more than 8.1 of my 32GB sys RAM. I doubled my sys RAM when they told us we would need 32GB - so I’m not sure why they said that, although performance definitely improved in VR when I increased it, which I don’t quite understand if it isn’t using it (and it would seem nothing else is, either), but there ya go.

DCS World does benefit from it, though, and uses much more of both - but then it’s a single core process.

Reading this thread makes alot of sense. I should probably move back to TAA then as I am mostly CPU limited.

Would this be a correct conclusion?

Non VR
3070ti
I9 11900k

i tried dlss and thought it was blurry so went back to taa.

Today for me was the first time i have been absolutely blown away by vr, tu10, dlss and the new Nvidia studio driver have finally put a smile on my face, for the first time in about 8 months its been nice being able to fly low level in an f-18 feeling the speed without out constant stutter, i cant believe what a difference this new update and driver have made its been awesome.
My system Intel 12 Core i7 12700K Alder Lake standard clock, asus rog strix mother board, 32gb fast 14clk memory, founders 3070 ti, Quest 2 with link cable.
I use msi after burner for undervolting but with small overclock and in the quest debug tool have asw off and 500mb set, in fs i set dlss balanced and a mixture of medium and high settings.
Hags off! Nvidia control panel vsync Fast and let the program decide.
Before i updated to the new studio driver when ever i turned my head frames would drop from 37 to 18 and be very laggy now im getting 47 frames constant even when moving my head in any direction, finally it feels like flying its so smooth.
Im also using Directx 12.
Cheers to all concerned it was worth the wait, thanx.

2 Likes

the dlss blurriness can be somewhat compensated with higher supersampling by setting the openxr tool (not openxr toolkit) and set the ‘custom render scale’ slider above 100%.

ex: setting this to 130% means the image will render at 3604 x 3522 and by setting the dlss quality=balance, decent performance with ~clear text on the glass panels.

I have had the exact same result!

2 Likes

Guys & Gals,

Don’t know if this helps the understanding of DLSS in VR or not…however, I noticed this as I messed with DLSS today and found that I could get really good visuals and run DLSS on Quality.
Here are screen shots of my setup in MSFS2020…also, the specs of the hardware I am running on…
I have the following system specs:
Intel i9-11900KF no OC
ASUS Z-590-A Motherboard
Flightsim is on a NVME SSD drive (Samsung 870 EVO)(MB mounted)
Flightsim cache is on a NVME SSD drive (Samsung 970 EVO plus)(MB mounted)
32 GB of 3200mhz RAM (Ripjaws)(2 16 GB chips)
Nvidia RTX 3090 with 24GB RAM no OC aircooled
PIMAX 8KX with latest software updates (277 & 299)
OpenXR 0.2.6
OpenXR Toolkit 1.2.0
All settings in OpenXR & Toolkit are default

This setup gives a FR of 26-28 around Puget Sound area in Washington State and 19-20 around Seattle area. The advanced info for FR also shows my CPU around 6500 and GPU around 14000 and Virtual Memory of around 11K.

Here are the setting pcis for the sim on my machine:








This provides a very nice visual in the sim. However, during the flights as new scenery is loaded the sim in VR flashes numerous times as if DLSS is learning the images and then it calms down to a flash every minute or so…this appears to worsen as the render setting is moved past the normal video settings of the device (VR headset in my case) (the headset is capable of 3840x2160) and I have it set slightly lower than this (if using TAA in VR)…if set two or three levels lower it makes the flashing almost go completely away…it is also exacerbated by turning up to High or Ultra the clouds or terrain level of detail above the 135 I have it set at. World scale seems to make no difference to the flashing but does improve overall cockpit image quality.

Anyway, I hope this helps people out and we can get MS or Asobo or the OPENXR folks or PIMAX to look at this issue and see who needs to do what to fix it. I am happy overall with my setup right now, but it was better (in my opinion) prior to SU10.

Let me know if anything I did might help you or if you have settings that might help me get totally rid of the flashing issue.

I am also a PIMAX 8KX user and see the background flashing.
Stopping the use of high load TAA and reducing the quality of DLSS and clouds has mostly eliminated the problem, but the quality is worse than before SU10.

The name plate flickering in the clouds is very annoying.
The problem becomes more pronounced with thick clouds and very distant views.
Lack of cloud z-depth? I feel such a discomfort.

The problem occurs only in VR, normal displays are fine.

That is exactly what I was seeing…did you try the settings I suggested…it fixed most of it for me…or at least calmed it down considerably. If you had the same or near the same setup of your PC and software? Just wondering if you saw improvement? On other thing I noticed is that if you enter VR and it was blurry or flashing and you exit VR then shutdown the PIMAX software and restart it then reenter VR it seems to fix some issues.

I am in complete agreement with your suggestion.
The setup is pretty much the same as you report and the cloud level and TAA have a lot to do with this issue.
Almost completely solvable, but cloud quality level dropped.

I was looking for if this is a common SU10 problem among PIMAX users and found a thread with similar bug reports.
The problem does indeed seem to exist.
I will track that topic.

https://forums.flightsimulator.com/t/large-fov-on-pimax-casues-occasional-glitchy-frames/529480

This is in another ticket https://forums.flightsimulator.com/t/large-fov-on-pimax-casues-occasional-glitchy-frames/529480

Pleas vote it up
!

Are you using the OXR Toolkit? I have an Index running on a 3080 and a 9600K - in the OXR Toolkit I have FSR on with sharpening set to 80 and it helps reduce the blurriness introduced by DLSS - I also have my SteamVR resolution set to 150% though with a 2080Ti you might not be able to go that high. Using TAA is tack sharp at those same settings - even tiny text is readable, but I like the extra FPS overhead I have with DLSS - I’m frequently able to run at 40FPS and sometimes even 45.

My SteamVR res is set at 150% but I no longer use any external tweaking utilities for VR.

Other than that, I just posted my sim settings in this post:

DLSS is absolutely pointless, it is upscaling, no sure how Nvidia managed o dumb people so much to buy into marketing.

Tried it with my 3090 in a couple of occasion (coming from a 1080ti) and it is pointless, as much as I find raytracing pointless too really, at least at this stage.

In VR is horrendous, even on performance with the 3090 it throw me back to MSFS 95 era, I just tried out of curiosity, DLSS 3.0 looks even more ridiculous.

You might be missing the point. You said it yourself: it’s upscaling. You have to trade-in the DLSS performance improvement BACK for resolution. In the end, if your system is any good it should look at least as good as “50% resolution scale with TAA” with “DLSS performance”. Too many people turn it on and immediately recognize the downgrade graphically and don’t realize they just told the PC to render at 1/4 the render resolution (50% render resolution). DLSS is not a miracle, no, but it does have benefits when properly balanced with resolution. If you can run it native you should, sure, but a fair fight is TAA at 50% vs DLSS on performance setting. In effect it can (under the correct circumstances at the very least) provide a less aliased and potentially more detailed image with greater FPS to boot: which can in turn be traded for even higher resolution (although never for the native). I’m not at all trying to win people over. Do what works for you. But DLSS does - when balanced properly, on systems with certain settings - provide a benefit and I would hate for people to see the messages above thinking DLSS is always bad. It’s a balancing act and too many people are turned off by having to tweak things - or for that matter have a certain graphics card.

1 Like

Yep - I didn’t notice DLSS=Quality advantage until I tried to kick up my raw resolution to 3500x3500 with OXRTK 80% scaling down to 2800x2800 and then use DLSS so that I could generally get (not always) a solid 36FPS for MR at 72Hz on my Quest2. Then I have pretty good (the best I’ve ever had) clarity and smooth sidelook performance.
CPU=9700K@4.8Ghz+RTX3080ti

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.