Nvidia Driver disappointed

Hello,
Discussions about graphics cards and their drivers goes in the PC & Hardware section. I have moved your post there.

3090 Asus Rog strix here . No stutters with latest driver. Try a clean install ( with DDU).
try also clean driver with out Geforce experience

I wouldn’t recommend this because it is not needed.

You might want to also read:
What NVidia Drivers are recommended for VR
How to install Nvidia drivers properly when trying out different versions

As for DDU (one among many other example):

weird, i never had any issue with DDU

1 Like

as for 457.30 driver , check this Security Bulletin from Nvidia :
https://nvidia.custhelp.com/app/answers/detail/a_id/5142/kw/Security%20Bulletin

The only thing I noticed with this nvidia update was that my 3090 runs about 4-5 degrees cooler.

Sure, have you clicked the link I’ve posted above and read its content prior posting this?

It says:

1 Like

No i didnt. I just checked your link.

1 Like

I’m embarrassed to ask:

What is a CVE?

Don’t forget it isn’t only about improving performance, there are security reasons for some of the driver updates.

So instead of reverting, do you suggest me to lower down my settings and wait for a better driver to come out?

I have the latest update of Nvidia drivers for my RTX 3060ti… I see it’s more stable than before. only few days ago Nvidia launched the 461.72 (461.72 desktop win10 64bit international). On 3840x2160 resolution I get smooth 30 FPS which I thing it’s a good enough rate while I get nearly 50 FPS on 2560x1440. Note I didn’t play with Nvidia settings at all. it’s the best choice to keep those settings intact and instead, try to change the sim configurations only.

Here my specs:
Motherboard : Asrock B550 Phantom Gaming 4 AC
AMD Ryzen 5 5600X , 32GB ram, RTX 3060ti 8GB, Philips 43 4k TV.

At the moment (I don’t need to upgrade my hardware at all)

CPU-Z CPU-Z-GPU

Can I see your simulator in game settings at 4K?
I have some settings on the Nvidia control panel moved around. Maybe that’s my issue of the stutters who knows.

The only changes I made on 4K are:
V-Sync = (OFF)
Global rendering = High End

How about your sliders?

Defaults, No changes I made

I’m inclined to agree. I’m noticing a lot more stutters and loading times when I approach any airport and the scenery loads- of course, that’s on final, so not the perfect time for this nonsense. But I didn’t have this problem to this extent before the UK update.

I don’t know if it’s some kind of incompatibility with an object or maybe it’s related to the lighting glitch somehow, or God knows what else. But, I’ll stick to blaming Asobo for the performance drop before I fault Nvidia.

1 Like

Interesting- I was blaming Asobo for the latest glitches as usual, but I’m definitely going to give this a try and see what happens. I’m on a 1080ti too.

It’s worth a try, it may work for you, all I can say it works best for me on my system at the moment, when I have the latest drivers installed I was seeing my Vram tanking at 10.5GB the earlier driver I have uses 8.5GB of Vram with the same performance and settings, I didn’t notice any major stutters with any driver installed, it was the fact that my fans were running harder and I had little headroom left with the new drivers which could have caused issues in different flight scenarios, but it is always worth a try :slight_smile:

Use the Nvidia website to get the driver. A recommended driver is 457.30. Make sure that you do a custom install - it gives you to option to do a clean install (by clearing out the old driver first)