Oculus Quest 2 Glitches when MSFS has main focus

I have a new (to me) problem using my new-ish Oculus Quest 2 and Microsoft Flight Simulator.

The issue is that the Oculus desktop is perfectly stable as long as MSFS does not have screen focus. (It does freeze intermittently while the sim is loading.

When MSFS is on top (on the monitor) the Oculus desktop then goes berserk, dropping to perhaps one frame every few seconds, while the screen twists and distorts with a huge black border, or sometimes defaults to a gigantic grey rectangle on a black background.

As soon as you move anything on top of the MSFS display (like task manager) and it loses main focus, Oculus goes back to normal as if nothing has happened, only to go crazy again as soon as MSFS is back on top.

I have no other game that acts this way.

As far as I can tell, MSFS seems to be sucking up every last bit of GPU resources when on top, leaving nothing for the headset to use, until you actually enter VR.

Is this… Intentional? Is there a fix?

My System:
Intel Core i7 8700K @ 5.0GHz / 32.0GB G.SKILL TridentZ Series Dual-Channel Ram / ZOTAC GAMING GeForce® RTX 2080 Ti Triple Fan / Sound Blaster Z / Oculus Quest VR Headset / Klipsch® Promedia 2.1 Computer Speakers / ASUS ROG SWIFT PG279Q ‑ 27" IPS LED Monitor ‑ QHD / 2x Samsung SSD 850 EVO 500GB / 1x Samsung SSD 860 EVO 1000GB / 5 other regular hd’s with up to 10 terabyte capacity each / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

1 Like

@SoundableTech98 I am having the same type of issue.

Out of interest, have you been trying the 200 render scale hack as well? I found when doing this, i not only get problems with the oculus home but also getting the translucent white box at the bottom of the quest as well.

Nope. I don’t use that.

What I notice is that even with just the main screen, before you even start a flight, MSFS is tagged as very high power usage in task manager, and GPU usage keeps pegging in the red at 100%

And that’s with nothing even happening!

Also: I did find that If I reduce MSFS screen size to some arbitrarily low level such as 640 x480, I also get back a stable oculus home.

1366 x 768 full screen resolution also works (as long as your sim settings are not ultra)

Very strange.

Here is my machine(s)
Intel Core i7 8700K @ 5.0GHz / 32.0GB G.SKILL TridentZ Series Dual-Channel Ram / ZOTAC GAMING GeForce® RTX 2080 Ti Triple Fan / Sound Blaster Z / Oculus Quest VR Headset / Klipsch® Promedia 2.1 Computer Speakers / ASUS ROG SWIFT PG279Q ‑ 27" IPS LED Monitor ‑ QHD / 2x Samsung SSD 850 EVO 500GB / 1x Samsung SSD 860 EVO 1000GB / 5 other regular hd’s with up to 10 terabyte capacity each / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

Try disabling the Windows Game Bar in Windows Settings. I’ve found at times it causes massive conflicts, some of which are similar to your description. Let me know if it helps.

1 Like

My Quest 2 was working great a couple of weeks ago, now it just crashes to the Quest home within the headset either straight away while having MSFS monitor selected on Quest link, or it runs with the music out of tune and stuttering with frame drops and windowing before then crashing to Quest home… I play DCS world and this still works fine so i’m guessing its something to do with the sim and not the hardware.

Ryzen 9 RTX 2070 Super 32GB Ram

1 Like

I had this problem. From what I can see the only way to solve issues with the Quest 2 like this is to launch the sim from within the headset and then stay in VR. If I want to play in VR I turn on my Quest 2 with the link cable connected. I connect to the PC from the Oculus home screen. Once I’m in the PC Oculus home screen I then launch the sim from within the headset menu (I think thats crucial). As soon as I get to the FS main menu on my PC screen I then go into VR immediately and stay there. I can’t go in and out of VR otherwise it turns into a mess. Its pretty much been like that from day one though.

Its all a bit of a pain. I’m not sure what causes the issue. I’ve got a feeling its all to do with whats happening on the CPU. Things have to happen in a certain order and stay in that order otherwise it all goes to pieces.

My VR performance is terrible anyway. My set up is RTX 3080, 5600X, 32GB of RAM. I get between 15 and 20FPS in VR.

I’ll say it again - I’ve had very similar issues with my quest (original). Turn off the windows Game Bar in windows settings and see if it helps. It fixed mine!

1 Like

After thinking about this ( and I’m still having the crashing to Quest Home every time I try to use it ) This started after I tried the 200 render scale people are talking about. )

Not sure how this would affect it but it seems it might of done ( render scale is back to 100 for PC and its still crashing )

Ryzen 9 RTX 2070 Super 32GB Ram

Already done, but it didnt seem to help :-/

I got a same sort of problem when I was trying to use my PC as a mobile hotspot for AirLink. Once I set it up properly with a router it worked great. That is with all default settings across the board.
I don’t have a cable so cannot comment on that.

It’s always been a ■■■■-shoot as far as stability.
However, it is getting better with each passing update by msfs, Nvidia, Oculus etc…
Still not clear on the order of startup, including OTT and Debug. Sometimes it all works amazingly well, then other times, with no rhyme or reason (last night) will act up causing slower fps, stutters and even a transparent white bar appearing across the bottom of my fov in my headset. Sometimes my peripherals stop working, or just some specific buttons simply don’t work. Must reboot. Sometimes it’s unplayable!
Today it may be all ok :face_with_raised_eyebrow:
BTW…PC@200 works great for me!

(i7-10700, RTX3080, 32g, Q2-Link)

I’ve tried everyones suggestions, with no effect so far. I did try process lasso, as I think one problem is that MSFS is unnesessarily sucking up resources like a starving Pac Man, leaving little left for other processes.

Process lasso immediatly went on the attack against MSFS and eventually limited the process priority to normal before finally getting seriously annoyed and
cracking down to the point of eventually listing the entire process as being under restraint.

This seemed to do wonders for removing stutters and raising FPS in non-vr, but didnt do very much at all for vr… :roll_eyes:

My humble question…Do you mean you play MSFS in oculus desktop? From your explanations, it’s unclear that you converted pc mode to vr mode by pressing ‘shift+tab’ keys and your symptoms are quite similar with things happening when MSFS played as pc mode in oculus desktop.

I am using shift + tab.

Do you do the above things in VR mode? As I know those settings are regarding PC mode (2d screen) and nothing to do with VR side.

For some reason, settings on the pc side do seem to affect VR, as noted by people using the 200 render scale trick.

Fiddling with settings on the pc side has noticable changes on the VR side, even though I at first believed the two things were completely seperate.

I know some pc settings make impact on vr side in some aspects, i.e. pc graphic resolution on vr window text fidelity. However, your case is very extreme.
My rig is a gaming laptop of i7 9750, 32GRam, RTX2060, etc., the GPU is certainly inferior to yours, and my setting is largely based the below linked post while some in game setting are downgraded to be adopted to my less powerful computer.

TnT Quest 2 Settings - Sharp and SMOOOOTH!