Oculus - VR not working. Any help?

Is anyone else still getting the “No Headset is Connected” error? I have done the config editing (was correct default) updated to v24 in public test channel. Shows error for both my Rift S and Quest 2 (link and VD)

1 Like

I am, same issue, No headset connected error. Unsure what the issue is, I’ve tried restarting the PC, still no dice.

1 Like

I have the same audio issue.

the regedit tweak works for me, but it does keep getting reset for some reason

Can you explain the regedit?

[Read First] VR Known Issues & Workarounds - Virtual Reality (VR) - Microsoft Flight Simulator Forums contains the relevant registry edit

Same here running gtx 1070 , also quite jumpy but maybe because only got 8gb ram? Running better after latest nvidia driver update but still not very smooth

Thanks this solution was good for my problem

MSFS2020 not showing on oculus rift dashboard

1 Like

I cannot get my Rift S to work - high end system and I have followed all instructions including downloading openxr, editing the reg file, opting for the public beta with oculus (installing the updates), however, when I click switch to vr mode, nothing happens at all. Interestingly, when I open openxr, i can see an error but i’m not sure if that’s connected or not. any help would be massively appreciated!!

fixed - make sure to copy and paste the whole line which needs to be changed on activeruntime - not just the last bit! LOL

1 Like

A. My headset wont even connect anymore, Ive tried everthing, B. even if it did connect, the stupid screen warps when i move my head, this is a joke

You need to bind in the ‘controller config’ screens , not the VR menu screen.

1 Like

Just dont do it if you have Quest 1 and use Oculus link, it breaks oculus link. Apparently

The fix for this is to make sure HDR is disabled in Windows and in-game. Requires a restart of the game, at least it did for me.

This has been super frustrating! My Oculus Rift works well with XPlane (Never had an issue), but for the life of me, I can’t figure out how to use it in MSFS2020. I would appreciate any help anyone can give me. The update was successful but not having any luck here.

What am I missing…my headset is plugged in and I use my Oculus Rift on other games no problem.

Ah, ok… thanks. This is somewhat helping me on my way

Yes. I had this problem too. Now fixed with this setting. Thanks a lot !!

I had exactly this problem. Now fixed by the audio setting in Windows. Choose advanced audio setting. You should see “Microsoft Flight simulator”. Now, choose Rift S for the headset.