Oculus - VR not working. Any help?

but now i have that weird mask there all the time

Same here. Also touch controllers don’t work at all.

I am experiencing this black thing on both sides.

I am having the same issue with the HP Reverb G2 paired with an RTX 3080. I will try the HDR workaround but I am able to use everything else with no issues while HDR is enabled.

When seeing black stencils in your Oculus view:

Update to the latest version of the Oculus software. If that doesn’t work:

  1. Go to the Oculus Debug tool (Default folder should be C:\Program Files\Oculus\Support\oculus-diagnostics)
  2. Open the Oculus Debug Tool
  3. Turn the option “Use FOV Stencil” to Off
  4. Disable/enable VR in MSFS

If you see yellow, try to recenter the view. And disable HDR in the graphic settings.


Updating the Oculus software to the latest version will get rid of those annoying black stencils.


Hey guys, turning off HDR in windows display settings solved my yellow screen in headset issue. Hope it does for you.

1 Like

They are no implemented in this unfortunately.

Just select the Oculus Public Test Channel to upgrade to version 24 and the issues will be gone.

1 Like

working now. please put it in the FAQs or something

1 Like

If anyone finds a way to make this game work in VR using Virtual Desktop, please let me know.

1 Like

Managed to get it working on the Index. Not sure how but it worked. My first take is that it wasn’t worth the effort. Performance / fps is horrendous and the settings are nigh all on low to be passable. This is on a 10900k and 3080. Hugely disappointed. Game also crashed when exiting flight. Buggy. Gutted.

I can confirm, turning HDR off in Windows solved the Yellow Screen for me. Not enough to just turn HDR off in game for anyone who this doesn’t work for, gotta be in Windows.

1 Like

I’m currently using a Rift S and initially had issue with the black frame and the camera starting way too forward and on the ground.

I downloaded the “public test channel” in Oculus settings and everything works perfectly now.

I can’t even get it to work in VR. I had the black frame, upgraded to Public Test Channel in Oculus, and now the sim will not load into a flight (in flat or VR). It crashes to desktop just before the flight loading bar gets to the end. It also does not show VR (CTRL + TAB) on the main screen as an option.

EDIT: And now my entire sim seems to be reinstalling (it’s showing a 107GB update…)

why do i have to dig into registry? hmm. why can’t it be included in the install?!

where can i find this? thank you.

how do we get that update? my oculus app wont go higher than 23 something on auto update

You need to click the ‘BETA’ tab in the Oculus software and then ‘Enable Public Test Channel’ to prompt a download of the beta software.

that worked! its downloading. Thanks bud

1 Like