Offscreen Terrain Pre-Caching Not Available in VR

Dont have time to test …but read on a FB group that the setting affects VR as well !
Maybe its just a glitch in settings ?

Can you try setting ultra in 2D settings and test in VR ?

Setting enable=1 and quality=3 in the config file for VR definitley seems to do the trick… no noticeable loading when moving my head and my VRAM usage definitely went up about 1.5-2GB

3 Likes

I’m not so much interested in workarounds to get the caching going - you can open another thread for that. I started this thread so we could discuss what went wrong to cause this issue in the first place.

Did they…
a. Not realize this UI element was missing?
OR
b. Release without this UI element working intentionally?

1 Like

Where is this file located?

Ho,

I can just confirm and I am a bit disappointed. I have bought my PC, RTX 3090, G2 and other stuff for the MSFS VR.

And still 2 phenomenas are around in VR. Just tested.
The poppin sceneries like costs and mountains and the growing buildings or trees when I move my head from the right to the left or back.

So sad…no pre caching set up and no solution for popping up mountains. Sometimes…the mountains keep a gap and you can watch under the scenery. Immersion good bye.

I hope, a patch comes out soon. For VR.

Well…

Regards
Dirk

See this post - not tried it myself yet, but looks like it works in VR but needs the config file edited to do it:

2 Likes

Ok thanks so far…I hope I can find the file.:slight_smile:

And I hope both phenomenas disappear…popping up landscape even if I watch into one direction and I am close to mountains or coasts…and the growing trees and buildings while watching around.

The precache can definately help concerning the 2nd point.
The first point…I’m not sure.

I will give a feed back later.

Regards
Dirk

This is just simply dreadful, I’m almost out of words as to seeing something like this happening and especially after the update was delayed so it’s not like they didn’t have time to check… It’s appalling quite frankly, sorry Asobo but it really is.

4 Likes

You’d think that at some point before releasing the update that adds a new graphics option, they would have had at least one QA tester fire up the sim in VR and… you know… make sure the option is actually there. Maybe they’d even want to go a step further and actually enable it! Maybe even test to see if it’s working!

If I ran any software releases at my job the way Asobo is handling these updates, I would have been fired a long time ago.

3 Likes

Ya. In general you right. Maybe not fired here. But no extra money for a good job and maybe a rebuke.

Ok…could be the priority like said already. X Box and 2 D world first.

But in the end it not an elegant result…working with setup-files …should not be and I am disappointed. Now going to try the file idea.

Update follows soon…

also have to say that this is very disappointing! I only fly VR. Far too little love for VR. Somehow I’m speechless …

3 Likes

Ok friends…just tried the ideas of Gordonreig and acutally numbernumber481.

I have changed the setting in the config data.The name is cfgdata.

And I can say…I am “just” 2/3 disappointed. The growing trees and buildings disappeared. And my memories are still free. I have 32 GB Ram and 24 VRAM.

Therefore, there are still 2 points. The menu for setting precache is not available…so why?

And the popping up of (parts of) the mountains or coasts is still around.

But really…after changing the precache…I can say “wow” already.

Thank you to the 2 colleagues who mentioned this solution.

But I have to repeat…still disappointed.

My friends are going to visit me next weekend and I wanted to show the VR flight. So…

If you have any idea, I would be glad to read it.

And last but not least…I hope, the next successful and complete patch comes out soon and it will be not too late after 7th September 2021.

Regards and thx again

Dirk


Hi Siedo, Is that the UserCfg.opt file? usually it can be found in:
C:\Users\blahblah\AppData\Roaming\Microsoft Flight Simulator =Steam Version
C:\Users\blahblah\AppData\Local\Microsoft Flight Simulator = MSstore version

1 Like

I have used this path

C:\Users<Username>\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe

I guess it’s better to use this one. In case you move your data of MSFS to another drive.

But usercfg.opt is correct. :slight_smile:

Edit: I have the disc version.

1 Like

Your right… the pre-caching helps a lot with fluidity of panning your head around but it does not solve the LOD issue.

If that screenshot is from your file, only thing I can suggest is cranking up the LOD sliders. They are 1.0 (%100 in the sim) in that screenshot. Try %200 (sliders maxed in sim). If you have 24GB VRAM, that means you have a 3090…as do I. You can go farther than 2.0 by editing the “Terrain” and “ObjectsLoD” values directly in the config file. I also have a 3090 but I start to see serious performance loss past %200

@Jummivana this needs Devs attention please.

1 Like

You are right as well. 200 is no problem. I didn’t try more by changing the usercfg. But even if I slender to 200, this lod issue is still around.

I really hope they solve it soon. 2 D is working already. I have tried it at San Fransico, the mountains beside the golden gate bridge. 2 D with in ultra…no problem…no lod. Just VR…

I also changed terrain data to ultra…and minimum…no change.

But actually…this lod problem should not appear in any setup.

I guess, waiting for a patch is the answer. :-/

1 Like

With RTX 3070 and Valve Index i didn’t have any problems when rotating the head quickly before the patch. I have tested setting precaching option to quality=3 for VR anyway. I didn’t notice any difference in terms of performance actually nothing changed. But im now hitting VRAM limits, which seem to result in ground textures being exchanged constantly and its quite annoying. Later today will test disabling it completely again. As i didn’t have issues when turning the head before anyway, disabling might work better with me.

You have to set the quality of the setting to 3.

1 is set to Low 3 is Ultra. If you set it on the pc side you’ll see how to set the numbers for the VR side as well in the file

Be happy if you don’t have any problems.

When you are back in quality = 1 FOR VR, then fly between two cities or forests where you can watch far. And pls do this close to the ground. Then watch fast out of the left window and observe the trees or city-skylines…then move FAST to the right window and observe again. In my case, the trees and skylines (whole areas) rebuilt and rebuilt.

Maybe it is the gpu. It could depend on how far you can watch with your gpu board. (I hope you understand what I mean!?)

But back to the topic of this thread: do you have popping mountains or coastlines while flying around and watching them? Like for example the top of a mountain or hill suddenly change the shape? The others say, this is a lod problem. If no or if you have found the solution for removing this phenomena, please let me know.