Open XR Toolkit NO settings menu

I have just downloaded and installed OXRT looked at information on here and YouTube to set up for MSFS. When in VR on my Quest 2, the OXRT will not show the settings panel as it should? Press CTRL +F1 or F2, nothing shows up on VR screen? OXRT is active so is the Oculus App on PC, The VR and the APP have latest update. Have no idea what to do?

Try the troubleshooting steps on our website:

I was using a Razer Mini keyboard where you have to use a combination of a FN+CTRL+F1. I have re-connected my Logitech full size keyboard , active OXRT and Oculus App, Wear Quest 2 and switch to PC mode. Key CTRL+F1 and still NO settings window box appears? I really don’t know what the problem is, but this Open XR Toolkit just will not work for me? Help Please!

iirc it’s ctrl+F2 for open xr toolkit menu. check what keybinds u have to open the menu (it tells u towards the bottom of the open xr toolkit gui). u can change the keybinds, try changing them to something simple like enter, just to test.

Have you looked at the rest of the troubleshooting instructions, like the one that says you should try different bindings from the companion app?

Also, just to be sure

  • you’re looking into the headsets? Menu wont appear in mirror window
  • your FS window had the keyboard focus

I could be wrong, but this sounds like it could be similar to issue #363 posted in GitHub, which also used a Quest 2 headset.

@ExceededBull193 by any chance are you using the SteamVR runtime in SteamVR–>Settings–>Developer–>Current OpenXR Runtime?

Are you using Virtual Desktop?

If you still haven’t solved it, does it work if you revert to version 1.1.0?

Yes, I tried all the F keys. I will change the keybinds to another key, and see what happens. I am sure I can work this out. MSFS looks good in VR without the extra OXRT settings. So with this, it should look and perform superb.

My MSFS is not a Steam purchase, but MS Store. Yes, using Virtual Desktop.

Checked and tried all the settings, from the troubleshooting guide. Open XR Toolkit refuses to work for me. The settings box will not appear. I have just about had enough of this useless piece of software and I am loosing my patience with this. Have to play MSFS VR without it. It already looks and runs quiet well in VR.

Lol nobody forcing you to use this. Please walk away I don’t need users like you.

3 Likes

Yes you are right, this is likely the issue here too, thanks for pointing this out. That issue is in the works.

1 Like

Sorry, I didn’t mean to offend. I was in a bad mood when I composed last post. Please don’t be too harsh. I will keep the Open XR Toolkit active while in MSFS VR. I assume even though I can not get into settings, OXRT will use the default settings, and should improve the visual and performance in VR. Hopefully, I will find a solution.

Tried to open the log files, but comes up with a error? Unable to locate? Checked 'Users/My Name/AppData/Local/ But there is NO Open XR Toolkit log folder? Something is very wrong here. Maybe I should un-install OXRT, and re-install? Also, does it make any difference if I am using Quest 2 Air Play, or via the link cable? I have never been able to use the link cable, as the PC and Win 10 and now Win11 will ‘Not recognise the device’ (Quest 2). For a very long time this has never been resolved, despite loads and loads of requests to Oculus Support and to Microsoft support.

Sad (and pathetic) to get such a response as “LOL, I don’t need users like you…”. You said what you did and in my eyes there’s nothing at all incorrect about the statement. Does it work for you? No? Then it’s useless software for you, isn’t it? If it worked, then it would be useful software possibly. That’s my take anyway.

I’ve followed others on this from youtube videos to other forums and exhausted the troubleshooting mentioned on the site. It doesn’t work for many people either, and same with no folder being created in my local folder where it states the log file should be. Tried installing as admin, even from cmd. Many other things that’s too much to type but to generalize, if the app is being blocked from creating a log file or the folder for that matter, the initial case is typically a rights/security issue. I don’t have that issue with any other app writing there so to me, it looks like the script isn’t working for all, or it’s not a feature meant to work.

Again, nobody is asking you to use this software - that was my response (which you did not even quote properly, my guess in an attempt to make it sound worse than it is). Here you are complaining as well, but not making any effort to provide any kind of constructive and actionable feedback. Hence I don’t have interest to support you.

2 Likes

I have a Quest 2 and Open XR works with Airlink.

Use CTRL Key + F-Key to move about and make changes to the settings.

If the instructions shown here aren’t working for you there is also a Discord server that has help and support.

Don’t give up… it’s really great software and you’ll get great benefit from using it.

Good luck!

2 Likes

I have exactly the same problem.
Hours spent in rehearsal, and to no avail.
There is no chance that the OpenXR Toolkit window will appear in MSFS.
Maybe some other ideas ???
Everyone can be helpful …

Check this companion thread to see if any advice offered there helps…

1 Like

Nobody is asking you to reply to me, nor provide me feedback. I was replying to person you whined to, not to you. Carry on. As I said, I am following other’s with the issues on several different sites. All of which followed your trouble shooting and still have no resolve. If I couldn’t understand something you already wrote, I would ask you. If I didn’t already see the FAQ, I would have contacted you. I am not asking you anything.

Thanks!

If you haven’t already, be sure to check all the key bindings in MSFS first. The CTRL + F keys are all taken already, so you’ll need to first remove them and then validate. Then be sure to apply.

I never got the menu in the OpenXR demo to open, and it never created a log or folder where it says it does, so my issue may be different than yours so I’ll cross my fingers for ya!