PC user with Gamepad (xbone) issues

Been using this sim with a controller since it released last August with no issues. This update has screwed up a lot of things and has made using a gamepad in combination with mouse controls unbearable.

The hud being one big annoyance. With no way to disable the dumb little cursor dot that pops up while free looking with the Right stick control. Vibration also seems unable to function at all. The only thing that made using a controller somewhat bearable was switching the ‘Cockpit Interaction System’ to ‘Legacy’. Which disables the horrid text pop-ups that display all over when free-looking with the right stick.
There also seems to be an issue when trying to pause with the controller and everything flickering like mad.

Hoping for a revert function for gamepad usage on the PC. Especially the annoying cursor dot triggering with right stick movement.

I have the same problem with the dot. Is your view also reversed? When I look left, the game looks right, vice versa. And also drifting. If I don’t touch the controller, my view will slowly drift up down left or right.


Yes I had to go into the profile I had saved and check the box to “inverse” it. which corrects it.

In my case my Xbox One Controller (bluetooth) is now not recognized after today’s update.
I think updates should wait until all these problems are solved, otherwise I feel like a betatester.
Anyway, I can not fly until my controller is back again.

EDIT: I have manage to recognize my xbox controller using the usb-c cable instead of bluetooth.


I would also like to point out that hovering over the throttle, propeller, or mixture control no longer tells you a percentage, even on Legacy mode. Which is also frustrating.

1 Like

Yes I have the drifting issue also, using the xbox controller to manipulate my views and for the drone cam - but the drifting only occurs in cockpit view. If I hover over an item with the mouse the drifting stops…its like the camera is continualy searching for something.


I’ll try to hover over an instrument in cockpit. Thanks for the tip!

Hovering didn’t work for me. I also turned off all assists. I’ll just wait till this white dot drift thing is patched.

But I still manage to score over 1,000,000 for the Denver landing challenge.

I’m having the same problem. the only thing I use the xbox controller for is view, so for now its back to holding right click and using the hat on my joystick. Its kind of annoying, I enjoyed flying around with the xbox controller in drone mode when I landed somewhere neat and for now that’s no longer possible without a drifting random view when I go back to the cockpit.

To fix the drifting - simply bump up the deadzones of your Controller a little. That has worked for me and stopped the drifting instantly. If anyone has a Solution for the Dot, that would be amazing!


Cranked up deadzones, did not work for me.

I think I found a fix, instead of having the right stick as axes I assigned it so cockpit look up was rightstick up, etc

that seemed to get rid of the problem, but the stupid white ball is still in the middle

1 Like

Asobo should be ashamed of what they’ve done to the pc community. My xbox controller is worthless now as they’ve changed my button config without asking, then when I reprogrammed it, ■■■■ doesn’t work. An example would be the smartcam’s while in cockpit view. Before the update, left / right on the directional pad was the default for bouncing around each of the pre-defined views in the cockpit.


Yup, on PC here too. The cockpit drift issue with an Xbox controller is driving me crazy. Hopefully they release a patch for this soon.

1 Like

This does indeed fix the drifting issue! If you remove the assigment to Cockpit View Yaw Axis & Cockpit View Pitch Axis and assign the Right Stick to the screen shot values by jonasbeaver you’re good to go. Still have the white pointer but can live with that for now. Looks like Gamifying a Sim isn’t straight forward…I think its great that its on xbox but they’ve messed up the controls and added a load of assists on by default. I’ve removed the “helpful” hints but the ATC seems to want to be on AI Controlled by default no matter if I turn it off. Hotfix inbound :rofl:

Bombard them with Zendesk bug reports and upvote these threads!
They just made the game unplayable for a vast number of paying customers on PC, just to push that bloody Xbox release out the door.

1 Like

Just realized that Controller Vibration is completely off as well.


i was hoping for a enjoyable experience upon startup, but this is absolutely hilarious. my mouse is constantly flickering and doesnt even react to anything but menus, cant even click buttons.

SU5 = Frankenstein’s Monster of updates…

1 Like

Set the Cockpit Interaction to “Legacy”, Menu-Quick Info to “OFF” and Instrument Tooltipps to “OFF”. This is how I fly. Should be working then.

1 Like