Performance Degradation with 1.14.5.0. Upgrade

Question now becomes how upset is Aerosoft going to be that they release the CRJ in the middle of this mess. Does not bode well for the confidence of 3rd party developers

6 Likes

yup, for me it’s all around London and even above the North Sea into Belgium. Sometimes to the point where I feel like getting a CTD (as was the case for a long time - so that got better :smiley: )
LOWI (I fly VR at LOWI) seems alright. And I experienced nothing at all around KATL and KMCO.

Okay, did as suggested here, put my DA62 at 76T on the runway and oh dear, oh dear… My sim was hardly working. Everything was EXTREMELY sluggish and slow. As a matter of fact, could not even start the dev mode because the menu was jammed. Had to then close the sim from task manager. From the task manager I noticed that the sim was using almost all the memory from my system. So I would say that we got some serious memory leaking issues going on here.

My system:
Ryzen 7 3700x
16Gb Memory
GeForce RTX 2060 Super

I have been flying only in Europe and have never encountered that kind of experience. My two cents to the issue, hopefully we get a hotfix soon.

4 Likes

Exactly - I have read elsewhere Aerosoft dont believe its an issue - but I cant believe its not going to impact their sales if there is a certain percentage of users who think their money will be wasted with poor performance in certain areas especially on landing…

I agree there may be some who are less affected, due to possibly highest end PCs or minimal settings etc etc.
I for one was almost perfectly happy with MSFS until the UK Update…that caused quite a few CTDs even though I never fly in that area.
Now 1.14.5 it’s another degradation of the sim. I can fly for 25-30 minutes and then it starts to stutter and occasionally become completely unresponsive.

This is honestly the worst FS I have ever had and I have literally had them all. And what really makes me angry is that it is getting worse every time there is an update. Not one of those mandatory updates has actually improved anything for me.
Not a single GA aircraft, not the scenery, not ATC …nothing.
The so called fixes usually have made community modifications unusable that actually did make the included GA aircraft like the DA62 many times better than what we all got from ASOBO.

Graphically it is stunning…and it does have the potential to become the greatest FS ever…but unless someone finally takes the reigns who actually knows something about software development this is going to be the greatest failure ever.

Any other software I would simply roll back and use an earlier build “offline” if I had to until a real improvement is realized by the developer. Here I am forced to download “updates” that make at least for me, and apparently a great many others, the whole thing unusable OR I can chose not to use software I paid for (120€) until it is finally somewhat usable again.

2 Likes

I believe, I swear, that the problem lies with the servers. Where I encounter problems, normally changing servers makes things better, even though it is a server with higher latency.

PLEASE GO TRY 76T and REPORT YOUR FINDINGS

Airport 76T, RW35, Stock C172, clear weather, no multiplayer, 12 noon…

Ultra 1440p: CPU 10%, GPU 5 %, RAM 20 GB VRAM 5G => 2 FPS

  • i7-9700k
  • RTX 2070 Super
  • 32 GB RAM

Yes, I confirm there’s a zone in between 76T, T76, and KLUD that acts like a “Bermuda Triangle” for the FPS

I have FPS = 35 outside this zone

When I enter this triangle, I drop to FPS = 2 :upside_down_face:

First working day for the week is almost over and there is still zero communication.
Unbelievable

10 Likes

76T … 2 FPS !!!

A catastrophy, i’m barely able to clic on Ready to fly and it’s in the middle of nowhere.

Ryzen 9 3900X
RTX 3070
32 GB RAM
1 TB NVME

Asobo is 8 hours ahead of us…Amazing…

2 Likes

Lol I tried to depart from 76T, it loads, but I can’t click the ready to fly button, fps is below one. 30 frames per minute perhaps.

RAM isn’t taxed, 16GB allocated, just under 7GB working set, GPU 4.8 out of 6 in use. CPU at 20% use, GPU switching between 0% and 30% use, nothing is anywhere close to being taxed. GPU is only 47c, CPU 52c (normally in the 70s). It’s just not working.

Finally managed to ‘click’ the ready to fly button, it’s ‘running’ at about 20 frames per minute, 2 frames at a time then pause, repeat.

Killed the process, restarted with dev mode on


That’s the two states it switches between, 30 frames per minutes not 12 fps.

It’s their normal (non)communication approach - do you remeber:

  • terrain spikes?
  • shoreline glitch?
  • tree draw distance degradation?

Can confirm around 2FPS at RWY35 of 76T airport. So should be almost for sure reproducable for ASOBO. Someone reported this exact location to Zendesk? Yesterday i’ve found also one in Japan near Tokyo, RJAA, about one minute after takeoff with A320 - drop to 2fps, then back to normal when owerflown this area. When turned back to RJAA, 2fps back above this area.

Yes someone did:

1 Like

@SteveX77

I just did in my ticket marked as solved, perhaps they read … but I think the “customer advocate” is more a MS advocate than a customer one.

Last Wednesday I created a Zendesk ticket for this major performance problem. It is still open today. This means that Asobo knows about it. Since the ticket wasn’t closed right away, none of their standard solutions fix this problem. I have no other status information.

I couldn’t care less that the CRJ is coming out tomorrow. I’m not buying any 3rd party content as long as their builds yield an unplayable sim like this.

6 Likes

Btw. Right now, when proceeding the RWY heading 350, after couple of minutes of unbeliveable pain :D, stutters suddenly disappeared, I’m back in a very smooth simulation. Will try to head back to the RWY 17 and will see whether 2fps mode returns…

Confirmed - turn back directly to the 76T and after couple of seconds 2fps is back.
Conclusion - it’s definitely some strictly terrain / specific area based engine glitch!

2 Likes