PICO 4 - My test is over, here are the results

Not had any SteamVR crashes changing DLSS settings in the Pico 4.

When trying DLSS Performance mode for highest FPS you will likely need to lower TLOD and OLOD to take some load off the CPU when you get main thread limited.

Yeah I did try that, helped a little

does anyone know how to recharge it while the sub type-c/rj45 cable is connected to the modem? I bought the whole 100w kit but if I attach the charger to the hub it doesn’t charge, I have to unplug the cable and put it in charge

You need a RJ45 to USB-C adapter with an additional USB-C charging port, where you can connect the charger itself, or a powerbank.

Is there haptic feedback on the Pico Controller when turning dials or pressing buttons in the cockpit?

Thinking of switching from the G2 to the Pico so this thread is extremely helpful!


thanks for your post, I don’t achieve to run MSFS in openXR, it shows openVR in HUD perf.

I had a G2 and no oculus, maybe I didn’t install something ?


Hey man. I’d like your advice. I am having a severe abstinence syndrome since i sold my G2 lol :slight_smile: I made a huge mistake selling it, despite all the grievances with the wmr platform. So after your experience with both the pico4 and the g2 and considering i’m using a 3080ti (can’t afford any 4xxx upgrades atm) if i have to pick between getting a pico4 and G2 (v2), what should i do in your opinion?

Ofcourse, if someone else can provide opinion, i’d be grateful as well.

Ok it works, it launches steamVR, but I can use OXRTK finally, so openXR is running even if openVR is written in HUD

1 Like

Definitely the G2 overall for MSFS. The Pico is unfortunately not usable for MSFS for me as I can’t hit a steady 72fps unless I go DLSS Ultra Performance which makes everything look like garbage, and I can’t stand repro. Although this may improve with the 7800x3D soon, as paradoxically it’s the CPU holding me back at higher resolutions.

And 45 fps (at 90hz) is nowhere near as smooth as on the G2.

On top of that the compression is very noticeable on the distant details etc., and battery only lasts about an hour when streaming via VD (although this can be improved a lot by plugging it in, though it doesn’t hold the charge) . It’s a cool headset for other PCVR games and for the price though, and the lenses are great.

But yeah, daily MSFS driver still G2. If I was looking to buy a new HMD right now I’d look into the Quest Pro probably, although that’s still streaming, but much higher Bitrate via cable. But it’s supposed to have insane clarity and feel much higher res than it is.

Hard for me to justify a Varjo having already spent 2K on a GPU recently, plus you need basestations etc, and it’s not an impressive FOV.

But I don’t think I’m making another big investment into an HMD without displayport.


Yes I believe there’s a mild vibration

Thank you. That is very informative. I think i’ll go for the g2 v2 for now.

Since SU12 it actually feels smoother too! Several others have said this too. Not so plagued by the stutters recently.

Tried out 60hz mode again the other day just to see again… While the flickering is unbearable for me, it shows so much potential. I can easily get 60fps locked and it just looks insanely smooth, no stutters at all and SO fluid. Can’t wait to have the hardware to do 72fps locked with decent visual quality, on whatever headset.


I would go with a (used) G2 V2 :slight_smile:

1 Like

So I picked up a Pico 4 at a great price new off eBay.
All set up but I cannot get VR to start in MSFS at all. When I switch to VR, MSFS hangs for a bit then I get the following error - ‘The initialization of VR failed. Please check that OpenXR is installed on your computer and your headset can use it.’
I’m using Pico’s streaming assistant for the moment and SteamVR - confirmed SteamVR is the active runtime under Advanced settings. If I quit SteamVR, MSFS will respond again. Tried various things like reinstalling SteamVR, GPU drivers etc. but still no joy.
Tried it with XPlane 11 and VR worked first time so assuming the error is between MSFS and SteamVR.
Does anyone have any idea where the issue lies or anything to try? I’ve read through this thread and there is some great information being shared but I haven’t seen anything that has led me to a fix yet.

Sorry I have no experience with the Streaming Assistant at all. Only used VD, which worked right away (though “getting there” took some getting used to!).

Did you have another VR headset installed before?

Nope, this is my very first headset. Streaming Assistant appears to be working fine though given I can see my desktop fine through that and SteamVR. It’s when switching to VR in MSFS that I’m having the issue.

Forget SA and just buy VD. SA is really ■■■■■■ for msfs.

Never used Streaming Assistant so I really can’t help. But ditch it, the quality isn’t even in the same league - VD is the only thing here.

Yup, I’m fine to purchase VD, I just didn’t want to purchase without first making sure I can get VR working correctly with the headset. Need to try and track down why VR is not kicking in yet. :frowning:

It might be related to the streaming software, anyway.