Pimax users: OpenXR is here! (unofficially)

Hey all,

I’ve been a proud owner of a Pimax 8KX since Tuesday. Big thanks to Pimax for sending me a headset!!!

I thought I would share a project I’ve initiated: giving you a sneak peak of OpenXR native support with Pimax headsets!

Current version: 0.2.0 (download from this link)

What is it?

It is an unofficial OpenXR implementation (runtime) for Pimax headsets. It uses the Pimax native SDK (PVR) directly and bypasses completely SteamVR. This is comparable to what other vendors (WMR etc) do.

By bypassing SteamVR, you are removing some extra overhead and hopefully getting better performance and improved clarity.

Is it good?

I don’t know yet. I’ve had my Pimax for less than a week, and I haven’t even started SteamVR with it :slight_smile: so I can’t compare. But so far a handful of testers have been very happy with it! One user claimed +10 FPS in MSFS and less visible culling. Another user claimed +10-20 FPS in DCS. People reported better motion smoothing and overall visual quality.

It is not a fully compliant OpenXR implementation, it just has the bare minimum to run some of the star applications and games.

What should I do?

Read the instructions carefully on the release page! This is still very experimental software. The installation should be straightforward (just run the installer program).

To confirm that it is installed properly, you can use the OpenXR Explorer, and confirm that in the left pane, under runtimeName you see something like this:

image

You can also use the PimaxXR Control Center app (from desktop or Start Menu) to toggle runtime:

image

If you are having issues, please join the OpenXR Toolkit Discord and head to the #pimax-technical channel.

Are the options in Pitool still working?

Yes they should! Even though the options in Pitool say “restart SteamVR” etc, they still work with this OpenXR implementation.

Is it compatible with other games than MSFS?

Yes it works with a handful of other games though OpenComposite, for example DCS and Assetto Corsa.

Is it compatible with your other project OpenXR Toolkit?

Yes, it is now compatible with all versions of OpenXR Toolkit above 1.1.0.

Why are you working on it?

Mostly for fun :slight_smile:

I saw a gap with the absence of OpenXR native support for Pimax, and when I looked at the Pimax native SDK, it looked pretty straightforward and fun to implement OpenXR on top of it. I have a weird definition of fun :rofl:

Also, it is very important to me that the community and developers get invested in OpenXR! It’s the future or AR/VR, and it is super simple and powerful!!

So far, I have spent the equivalent of about 4 days of work on it, so it’s still very preliminary. I don’t know where it is going :slight_smile: it certainly looks sufficient as-is to do plenty of stuff already!

10 Likes

Amazing! Went from 38 FPS to 46. goodbye SteamVR!!

1 Like

Theres a bug sometimes when you enter VR before loading a flight (ie in the main menu) where the image in the headset freezes right at the end of the loading screen. Simply leave and re-enter VR with Ctrl-Tab to unfreeze it!

thx, will test it next days :slight_smile:


Edit:
@mbucchia - The installation and use of the runtime in the FS ran without any problems. I’m guessing the pimax culling hack only works with SteamVR right? At least it’s back with the runtime for me.

To the FPS. Since SU09 and with the bad servers this days we can only guess. The burglaries since SU09 were massive (-20-30% for me).
In this respect I only have an A-B comparison to with friday, AI traffic off. Live weather disabled in the data and only clear skies (otherwise use Rex), same area, same plane.

My FPS got worse. Dropped from 36-40FPS to 26-29FPS. I didn’t get micro stutters, this was nice.

However, I have to say that my computer is optimized for VR and SteamVR runs on its own cores anyway.
Also roughly corresponds to the experience I had in DCS via the Ocolus Runtime with the OXR Toolkit. Didn’t bring me an FPS gain compared to other testers. (I have there with SteamVR 68-85FPS, via Ocolus around 70 with the same setting)

(Win10 / 10850k @5.1 / TitanRTX Hardware full unlocked (between 3080 and 3090) / 32Gb @3800cl16)

Right now OpenXR Toolkit is identifying Pimax using the runtime name, which is different with Pimax-OpenXR. I have to change this in OpenXR Toolkit, but I have already confirmed that the hack still works.

For your performance, will likely need some data from the OpenXR Toolkit overlay to understand the difference. I think so far out of maybe a dozen users, you are the only one reporting loss.

yeah, the overlay is not readable , only the FPS Counter on the right eye :frowning:

Ok, then maybe when I manage to get newer OpenXR Toolkit to work (which had proper display of the menu/overlay and even adjustable overlay, but currently not working for other reasons.

2 Likes

Small addendum, I tested it again with Large-FOV (before Normal). Here the culling is almost gone and the FPS seem to be slightly better than before. But now I can’t see the counter anymore.
Maybe 25 or so.

Edit @mbucchia I balanced OXR something with Lasso and lowered the render resolution from 30xx to 24xx pix vertically.
That looks pretty good. Could be a little over 30 FPS. At least you can now play FS with full FOV. That wasn’t really possible before.

I cant get Pimax to work with MSFS2020. Tried to go in ,and within a minute or so at the gate, I get a CTD- 3X’s in a row. One time, it looked like it would work, but the screen went orange, THen black, then CTD.
What is the sequence to get Pimax ( 8KX) to work?
1-PITOOl on ( Should it be on Home Experience option)?
2-OPEN XR ver 1.1.0 on
3-Open MSFS -start at gate
4- In PITOOL, do I option PP on? , Smooth ? 90Hz, Normal …
5- I then Go VR and I get nothing but CTD,s…
What Am i missing / doing wrong/ ?

Sorry but this is not clear from your message. Are you trying with SteamVR as your back end or with the OpenXR runtime I published?

I have a Pimax 8k I will try in the morning , this sounds great! I do have an issue with the open xr menu is way off to one side with previous versions so maybe this will be better?

Thank you in Advance for making all this possible.

The OpenXR Toolkit menu will still be broken since right now it only works with version 1.1.0. But I will release a fix tomorrow to fix that and enable 1.1.3 which has the fixed menu for Pimax!

2 Likes

Dont forget too sleep! :beers:

If you ever come north to Surrey Stop in for a road pop!!! Try my 6 DOF… LOL

Thank you

Matthieu: I am using your Pimax-OpenXr addon, and NO Steam VR… Should I not use the OpenXr 1.1.0 toolkit?

I haven’t tried yet but many thanks for improving our experience with the 8kx.

Thanks for confirming. I just wanted to confirm that this is using Pimax-OpenXR. What you are doing seems correct.

I don’t know about the CTD, but I would certainly say let’s try without OpenXR Toolkit and see if it makes a difference!

Well, Tried this morning- without the OpenXr toolkit 1.1.0
Worse! Left eye turned orange, ight eye black. ten , CTD!!
I dont see where the PIMAX-OPENXr is running… there is no shortcut or .EXE file to click on. I look in TASK MANAGE and it doesnt reflect running.
Im just beginning to believe I wasted money with this PIMAX… I have not been able to fly one freaking time!

Hi,
You may want to try this new version:

I tried the previous version 0.1.1 and I had my best flight in MSFS with my Pimax 8kx. Just a little culling on the sides when using Small FOV in Pitool. After switching to Normal FOV in Pitool, the culling was almost gone.
Going to try Pimax-Open XR 0.1.2 now. Will update my findings.

Edit:
Just tried v 0.1.2 and my personal observation is that I find v0.1.1 better. With the older version I had less culling and overall slightly better performance in MSFS. Just my personal 2 cents. Will revert back to v0.1.1 for now.

1 Like

You might want to visit the official pimax forum for basic help. Seems there are a few other things to fix first.