Playtime gone missing [Packages out of date]

I was in between flights, working on “Jack of all planes” achievement. Since I was frustrated for being stuck on 90%, I was trying some Deluxe and Premium planes, like the C172 steam gauges and DA40 steam gauges. The message “your data is out of date” showed some three times, in different moments. The first I don’t remember, but the following ones were when I noticed the sim was off-line. Once enabling server connection, the message showed up.

I was using pms50-gns530 GPS mod and have several others installed, like Working Title, Fly by Wire and others.

Even now, having lost all my flight log data and 4 whole days after this thread was started, I am still
getting ‘Your packages are out of date’ messages!

I feel that at this point it is not unreasonable to ask what on earth - if anything - is Asobo doing about this? Because the response has been, well, lets be honest, glacial.

Why oh why do we not have full control over our own Log books? And by that I mean log books that are stored locally. Log books that can be auto saved and auto backed up locally.

My suspicion is that MS/Asobo see MSFS 2020 as more of a game than a proper flight simulator. Why else the obsession with so many unnecessary stats that do little more than engender an out of place sense of competition.
That said, I would find it easy to ignore all of these more …juvenile elements to the sim if MS/Asobo would only relinquish their ‘Big Brother’ like control over my log book.

Sorry all.
Forgive my rant.


Hey guys,

I just joined the club today…lost my 350 hours…really got frustrated…

Why today lot of products sold are not finished without bugs ? Pandemic side effect ?

I think that one is pretty obvious. The Steam store has managed to gather an incredible number of fans through a similar achievement framework that some people seem to get totally obsessed by. Microsoft are just trying to emulate a proven to be successful store model that worked elsewhere. Does not appeal to me personally but I can see why they did it.

As for the bug, it does seem to be triggered by temporary glitches in net connectivity.

I would suggest signing out between flights (if you are lucky enough to have no bugs yet) to reduce the time you are logged in and hence reduce the chances of a glitch. In particular do not wander off to watch a movie and leave the sim running that is asking for trouble :smiley: If your on a long flight on autopilot consider using acceleration, again to reduce the chances you are logged in when the inevitable net glitch occurs.

I use carefully considered phrases like “My suspicion is …” because I don’t want to be seen as reacting in a ‘knee jerk’ or controversial kind of way.
Nor do I wish to be sanctioned by our hard working moderators!


Hi all may this can help somebody:

So, basically you click “NO” repeated times until you managed to get your way into the options and turn online data back on, but only then you click “YES” the next time the windows appears. Good to know.

I got the “packages are out of date” message overnight at some point.

Was doing a long-haul from Zurich to Anchorage and slept in the cruise so I have no idea when it popped up.

I was about 1hr from landing so just clicked no.

After landing I went back to the main menu and noticed the marketplace was greyed out. Closed MSFS and opened it again and now it seems to be going through and redownloading the whole thing??

Really really poor user experience Asobo…

Hi @Jummivana,

Any word of Asobo heard regarding this thread?

Kind regards


We’re sorry to hear that you’re having trouble issues with the logbook.

We are currently investigating this issue.


At first I managed to get everything back with the suggestions in this thread. However, after another short internet disruption while being online, the message came again, and now I also lost my logbook hrs. Not that I care, but still a strange bug! My other settings seem to be OK.

This kind of mistake has been made for several days. My more than 200 hours are gone. Doesn’t asobo watch the community? So community existence is meaningless. Why is there any mistake that has just been opened and there is no official explanation and reply

Mate, this started ‘after’ I did those 3 updates. At least Asobo have something to go on with 600+ posts…
Right now I can continue enjoying the sim but the hours etc will start again, so my issue is; Do I continue playing, or wait for a fix, hoping that my data is recoverable.

242 votes… seems affected are not all users and may be therefore they need time to find out “why it happens”.

1 Like

Like the performance issue a month ago which also affected only “some users”

1 Like

Same for me. After some update “your data is out of date…” game reset my play time, my progress landing challenge, my achievements progress and resets some settings (language (from Russian to English), some help (cities mark, airport markers, some on-screen help was turn on)).

Same here, I got the message first friday night. I updated the US content in content manager, and bang, my 250+ hours were gone. But not the 300 hrs ‘next achievement’. Yesterday I also got this problem, maybe related, maybe not. Logitech Flight controls CTD or as soon as I plug them in - #3 by FLAVIOR8LIX

Am hoping that we get some form of response today. I posted on Zendesk, but yet to hear. Last Friday, thinking it was my error which caused the Packages being out of date, and that I could find no immediate fix online, and no comment from Asobo, I uninstalled MSFS and then downloaded a clean copy. I got the same error (of course), but even after signing out of xbox and signing back in, plus deleting xbox and reinstalling, and using all the ideas above - I am still “Out of Date”. Further to that all the additional content following last years release (Japan, US, UK etc.) are now missing from my content manager.

Please Asobo fix this. I have been an FS user since FS4 (plus ATP and the A320 boxed sim) and in 29 years have never experienced this sort of Online/Server issue (I miss disks). When I purchase a product a expect to be able to use it! I look forward to you fixing the current issues at the earliest possible opportunity.


I dont if they’ll respond, is their Chess Tournament over? Someone posted a link to Asobo’s (redit of facebook) page dont remember which where there was no mention of the bug, but had the results of the in house chess tourney they had on Friday (hmm same day this all started).

But you know you could tell from the pictures that the staff at Asobo look really stressed out (Not) so they must me at least thinking about it…


Each time a major issue crops up Asobo is silent for days or weeks investigating. My suspicion is that all hands are on deck with the move to XBOX leaving only the CEO and his skeleton crew to deal with the live build.