Please fix the windshield cubemap reflection

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?


Brief description of the issue:

The horizon reflects in lateral windows very intense or when it shouldn’t. We can’t lower cubemap intensity for windshield and we can’t see the terrain in some ilumination conditions. And when you pitch the plane more than 20º, the horizon reflection should be blocked by the interior cabin. I´ve tried to change the options directX, windshield efects, cubemap reflections, and raymarched reflections without success.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Turn to the left or right in different weather and time conditions.

PC specs and/or peripheral set up if relevant:


Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I’ve tried to disable it but the only solution i’ve found disables all reflections in windshield. There’s no way to reduce it a little bit, alpha 0.01 is the minimal.

This example is 0.01 and 0.0:

Does anyone see this efect correctly on their computer?

Voted. These reflections are hideous and often ruin the side view. Please fix.

1 Like

Does this happen with default aircraft (no mods) and if so, which ones?


Some planes are more affected than others. This is most often seen on dusk/dawn when banking the plane.






Thank you!
Will check these out.

hey soccorista, could you explain how you changed this alpha value of the cubemap to 0? i’d like to try flying like this myself, i prefer 0 reflection to anything else. where do i have to go to change that setting?


As always the first is to make a copy of any modded file, a simple wrong character will crash your sim.

-Open with notepad the planeModel_Interior_LOD00.gltf.
-Inside the .gltf look for: {“name”:“WINDSHIELD”
-Inside it look for: :{“baseColorFactor”:[1.0,1.0,1.0,0.01]
-Delete the last “1”

The disappointing of this is the gauges glass reflection also disappear :confused:


1 Like