Please insert the MSFS Game Disc error message

Hi all, this is not caused by MSFS2020 but because live.com signin is not working right at that moment. Look at this, happened when it occurred to me. Microsoft's latest cloud authentication outage: What went wrong | ZDNet

1 Like

MODERATOR EDIT: The following 3 posts were merged into this topic.

Appeared on FS start. There were no updates since last time started FS. The only difference is I have a Jabra Speak 510 connected with USB, but I quit and started FS again and the message didn’t appeared ever more.

Hi.
Very frustrating, I am sure.
If it is of any help, the only time I get that message is if I fire up the sim having forgotten
to connect to the internet first.

Good luck.

Here are reasons why this message may appear:
https://flightsimulator.zendesk.com/hc/en-us/articles/360015985699-Error-message-Please-insert-disc-

I also guess either you were not connected to the internet or the XBox servers were not accessible for some other reason.

1 Like

Coppersens has provided the correct answer.

Thank you both, captainLIF and Coppersens!

I kept getting this, then noticed that my local time was 9 hours out of sync :dizzy_face: put that right and it worked phew!

Received the same message today. Was using the sim just last night. Now I don’t have access to a program that I paid for. Tried every possible option, from adjusting time zones, to resetting X-Box networking, to making sure the Digital Ownership is installed and very other solution I came across, and I JUST USED THE SIME LAST NIGHT!

It’s so frustrating!

Reformatting the entire system and going back to P3D!

Now I remember why I haven’t used the sim since December

1 Like

Sometimes there are outages of the XBox Live network. This might be one of those occasions.

i have tried all the steps and nothing is working. Just rant he update last night and now for the life of me i cannot run the game it just wants the disk everytime

After weeks of trying to fix this issue, I finally came across a solution on AVSIM that worked for me. It is covered briefly in Coppersens post above.

  1. Reset Microsoft Store
  2. Reset XBox
  3. Ensure you have XBox Netwoking showing as connected, otherwise select fix.
    In my case 3. was the issue, not sure if 1. & 2. helped. What is bizarre is that I never have used XBox so I don’t understand why this setting caused my issue. Secondly, once I had access to the game it then went through a complete download of Game Update 4 plus all the updates in Content Manager, despite the fact that I had already updated this previously. It seems it’s another flaw in this game, shame really as otherwise an excellent sim.

Today I can’t get to the FSFS, it prompts me to insert the game disk???

i also had this today however it was my internet that was down

Yeah, check your internet connection

I turned off my firewall, and the insert disc message went away.

Good luck.

FYI I had the same issue, it was caused by PiHole domain blocking.
I had to run live diagnostics on Pihole while starting MSFS to isolate the list of blocked domains that was causing this.
Once whitelisted, the error was gone (sorry can-t remember which, but in my case it was a single domain for sure).
Hope this helps someone.

I run a Pihole as well, and have not seen this. Had you perhaps manually added the domain you had to remove?

Well the way Pihole works is one has to add lists of domains that are considered annoying for various reasons :slight_smile:
I used https://energized.pro/ lists and others. For sure this particular domain was blacklisted, it must have been included in one of these lists.
Bottom line as soon as it was whitelisted, MSFS stopped asking for a disc.
Hope it helps.

I didn’t have this problem, so that’s why I asked if you had added it.

Maybe you could tell us, which domain it is so others facing the same issue and using thr same lists could benefit from your finding.

I’m using the default blacklist on the pihole and it doesn’t cause any issues.