Please insert the MSFS Game Disc error message

Me neither.

1 Like

Well I currently have more than a million domains blocked in my Pihole, all ads and security or privacy related, including telemetry, so I am not at all using the defaults, just open source lists like the one I linked above.
Sorry I do not have access to my computer at the moment and I do not remember the exact domain.
What I did is ssh into the pihole server and run the following command to find out:
pihole -t | grep 0.0.0.0
and launch MSFS2020 at the same time.
I recall there were 3 or 4 xbox / MS related domains that were blocked, I tried them one by one, and sure enough one particular domain was the culprit :slight_smile:
No more “insert disc” after whitelisting that one :slight_smile:

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes (even though if you lads need people to recreate their WORKING sim setups after every update, ya might wanna rethink the whole update process)
Are you using Developer Mode or made changes in it?
No.
Brief description of the issue:
The 120 quid game I bought doesn’t work after an update again.
Provide Screenshot(s)/video(s) of the issue encountered:
tedious
Detail steps to reproduce the issue encountered:
Step 1. Pay a decent chunk of change for a game.
Step 2. Play it off and on from launch, because of the broken state of the game (and that half the time the game that’s supposed to auto-update itself… .DOES NOT so you discover that you have to download 10-20 gigs of data to even get to the main menu)
Step 3: Try to play the game after latest update and get an “insert disc error” for a digital download game
Step 3.5: Get increasingly irked about the whole thing
Step 4: Try the various “reset this, redownload that” non-fixes listed in the FAQs, before either re-downloading 130+ gigs of data (which gives you a 50:50 shot of fixing things) or move on to a less broken game
PC specs for those who want to assist (if not entered in your profile)
Not applicable, as the issue isn’t hardware related
Did you submit this to Zendesk? If so, what is your ticket #?
Not this time

1 Like

I’m getting this with the latest update. Did you resolve it?

I got it this morning when I updated before work. I restarted everything as soon as I got home and it appears to load fine.

In my case, the game started working after restoring my machine using a known “good” drive image, which seems to suggest that somehow the initial Windows Store update randomly corrupted the base game (or its registry settings), because downloading the same update on the same laptop (after applying the system image) went without a hitch.
Hell, while I was doing that, I tried installing the game on another laptop (basically the same machine, inclduing the installed OS image, but with a slightly inferior qRTX4000 GPU) and it worked as well, which ruled out xbox live / win store issues and/or firewall/router misconfiguration

I got one. I closed the program and started over. It did not reappear.

I get it quite routinely.

The “Insert disc” is a very misleading error message which gives to the software the appareance of a bugged thing. Of course, it has nothing to do with the disc, I purchased the downloadable version because my computer doesn’t even have a DVD reader.

To fix this, I have to quit MSFS, logout from MS Store account and then login again (of course I was already logged in fine before). Other users reported that quitting MSFS and starting it again, will fix this too in most cases (just “try again, you will be more lucky”). I also read somewhere that may be useful not running MSFS as soon as the computer starts, because MSFS may try to check for the license before Internet is ready and the computer actually connected.

I just wonder why, if this isn’t a DVD version, the software will not simply ask to reconfirm user’s credentials and say “make sure you are connected”, instead of giving misleading messages. It would save users from investigating about totally wrong things and loose time on forums.

Hello everyone, i have the same problem…
I solved it… its ocuring due to my credentials in microsoft store are different to the Xbox game pass app…
then the MFS2020 recognizing my wrong credentils… i filled the same credentials in microsoft store and xbox gamepass app, than it worked ok, i startes de MSFS2020 and it bring uploading to the ultimate version…

I have this “insert the disc” issue. Microsoft Support had me re-set my PC so I lost a lot of apps, add-on etc. I then spent another two hours with the XPASS support which had me do the "Signin/sign out " move with a game pass app. That also did not work. The problem seems to be that the store and Game pass both download the program connected to a disc version. There way to get me off was to give me this Forum which of course I aleady knew. Microsoft actually do not have a solution or any intention of finding one. Guessing ASOBO will not be able to help as they are just the developer but I will fill in the Zendesk report. If anyone is aware of a solution or things to try other than the reset/uninstall-re-install which I ve done numerous times, I would appreciate it. About ready to give up.

Do you by any chance use a systemwide ad/domain blocker/third-party firewall like PiHole ? After resolving my initial “Insert Disc” error, I started getting those again of late, but for once it wasn’t caused by MS/Asobo and after some digging I discovered that my PiHole was blocking the activation domains . That said, I do believe Asobo should provide an error message that’s not so generic (and misleading) as “Insert Disc”, because aside from everything else it would make their own life much easier when it comes to diagnosing and fixing issues (with the extra benefit of not annoying their client base by providing them with irrelevant/useless generic tips) .

Anyway, here are the two domains that I had to whitelist for PiHole to get FS2020 working:
collections.md.mp.microsoft.com
in.appcenter.ms

Thx for taking time to respond. I contacted microsoft support who had me do a reset my pc entirely. It allowed downloading but now i have the “insert disc” error even though i have digital ownership.
I will try your suggestion knowing that every update brings a set of issues like these. This program is not ready for prime time.
Kind of you to respond. Enjoy your weekend

So I figured out that when Microsoft had me re set the PC it also automatically reinstalled the MCAFFEE anti-Virus software without me noticing. It had come from DELL originally pre-installed and I always remove it first time I install a new computer from them.
Once I removed the McAffee virus ware the sim reloaded flawlessly. Wifh I had figured that out prior to the 6-8 hours I spent earlier. Understand I had removed the AVG software and Windows defender immediately after the reset. So if anyone’s looking for a solution be sure to check and see if another anti-virus somehow is on there. It was actually a post here from bk1009 that got me looking (Thanks to bk1009!)
Thanks to everyone that replied.

Ok, I know we have seen this before: we have a digital version, yet get this message.
From this forum and elsewhere, “could be the server, could be the Digital Ownership File, could be latest update, could be???” - tried everything more than once, but solution not found!
The story: Everything working fine, then 4 days ago I got a message that it could not sync my data from the cloud. I waited a day because I heard that there was a cyber attack on a cloud server in USA. So I waited another day, then another.
Finally, on day 4, it loaded and asked me to “Insert Disc”. But, I have no disc!
So, I did everything suggested in this forum, online, everything X-Box suggested. In the end, I uninstalled the sim and reinstalled completely, - 6 times!
Guess what? “Insert Disk” still comes up.
Then, on 7th reinstall after I deleted everything that could possibly be related to MSFS, finally went to the start screen, without “Press any key…” message. Just sits there now and spins, and spins, and spins…
I am now waaay over-limit on my IT skills (and my patience).
Any help or ideas would be appreciated. Thanks in advance.

Uninstall AV software and restart your computer.

Thank you TenPatrol. Already tried that, and just tried it again. No luck - still spinning and playing music on nice picture of Arc-de-Triumph (so at least latest version has downloaded). I am totally at a loss on this! Will try uninstalling and reinstalling again today. Last desperate attempt, then forced back to P3D.

Tbh the future of flight simulation is now​ msfs 2020 not P3D :wink:

https://flightsimulator.zendesk.com/hc/en-us/articles/360015985699-Error-message-Please-insert-the-Microsoft-Flight-Simulator-Game-Disc-

I can’t agree more. MSFS is amazing. My post is not about that it is not good, only that it has stopped working. P3D can’t even come close, but I do simming as my hobby and my objective is to continue doing that. If MSFS won’t work, then must go to Plan B.
BTW, just spent 2hrs online chat with MS “Expert” doing all sorts of fancy stuff with Powershell and other things I don’t understand. The sim is now sitting there spinning away letting me enjoy the Arc-de-Triumph and the default music. I am assuming it is downloading/installing content (?), so will wait for a while before I give up completely.

Smth like

Add-MpPreference -ExclusionProcess …

and

Add-MpPreference -ExclusionPath …

?

?? I don’t understand your post.

Update: I finally have the splash screen up, with music. But, there is this spinning circle thingy in the lower right corner. I thought it may actually be doing something useful, but after 29 hours, still spinning, no increase in downloads, no files saved.
Do you know what this is telling me??? Is it progress, or regress??