Possible Stuttering Fix - Nvidia/Gsync/Freesync

So, I think I pinned my stuttering down to some sort of Gsync/Freesync issue on my machine. After following the excellent post by @CptLucky8 My 2070 SUPER 4K settings and suggestions - episode 2 I was still having stuttering issues with glass cockpit planes. I’m not sure if it’s because I have a Freesync monitor. My monitor, ViewSonic XG350R-C, 35 Curved Gaming Monitor is supposed to be fully Gsync compatible, but Nvidia CPL tells me that it’s not certified.

What I figured out was that if I disable Gsync completely in Nvidia CPL, I disable Vsync in MSFS, and I enable Adaptive Refresh (1/2 Rate) under Vsync mode in Nvidia CPL, I get really good results. The trick is to make sure that if my monitor refresh rate is set to 100Mhz that I can maintain a constant 50fps in the sim (1/2 rate). If the fps drops below 50, then I start to get stuttering. If I set the refresh rate to 60Mhz in Nvidia CPL, I can easily maintain smoothness because my machine can do 30fps all day long. (Of course the problem with 30fps and 60Mhz is that it’s not as smooth on they eyeball as 50fps and 100Mhz, especially during sharp turns or with TrackIR, but it sure beats stuttering!)

The key is to make sure your FPS is matching your refresh rate or half of it. If it drops below the refresh rate it starts to stutter immediately.

This technique allows me to utilize the planes with the glass cockpits. I haven’t tried the A320 yet, but I was able to get the Baron to work really well. I believe that if I want to use the A320 I will have to limit my refresh rate to 60Hz so I can run the bird at 1/2 rate with 30fps and get no stuttering.

Enabling Vsync in MSFS only helped me with the C152, Savage Cub, and DR400 (faster fps, no Javascript glass panels?) Reducing the refresh rate of the glass cockpit did NOT help.

I’m still open to further suggestions. I’m not sure if this will help anyone out there but I hope it does.


I had read about stuttering issues in MSFS with g-sync on a while ago. Had it on when I originally started using it and did find some stuttering. Turned it off and it’s been much better so I’m leaving it off for the SIM.

1 Like

I have the same monitor. Not sure where your source is that it is G-sync compatible, it is only AMD Freesync compatible.
I have set the monitor at native refresh & resolution (100Hz/1440p), VSYNC off in the game and nvidia, and this is getting me the best FPS and zero stutters.

1 Like

Great, thanks for your feedback. I’ve read that the monitor is unofficially g-sync compatible from a few sources, such as Tom’s Hardware for instance…

"FreeSync (and can run G-Sync unofficially) "

Thanks for sharing.
Just to add something more, what you said is absolutely right - when trying VSYNC, you must choose a FPS rate that matches your monitor refresh (or half/quarter of it).
I forced the monitor to 60Hz and tried VSYNC at 60 and 30FPS. That gave me stutters all the time. Even though the card can do 50-60 FPS easily. Best setting was to leave everything unlimited. I am more interested in a stable performance without stutters, rather than the highest FPS.


Ok, this is good info. I will try turning off the Adaptive refresh, just everything off. If that makes it even better I’ll be stoked!


1 Like

Hey MikePapa,

So I did some more testing last night. I turned off Vsync, Gsync, Freesync everwhere. This didn’t work for me. I started getting stuttering whether or not the frame rate was above or below the refresh rate. It wasn’t terrible, but it definitely stuttered more than with my settings.

At this point I stand by my OP. I get the best results by…

  1. Setting my monitor to 100Mhz and…
  2. Using Adaptive (1/2 Refresh Rate) in the Nvidia CPL OR…
  3. By letting the Application manage the Vsync in Nvidia CPL and then enabling Vsync in MSFS at 30fps

Just curious if you have tried it this way since 1.9.5? What card do you have and which driver are you using? I’m curious to know what the difference is and why. I have a 2070 Super, currently with 452.06.

I tried again because my last test was a few weeks ago. Tried all combinations (60 & 100Hz on the monitor, vsync from nvidia/from within the game). Generally didn’t see any change. With nvidia vsync, I have very few but noticeable stutters. With vsync from within the game, stutters are really bad and even affect the sound.
For me smoothest performance remains with everything unlimited. I have GTX 1080 Ti and latest drivers.

Ok, thanks for reporting back, I appreciate it.

One more question, are you using an HDMI cable or DisplayPort connection?

I am using HDMI.
This really proves that every system behaves slightly differently… However you have a better graphics card so it could be making the difference.