PSA: Get better engine sounds with the Reverb G2 (and probably other Headsets) 🔵

Hi,

I’ve just discovered I could change some audio properties for the G2 headphones and I wanted to share this with you:

  • Open Windows Settings WIN+I then select: System > Sound > Sound Control Panel
  • Alternatively open the legacy Control Panel > Sound
  • Locate the “Speakers” entry corresponding to the G2 and select Properties
  • Select Enhancements then enable Bass Boost.

It should resemble this:

I find this helps giving just what is necessary to feel a little bit better the engine roaring and this is also giving more presence to the rumbling during the takeoff roll!

PS: don’t forget to also disable spatial sound (it doesn’t sound properly when turning your head otherwise):

fs2020_settings_sound_vr_3

4 Likes

I know there were some early issues with the G2 and black screens due to power draw from the audio. If you start having weird issues at higher volumes due to this, that may be the culprit.

@Trowels Good call! I’ve not had this happening with my G2 but some are indeed reporting this.

It was alluded it might be too much current draw (which I doubt given the 45W power brick). It might just be the USB Audio Driver failing to sustain the data stream, or maybe these users are using a stack of audio effects on their systems which when used together with the G2 are triggering a bug in the G2 firmware decoding the audio stream from the USB and blacking out the screens as a consequence. For now, let’s hope they’ll find the root cause and solve it.

Yea, the power thing is dubious to me as well for the same reason. I think that was the initial suspected culprit because it was a major issue on previous iterations of WMR - my O+ would drop into terrible static in random moments where the USB bus was getting thrashed (iRacing crashes were the worst – combo of loud noise and heavy FFB response would make it bubble up.)

I’m thinking about some home made headphone / ear cover mod for the G2. Try covering the headphones with your hands. It immediately sounds 10x better.

I have also noticed they’re exceptionally sensitive to proper positioning. In fact, being unable to get to the sweet spot is usually a reminder that I haven’t canted the headstrap down far enough to cradle my head. It seems like one of the ways they reduce bleed is by delivering sound to a very targeted, but small, sweet spot.

@Trowels I believe this is normal given the way these audio drivers are working.

There is great information about the Valve earphones here:

Valve Index Ear Speakers - Research, Design, and Evolution

Fantastic information! Thanks.

1 Like

Out of interest do you have any issues with audio not initialising properly on your G2?

Mine will often start up as "headphones (realtek USB2.0 audio) and I can’t get it to play any audio even with checking it is selected in the sound options.

Unplug and replug (sometimes a few times) and eventually it shows up as “speakers (realtek USB 2.0 audio)” and then works as intended. Really odd… if you have any ideas as to how I can force it to stick with speakers rather than headphones I’d be all ears (pun definitely intended!).

During the first days, I used to have the G2 symptoms of the audio volume popup showing up and fading out (like when you’re switching audio input).

Since then, I’ve made a mod to the G2: I’ve firmly attached the cable at the left headphone level using a thin Velcro band for cable attachment (one which was included with my UPC was thin and fit perfectly). This mimics what exists in the Index which has a plastic cable holder near the same region in order to prevent any tension on the cable plug going into the headset. Since I’ve done this, in addition to another Velcro attaching the cable to the rear padding (instead of using the fragile plastic cable pass trough of the G2), I no longer had any such volume popping up problem.

You might want to also open the Mixed Reality Settings panel (WIN+I) and check at least the first two options are checked (sound tab | headset audio and headset mic).

1 Like

I’ve seen that mentioned before so I’m wondering why. It works for me and when I disable it sound doesn’t seem directional. Try it enabled with Windows Sonic turned on in your Win settings and see if it makes a difference.

Spatial Sound is “expanding” the sound channels, injecting left sound into right and vice-versa. It gives the impression of a more enveloping sound when using 2 speakers.

When using headphones you’d need HRTF instead, and this is notably what Valve Audio lib is doing and why HLA sounds so realistic for example. In effect you can locate sound source origin as if they were coming from the real world.

However I don’t believe FS2020 developers are using any specific VR sound processing which works only in VR but not in 2D. Instead, they’re using the Wise audio lib and/or using the Wise effects or the Win10 effects. And with FS2020 Spatial Sound ON, it is clear to me my right ear for example is earing inversed phase waveform derived from the left sound channel, and vice-versa. It also amplifies sounds so that you can hear for example the engine louder or quieter depending on the orientation of your head, whereas you’re supposed to hear the same level regardless of the head orientation (just the direction changes).

Now in VR, the directionality is supposed to be handled by the software and the Wise sound lib is supporting this naturally: tell it location of source and ear, then add some occluders and reverb specs, and it is supposed to do the math. The question: is FS2020 using 2 ear positions or 1 only? is it using HRTF or not? (search online what it is if you’re wondering).

All in all, I find it sounds more natural regarding sound source orientation and perceived level balance between the 2 ears regardless of direction (including looking up/down) with FS2020 Spatial Sound OFF.

Can you lease detail which Win Settings are you referring to?

PS: https://valvesoftware.github.io/steam-audio/

Right click the volume icon near the clock in the task bar. Look for Spatial Sound. Windows Sonic For Headphones should be there by default and Dolby Atmos if it’s been installed. Once I enabled Sonic I could feel the engine noise move around me as I turned my head… well not move around me, but move through the correct location in the stereo field.

Thank you. In my test system it only shows [ off ] (lots of spaces prior the Off text) and it doesn’t seem to do anything except rebooting WMR.

I’ve however tried comparing again Spatial Sound ON and OFF in FS2020 and I still believe it shouldn’t be set to ON in VR because it really sounds like “widen stereo” filter:

https://blog.discmakers.com/2016/04/stereo-width-and-post-production-audio-mastering/

When OFF I can accurately pin point the source location AND the source volume is not changing with orientation, whereas with ON volume is changing and I can hear stuff much louder than expected in the opposite ear.

Does everyone elses volume default to 50 after each reboot? I set mine to about 70 but it doesn’t save.
Quite annoying.

I’ve been getting momentary black screens (inside my G2s only, not on my regular displays, nor does it affect the actual sim or anything else running on my system, just a momentary blink to black, and blink black) that last NO longer than 2-3 seconds tops, most of them less than one, but I don’t think they’re sound related.

Should I be worried that my device itself might have a flaw in need of a warranty fix/replace? It’s not like the end of my warranty is coming up, I just got them 2 weeks ago MOL, so waiting is certainly an option, but if it does indicate a potential problem, I at least want to make a mental note…

@CptLucky8, can you snag a pic of that and post it? Thanks bud…

I just tick loudness equalization. It somewhat increases the overall volume, which i thought was a bit low.

This!
I can now hear every detail of engine rpms in racing sims.:beers:

1 Like

Here is:

The “red label” Velcro comes from my APC UPC, the one on the back of the head comes from the Index (nice packaging and Velcros).