PSA: NVidia has found the root cause of stuttering and VR performance in their drivers!

Task Manager → Details tab, right click on the Microsoft Flight Simulaor executable and set priority.

1 Like

thanks!!! I am waiting for my i9 10900K, see what happens. I got it for my work stuff but keen to see how it performs with the 3080. Im not expecting too much tho!


@CodeLoran69, if you happen to do that test, please fill us in on your findings. I’ve actually been thinking about doing exactly that, myself, but I can only mentally process so many experiments at once.

This is because you’re not at the right level of consciousness yet :face_with_hand_over_mouth: (can’t resist)!

Oh, byte me lol…

1 Like

I’ve not tested this yet, though I did download and install. What struck me straight away was that my desktop image is considerably worse quality than it was before I installed the driver.

Seriously, I’m currently using a folder full of P3D screenshots as my desktop background and before the driver install they looked as good as ever, but after - and since - they have a distinctly grainy look and the cockpit gauges of the VC screenshots are almost unreadable, whereas before they were very clear.

Weird! Settings are the same.

edit - forgot to mention I’m using a 2080Ti

Ok by popular request :wink: just did it again and I confirm same thing I already saw:

Hyper-threading OFF (so 8 cores 8 threads vs 8c/16T with my I7 10700k) is faster in MSFS when you’re CPU limited.

To test this I lowered all my graphics settings to the minimum so all is on CPU side, because with my usual settings I’m GPU limited (GTX1080) so this change affect nothing.

BTW I always use the same test scenario, no external element, same airport, plane, weather, etc. I wait around a minute until all been stable.

So from left to right, with my usual settings HT ON and OFF, and with lowest graphic settings HT ON and OFF:

So on scenario where you see “Limited by mainframe” often, turning off Hyper-threading could be interesting, weirdly, here from around 101 to 112fps. At least it’s what happen in my configuration.

I don’t see any reason for this behavior, more brainstorm needed here…

Edit : Ho! and tomorrow I receive my new RTX 3070, off topic, but just wanted to share my joy :slight_smile:

This is expected: one HT processor is not a full core. HT is a technology which permits “splitting” the instruction stream in a way which minimizes contention. If you do have a series of instructions and one takes a longer time, the code won’t make any further progress during this time. With HT, some instructions can therefore run in parallel and it usually is effectively raising throughput by 5% on average and about 15% max.

However, should the thread scheduler uses the 2 HT units of the same core for 2 different threads, any synchronization between the 2 threads will effectively renders HT useless. Furthermore in this case, because the cache lines are shared, you can have other side-effects effectively reducing the throughput. This is why when you’re implementing a work task scheduler (see Intel TBB for example) you have to pay attention to this and effectively ‘pin’ your work task scheduler threads to “main” core only (i.e. CPU0, CPU2, CPU4, CPU6 etc…) for better results.

The issue is Win32 API presents these HT cores as if they were 2 real independent CPU cores which is not true, and it takes special care to manage these efficiently.

This is why in general for gaming, CPUs without HT are better (or disable it in the BIOS) and for flight simulator (not flight simulation) single core performance is key to choosing a CPU brand/model.


Understood, thanks for the explanation.
I thought about turn it off for some times ago, as I also discovered last summer when I upgraded to the 10700K that my CPU is easier to OC and stay cooler with HT OFF. HT at least for gaming it’s useless nowadays…

1 Like

Just wanted to give an update. I tested 461.33 again and turned off Hardware Accelerated GPU Scheduling in Windows, and I am now getting the same frame rates as I was getting in 457.30 using my G2 with Windows Mixed Reality.


So, if I’m still using 457.30, should I enable or disabled Hardware Accelerated GPU Scheduling? Will not put 461.33 back in until I’m sure. It messed everything up

I’ll be honest guys, I, like others appreciate the effort in getting this figured out but most of this is over my head. I don’t have the time to sit and learn a bunch of computer stuff. Right now, I have NO IDEA what driver to use, what settings are WHERE and how to change a bunch of stuff. I’m not computer stooopid but dang close.

System Specs:
Power Supply: Corsair RM850X
MB: MSI Gaming Pro Carbon
DUAL 2GB NVMe Drives. One in TURBO M.2 slot.
CPU: Intel i9-9900KF 3.60 ( I overclock MSFS2020 to 4.8 when possible.)
RAM: 32GB Corsair RGB RAM (No O/C of RAM)
Windows 10 64
Res: 2560X1040 (144Hx)
Dual DELL S2716DG Monitors.
Onboard Audio.

I believe you’ve forgotten to add your headset in the list?

Don’t look any further, this could give you a good start:
My 2070 SUPER VR settings and suggestion (Reverb G2 - WMR)
My 2070 SUPER VR settings and suggestions (Index - SteamVR)

1 Like

Headset is a INDEX. Sorry! I have read the posts as much as possible however it is a lot to digest. there is 428 posts talking about tons of stuff. I just tried the 457.30 driver along with the SteamVR BETA and it tanked my sim. Totally unflyable. Not sure what to do now.

There is a long discussion of interesting topics and developments on the subject of VR where a lot of people can learn and better their experience!

Nevertheless, why not just starting with the 1st post only…

Again Cpt, I’ve read as much as possible. Over and over. Seems there are a million different setups. Will relaod the latest driver again and see what happens.

@RwpTurnip, I concur with @CptLucky8. Just go to post #1, do exactly what it says, and don’t worry about all the details. Step by step, just follow the instructions.

That’s what I did, and it worked quite well. But I’m a tweaker by nature, so I’m still tweaking lol… And in the meantime I keep reading the detail stuff slowly, so I can actually absorb what is being said, and it’s (very) slowly starting to make sense to me in such a way that I can do more than just follow step-by-step instructions.

But start with that, it’ll fall into place eventually.

1 Like

I have to say, after a few hours of flying in a mix of cities, mountain & desert terrains, I am finding the 461.33 driver with SteamVR 1.16.2 & Valve Index to be the smoothest experience I’ve had yet in this sim in VR. I also currently have HAGS enabled, and I’m not getting any stuttering whatsoever (although I don’t know if I see any difference in framerate + or -).

My CPU is i7 9700K @ 4.9 GHz, with RTX 2080 Super.

This is now performing well enough for me to where I’m ready to quit tweaking and just enjoy the sim for awhile. :slight_smile:

1 Like

That’s good.

I tried the G2 on 457.30 with the latest steam OpenXR runtime and now it gets actually marginally better perf than using the WMR runtime for me, previously it was worse.

Switching to 461.33 works well in my steamVR games I’ve tried so far, but turns msfs into a stutter mess again (using steam openXR at least, didn’t have time to test it on wmr version).


Quick question - do you notice any change in your head movement in the cockpit when using Steam OpenXR runtime vs. Windows OpenXR runtime?
To not derail this thread, please check out here: Bobbing (Tilting) head up and down in cockpit view (plane's dashboard goes up and down) - #17 by PolackofDoom

1 Like