Quality of Life Suggestion: Remove the "Press any key to start"

Look, the load times are horrendous, but we get it. It takes a lot to load in this sim. But for the love of all humanity, please, remove the initial “press any key to start” prompt. Because we should be able to launch this sim and then go do something else for 5 minutes.

Also, if it doesn’t already exist, a feature to tell the sim "always startup at this location in this aircraft, etc.

This would allow simmers that always fly the same place/plane to be able to launch it, walk away for 10 minutes, and come back and be ready to fly.


In addition, put the “Fly Now” button on the planning page on ALL the planning pages, not just the map page. It’s annoying to have to go from weight & fuel back to the map page just to hit fly now.


“To start press any key”. Where’s the ‘any’ key? I see Esc, Cataral and Pig-Up. There doesn’t seem to be any ANY key!.

sorry couldn’t resist :grin:


it would be very hard to make a game load slower than this one… i think there is a problem underneath.

and agree… the “wait 2 minutes to get to the press any key” to then “wait another 2 minutes to show a menu” then “wait many minutes to actually start flying” is ridiculous


Spoken by someone who clearly has not played GTA Online. LOL.


How does someone come up with a design like this, where the user waits awhile to get to a “Press any key” screen, then has to wait awhile longer after that?

Maybe they were going for the classic console “Push Start” title screen, since this is eventually expected to be an Xbox game.

Maybe they never realized how obnoxious it is because they always automatically skipped past it in private developer builds.

In any case, I think users would be more appreciative of a design that respects their time.


I agree with all. Takes way too long to load. No need for the “press any key” step.


The “press any key” is the equivalent of calling any store and hearing, “Hello, welcome to _______, can you hold please?”


agreed it feels cheap somehow like an arcade game when i see it


:clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap: :clap:

:facepunch: :facepunch:

YES! Please just let it load right into the Menu.


Excellent suggestion. This is a pain! I’m curious about why they made it this way. Must be a reason :thinking:

+1 here.

Suggestion, move this to after the loading screen :slight_smile: This way once we click a button we’re in! Just helps for those who may step away while booting up th e game…

1 Like

+1 to that. This serves no purpose, is annoying as hell and can be easily avoided. BTW an option to “skip” the whole dev advertisments on start after having seen them a dozen times would be cool, as well… everybody knows who made this software.

There’s a -FastLaunch command line parameter to skip the videos. Check this thread for details:

1 Like

At first I went all round the keyboard and nothing worked. I then pressed a joystick button (key?) all was fine.

If you have the Game Pass open Zoo Tycoon by Asobo. If you just have Zoo Tycoon then try it too. I was amazed to find the same or similar globe and the press space bar to continue. Almost as if the same UI is used on a few different games they make. I am not 100% Pro or against MSFS 2020 and include this just because I found it whilst checking out some games on my new Game Pass.

I ‘think’ the program downloaded OK.
I see the XBox screen.
I see the Asobo screen.
I see the Blackshark screen.
I see the Wwise screen.
I see the pretty airplane screen. I press a key…
I see the black screen. I press a key…
(I hear the soothing music. Zzzzzzzz…)
I did all the troubleshooting: Turn off USB devices, disable firewall/Defender (???) check Xbox game settings, disable nVidia audio, uninstall/reinstall, blah, blah, blah…
Repeat above steps.
15 minutes later… NOTHING. Update: 45 minutes of black screen with soothing music - still nothing. Update: I left it on the black screen for 6 hours. NOTHING.
Flight Simulator is still using 22% CPU / 422MB RAM / 0% Disk / 0% Network / 29% GPU / Power Usage = Very High
I feel like Towelie - “I have no idea what’s going on.”
i7-7700HQ, 16GB RAM, 1TB M.2 NVMe, GTX1060 MaxQ, Win 10 Pro/64 Build 19041, all drivers and Windows Updates are current.


Yesterday morning I created a new user account, and made it a Microsoft account. (My previous attempts had all been when I was logged in to my offline Windows account.) I went to ‘My Library’ in the MS Store and launched the game. It went through all the screens I’d seen before, but this time it moved on. Hooray!

Ten hours later I had the 95GB feature pack downloaded, and this morning I was able to fly. I haven’t tested whether I’ll be able to launch the game from my offline account yet.

I panicked a little when, with 93GB downloaded, and 2GB to go, I had a power outage, which killed my internet connection. I left the downloader running all night, but it remained stuck on 93GB. Aaarrrrrghhh.

Luckily though, the game launched, and when it looked for updates, finished downloading what was left over (instead of forcing me to do the entire 95GB again.)


Try to install it via the X-Box App, that was the only way for me to get past the “hit any key to continue” screen (and I too tried everything from unplugging all devices, updating to the latest Windows/Nvidea/Microsoft Store, disabling all antivirus and firewalls etc. etc.)

Honestly all they have to do is make it load in the background so that when you do hit the “any key” it’ll be instant. Could keep their neat-o video/splash screen thingy.