Quest 2 stuttering and tearing/flickering

Hi,

I’ve tried so many guides but cannot find a solution. I use a Quest 2 with the Link cable, I use the oculus software and not steam VR.

When I am on the ground and taxiing straight it’s mostly fine, but when I turn on the ground it stutters, it’s even worse when I look to the side and if there’s buildings around too.

In the air it’s still there but not as bad.

I’ve tried all sorts of settings with and without OTT and debug tool too. Tried lots of settings in Nvidia control panel too. No joy.

I’ve also tried putting both sim and oculus software settings to their lowest but it still does it.

All my other games work fine but it’s just FS2020.

I have an i7 4790K @ 4.4GHz, 32GB RAM and RTX 2080Ti - sim is on an SSD too

Any suggestions are welcome :+1:

Thanks

Usually when turning side by side on the Quest 2 some resolution setting is too high for the quest to handle even with the link cable.
What are your settings in the Quest software ( x1) of is it cranked up. I say start with x1.
Also doing the test, what the speed you are getting with the USB C port of your PC?

Last publish your OTT settings, i get great results when my FOV Tangent Multiplier is less than 1 ( i am using .75).

Encode rate too high on OTT? Leave at 0.

I tried to get my Quest 2 with link cable stutter-free for months by tinkering with all the possible options, lowering parameters to absolute minima, without success. Then I read somewhere on this forum that Virtual Desktop works better. I own and use that for room-scale FPS games because I don’t want to get tangled in a wire. I always assumed link would be better for MSFS. Boy, was I wrong! Since a few weeks now I fly stutter-free. After SU5 I can set the VD rendering at Ultra and the MSFS rendering at 70. The only limit now is purely the framerate. I leave VD’s SSW off and get between 27 and 35 fps at all times, just enough to make things smooth. And if I feel the need for an even smoother experience, I quickly lower the MSFS render scale to 60. I’ve also read that AirLink should work better than via a Link cable. I haven’t tried that as VD works great.

I also have been having this issue for some time and have not been able to solve it. At some point you just have to accept it and save up for a faster graphics card…. Now the savings waiting game,…

It’s not your settings or your hardware. I have a 10900k, 32gb of 4000 CL14 ram, 3090 under water and 2 NVME SSDs in raid 0. I have the same problem as you, I’ve even tried the ghost spectre version of windows thinking it’s a process running that’s causing it. Nothing fixes the stutters with the quest 2. If I put it on 80fps with a 1.0 resolution, I have around 40% of headroom when running with ASW at 40fps and no CPU threads are maxed either. I’ve literally tried everything and thrown thousands of dollars at the problem, but if I look around it stutters. I’ve almost went insane at this point.

Most probably it is an Oculus issue as I have similar problems but with intermittent stuttering and tearing. I use cable as VD might need WiFi 6 ? Airline never actually worked great.

Yesterday upgraded my 2060s oc to a 3060ti but still got same problems. Next month I try getting hold of a G2.

Before investing into a G2 or a 30 series GPU, which are all great upgrades of course, I’d spend £15 on Virtual Desktop (if you don’t already own it) and £40 on a new router. which is the current price of the TP-Link Archer C6 on Amazon (UK). I tell you, after months of micro-stutters, however low I reduced my settings, I’m amazed how reliable and smooth VD works. And it’s worth the extra money compared to AirLink, because the developer created his own reprojection system, synchronous space warp, that works just as well or better as Oculus’ ASW and uses the resources on the headset itself rather than on the PC, which is great for many others games, even though I don’t use this feature for MSFS.

Well that sounds pretty good, what are your settings, and as a note I’m running a 2070 w 32Gb RAM i7 9000somthing…. Also running the SIM on an SSD. Any help would be awesome. :slight_smile:

I have a 3060 Ti, one of the latest Ryzen CPUs, 32 GB RAM. As I already mentioned VD at Ultra, which is only slightly less resolution than a cabled Link connection at maximum in the Oculus app. Render scale in game generally at 70. I won’t go into the detail of all other settings, but the main things: both terrain and object LOD at 200, clouds at High, AO at Ultra, trees/grass/reflections/shadows etc all at High or equivalent. Some non-essential things like windscreen at Medium. I’ve done extensive testing on all these settings to find out what is important to me for immersion. The only compromise I’ve had to make is not to have clouds at Ultra. They do look quite a bit better at that setting, but it effects framerate too much and I’d have to compensate for that by reducing rendering scale and sharpness.

Pretty sure it’s an oculus issue. Was flicker free up u til firmware 28 I noticed.

If anyone has a fix let me know

Might give VD a try but I don’t have that router.

My sim is on steam so do you launch the VR thru VD on steamvr ?

My copy of MSFS is MS Store version so things might be different. This is what I do: start MSFS and wait for the main menu. Put on headset and open VD. You should now see the MSFS menu on the virtual screen hanging in space. Click small inlaid button on left controller to go back to VD menu. Press “Start SteamVR”, which opens. From there you hold left controller button to return to VD menu. Easiest thing now is to take off headset and press Ctrl-Tab on your PC keyboard to switch MSFS into VR mode. Put headset back on and press “Go to VR” in the VD menu. Voila, you are now in VR mode. I have VD settings on Ultra, 120 Hz, no SSW, max bitrate (150) and some options on the right marked (video buffer, sliced encoding come to mind). Now you can play around with the in-game rendering scale to find the sweet spot for you.

1 Like

Many thanks. Final questions do you have any settings in Nvidia control panel ? Are you using openxr or steamxr as runtimes ?

I have almost your same setup with MSI 3060 to gaming z trio, 32gb ram and Intel i7 8700

Update. My max bitrate in VD is 116 not 150 ?

It looks fine finally even though need some more settings but on occasion it seems to disconnect a bit the image.

Have a strange problem that the simulator crashes when I do the exit to desktop and most of the time even if it closes I keep hearing the music and need to force exit the exe via task manager.

I’m using Steam runtime. VD bitrate can be set fixed at any rate or have it decide the optimal rate automatically. Not sure if this makes any difference. Maybe better to leave it on automatic. Nvidia settings are default except texture filtering at High Quality, but also not sure if that’s good or not. I’m still not sure either to leave pre-rendered frames at the default 1 or set it to let the 3D application decide.

tried VD and it is better than cable strangely enough :slight_smile: with cable even myself had stutters.

Tried with above settings (many thanks satshanti) and it did wonders. Have a 3060ti too :slight_smile:

The only lags I have now are when I am at a modded airport like Gatwick or JFK.

Would love if you can post a screenshot of your ingame settings :slight_smile:

1 Like

The only problem I am getting with VD is that if I remove the quest and than later put it back on and reswitcg to VR I get a total stuttering fest that even my main monitor lags and even if I reset my quest or steamvr it does not help.

So Oddest thing happened when I tried to get VD working the other day… Followed all these same steps, but the system wouldn’t go into VR, instead would display a “window” of the “cockpit”, but would not alow me to look around, only the “window” right in front of me… It was very strange and I could not get the system to enter full VR at all… So back to the Oculus Link cable. :frowning:

This sounds like ASW is not disabled. Easiest way to do this in my opinion is by hitting Ctrl-numpad1 after entering VR in the Simulator.

OTT does not always disable ASW properly, although it shows as disabled.

In my experience, disabling ASW makes the biggest difference. Even when you stick to default Nvidia settings, not using OTT and not try all kinds of (Windows) tweaks.

1 Like

Did you have the runtime set to SteamVR or Oculus? It might need to be on SteamVR in order to work with VD.