Quest 2 Virtual Desktop Vs OpenXR

I had a quest 2 right from the start and with msfs2020 it was very buggy. Then I used virtual desktop and I haven’t looked back. I don’t think there’s any oculus software installed.

Since I have a usb3.0 cable powering my headset, is it worth having another go now its 18 months on? And we are many versions on.

What do I need to install and will it break my current setup?

Have you tried airlink? (if you have good 5g wifi and ethernet cable for your computer.).
Together with the oculus tray tool and openxr tool it works way better for me than virtual desktop.

I have Air Link and it is not worth the money. It’s a great idea however I get a better connection without it. ( Router is in another room ) Maybe if there is an update it will work better. If you look on line there is nothing great about it but the idea of it. Good Luck

Not worth the money? It’s free and works perfectly well… at least for me. I’ve been using AirLink since it first came out. You do need a solid wireless connection. The only other choice is to buy a dedicated Oculus “Link” cable.

Everyone who owns an Oculus 2 headset also has AirLink. It’s included.

3 Likes

You must be confusing Air Link with something else as it is free.

2 Likes

Isnt airlink just the same as the wired connection but using wireless. I.e. it’ll be the same underneath as virtual desktop but with the limitation of wifi? I was thinking that a hard wired connection ought to work better. It didn’t used to such was why I switched.

I guess I can try. Do I just install open xr?

There’s a checkbox inside the settings of your oculus headset.
(and make sure oculus home is running on your computer)

OK installed, so long since installed oculus that had to log back in. Now I get the oculus home up via the cable - looks blurreyer than I remember but its working. Looks like later on I can just launch msfs2020 and it should now use this?

To revert to VD, I presume that I just don’t enable the link and use VD instead to establish its link and then start VR in msfs as usual?

That’ll be cool.

There’s switch in oculus home to activate openXR runtime if you want to use airlink.
I believe it automatically switches to steamVR (?) when using VirtDesktop.

Also check your resolution settings in oculus home.
Maybe you can increase it.

yeah - mine is set to 1.3x which is the same resolution as you have there. So we’ll see.
I just want to be sure I can switch between VD and the USB cabled solution easily. Not really sure if I already broke it I guess we’ll see. My next problem is finding a block of time to mess with it!

Hello all! i am very new to the VR world and to the forums! Im on here because i am desperate and am in need of help! ive been playing msfs 2020 on xbox and just recently got my PC gaming rig built and operating. I have a oculus Quest 2 headset, and my computer has a ryzen 9 5900x with 32 GB 3600 of ram, a evga rtx 3080 ftw3 ultra and a samsung 970 evo m.2 ssd. I downloaded MSFS from the windows store and it seems to be working just fine non VR. As far as VR i went online and found the forum on hooking vr up as well as found a few videos. My computer is running Windows 11 and everything as far as i know is up to date, all my drivers, graphics card etc. My flight sim is also all up to date. My Oculus Quest 2 is also fully up to date. I have downloaded the oculus app and the openXR as well. i am using a link cable to connect the quest 2 to the pc, it appears to be showing up on open XR and it says it is linked on the oculus app, as well as i am in the linked mode on the headset. NOW to the problem… My problem is, with both openxr and oculus running and connected, i run MSFS and when it loads up, it appears as if MSFS is not recognizing my VR headset, when i go to the controller tab my keyboard, mouse, joystick are all there. And since ive connected the vr headset, it shows the “touch pointer”. but when i try to assign VR activate/deactivate key, it says “you are trying to assign an action to a device that is not detected”. no matter what i do i cant seem to find the vr headset on the sim, nor ad any key functions to try to use it. ive re installed fs 2 times, i believe its downloaded thru the correct directory since the sim atleast works, but no VR luck! PLEASE HELP!!!

Im new to this forum and could not find a post similar to my problem or any way to make a new one, so i apologize for the poor placement and if ive done anything wrong let me know! thanks in advance!

Just for reference

MY pc

Asus rog motherboard
ryzen 9
evga rtx 3080
32 gb 3600 ram
1tb ssd m.2
1000w power supply

Oculus/meta quest 2 VR headset with link cable

If you have “downloaded the OpenXR app”, I’m going to take a wild guess that you mean the WMR one, which is not useful for Oculus(!).

All you need for Oculus is to enable Oculus as your OpenXR runtime as shown below:

This should be all you need in addition to your typical Link connection using the Oculus apps.

O sorry Air D-Link Quest 2

So, tried it with usb. Its sharper than vd. But its framerate is wildly inconsistent. I get 40fps which looks fine then 22, then 40 then 26 anything below 30 results in stutter. If I’m away from my home airport its fine edging towards 55fps. So all other settings are equal to the vd setup. Even with dlss its no better than itv was in jan 2021. It seems that on my setup the usb loads up my machine. I tried airlink, looked the same but 2 second lag and its not fast enough.

So vd it is then. Same settings and it plays just fine, just a little blurry especially for instruments.

I haven’t a clue what “Air D-Link Quest 2” means. All I do is connect to my router via “AirLink” (within the headset) and I’m off to the races. Once Airlink makes the connection, I switch to VR.

Easy as falling off a log. :slight_smile:

I expect its an autocorrect issue, since It probably doesn’t know what airlink is.

Anyway, in my setup the airlink worked fine until I pushed it and then you get black tearing and lag. My router isn’t wifi 6 which will be the problem. My desktop has an unused wifi6 adapter so I could set that as a hotspot maybe. But I thought that usb would be the highest solid bandwidth.

Thanks for the reply! I’m not sure but you’re probably correct on the openxr being WMR. I’m guessing maybe it’s possible for it not to be working because I’m running both programs? I will try deleting the windowsxr app and let know how it turns out! I’m new at all of this (not the aviation) just learning the computer stuff!

Thanks!

Ok, after a bit of fiddling I have it silky smooth better than ever. The trick was to try to get rid of motion reprojection. Asw and motion reprojection set to off amd now I can get full resolution and can read the instruments.
All good.

Just got home and tried it, uninstalled openxr, double checked the settings on oculus app, Microsoft still doesn’t appear to recognize the headset? I just don’t know what the problem is. I’m sure it’s something stupid! Any suggestions?