Recent Airport History broken again - Not updating on World Map

Are you on Steam or Microsoft Store version? Steam

Are you using Developer Mode or made changes in it? Occasionally just for FPS limiter and to view console log

Brief description of the issue: Airport history not being recorded

Provide Screenshot(s)/video(s) of the issue encountered: Please see linked thread.

Detail steps to reproduce the issue encountered: Do a few flights.

PC specs and/or peripheral set up of relevant: 9600KF, 32GB, 2070S, NVMe.

Build Version # when you first started experiencing this issue: WU7 1.22.2.0

MODERATOR EDIT:
This issue was resolved with SU6. https://forums.flightsimulator.com/t/bug-logged-airport-history-not-updating-on-world-map/373761

If the issue is back, please report in this new topic.

I have tried this several times and cannot reproduce your issue.

I can confirm that airport history is also saving for me.

I’ve spent all day troubleshooting since updating to WU7 as I was getting CTD even in Safe Mode, have done over 10 load ins at 4 different airports and none of them saved in the recent list. I even made a quick direct GPS flight plan that did not make a difference.

Still getting CTD when panning the camera at low altitudes but seems to be more stable with HAGS off. I also used DDU and installed the new Nvidia drivers and tried with both GFE installed and not. I now have it installed but have overlay off. All other overlays are off (Discord, Steam, Xbox).

If there’s anything else you could suggest testing (other than a full reinstall) let me know because I’m out of ideas. Mods, no mods, safe mode - no difference. I even did a verify files with Steam which said no integrity issues and then MSFS decided to download 17GB of files anyway for no reason. Sim has been running pretty awesomely stable (even with mods) prior to WU7.

What does your windows Event View report?

0xc0000005 errors attributed to either FlightSimulator.exe, ucrtbase.dll, or nvwgf2umx_cfg.dll.

The Nvidia one is thinking maybe I should roll all the way back to 497.29, as both 511.17 and .23 seemed the same stability wise.

I believe the CTD issue is seperate to the Airport History issue though.

The airport recent list does not work for me either. It is populated by the first three airports and have been stagnant for months.

1 Like

Same for me.

Same. History not saved again. Also, the sims CTDs when closing down a lot at the moment. So when I select Quit to Desktop from the main menu. Wonder if that’s related.

It looks like it’s partially working again, but only when I load a .PLN file (from SimBrief). Selecting a departure airport or creating a route in the sim does not save the airports.