Repeated CTD's 1.18.14.0 & 1.18.15.0

If some people like me continued to encounter CDTs, I simply turned off “MSI Afterburner” and “NahimicService”. I haven’t had any stability issues since. :blush: I am gradually starting to hand over the contents of my “Community” file to detect another possible culprit.

For those who are saying that they’ve removed their overclock and still get CTD’s, I would bet 95% of them haven’t reduced the overclock on their memory. Most people don’t realize that all memory is overclocked. Memory is sold to be rated to work at 3000 or 3600 or whatever, but it’s overclocked to that level. My memory is certified 3000 but it will randomly CTD in flight simulator at that speed while being totally stable in all other use cases except a full on memory stress test. I have to run it at 2800 to remove CTD’s.

I’m also not saying that all CTD’s are from overclocking, but if yours is then you will be waiting a long time for Asobo to fix a CTD bug that doesn’t even exist.

If your CTD’s are seemingly random then it’s almost certainly hardware related. Software CTD’s happen under specific situations that are repeatable.

1 Like

Stop blaming overclocking for CTD’s - just a reminder Xbox is also affected by the same CTD’s and they can’t OC, there are no different software/driver/hardware configurations for them so you cannot blame on that either. The game is currently half-broken and it’s solely on Asobo to fix it - EOT.

4 Likes

yep… this is called XMP profiles :slight_smile: … it was one of the older issue within the existing ctd threads.
We recommended to try to disabled XMP profiles for a test-case and it helped a lot of users.

XMP profilesd should normaly works fine if mainboard and memory can work stable together.

The other kinds of overclocking, like CPU or (more worst) GPU , cause much more issues. It is just what the name tell us “over clock”, all these components running out of normal specs then.

1 Like

And right on time I had my 1st CTD since the update while re downloading a new install of MSFS, yet it wasn’t the sim but the UI of Windows 11 itself and no amount of Ctrl+Alt+Del or Alt+Tab would get a reaction even though I could still see from my front panel LED that the install hadn’t stopped. It would seem 4000MHz overclocked G.Skill isn’t too keen on a lot of multitasking, it’s the only overclock I had and now it’s back to 3600, even that is an OC but it’s one that has been stress tested till the cows come home in every available bencher.

Hi. Empty comm file. Then go to your msfs programs beside marketplace and delete exery add on listed there. You wont loose them they can be readded. Now start your game, worked for me. And delete a320nx

My 2666 memory is working fine at 3600.

zero overclocking here.
nothing in community folder.
CTDs within a couple minutes of starting flight…every single time.
rarely had ctds, now relentlessly consistent.
the worst part is that I have been in isolation with covid for a week and a half and ZERO sim available to me to pass the time. been simming for decades, and it picks now(when I have all the time to use it) to not work at all. absolute murphy’s law.

2 Likes

It should do at the resolutions we play at. For 4k there will be significantly more A.I. data being swapped in ram.

1 Like

Greetings all X-Box users from Asobo! We promise to fix the sim on our NEXT update.
PC users: We thank you for bank rolling the early development of this X-Box sim. And as a reward, we will build you a NEW SIM starting right after we take care of our valuable X-Box players AND return from our company vacation on the Isle of Santorini. All PC Zendesk tickets will now be purged! Good day!

2 Likes

we should not have to wait untill the 27 just to play the bloody game

2 Likes

Who knows if they will even fix it I just want to fly since I can’t get a refund

2 Likes

Yes, I am not very optimistic, I fear they will just make some fixes that won’t necessarily help everyone, and then they will pretend that the issue is solved.

Although chances are that people that have no issues now will have after the WU6.

1 Like

CTDs are really frequent on Xbox as well. The game can crash at any time, I think it’s caused by the data streaming, or when it actually can’t stream properly for some reason. I just lost a flight almost exactly 2 hours into it. It’s quite maddening.

The sim on Xbox can crash:

  • Right after the “Press any button to start screen”
  • On the World Map (I suspect because of the satellite image streaming)
  • While loading into a flight (again, probably because it can’t download the needed data)
  • In-flight, almost exclusively in external view (again, camera rotation might cause new data to stream in, raising the risk of a crash)

I’m not a software engineer but I do feel all this has to do with the constant data streaming. Either the servers can’t handle the load of more players or the client can’t handle something, but it’s clear that it is extremely unstable and nigh-on unusable, especially on longer flights.

2 Likes

If their hardware is fault free, their data upto date and in the right place and with all recommended steps being followed I really can’t see why anyone should be getting multiple CTDs unless they’re flying repeatedly into badly optimised scenery. Of course if you can’t do without XXX until their publishers have patched etc. etc. …

That’s just a personal opinion mind

If the internet can’t keep up the sim will switch to offline mode … tested by myself and it still works that way

Simmers,

I had luck with minor fixes at reducing CDTs since SU5, and 18.14 the sim was unplayable. With the successful minor fixes (thanks to the forum) I was able to load up and fly, but still averaging about two an hour the last couple of days. Best luck I found at the time was turning off live weather, live traffic, and multiplayer in the (general options-data tab) and limited my card to 50 fps in the nvidia control panel. That said, I was able to fly, but still getting CDTs in game and at initial load of the airport.

I did a clean install of the game, and still CDTs.

Yesterday, I reduced my graphics card by 150 hz, and I have been playing the game with all settings on, and havent had a hiccup or CDT since.

Hope this helps.

Cheers.

1 Like

Since Hot Fix #2 following SU5, opening the VFR map is very laggy although it is fine once it has been opened. It takes a couple of seconds after pressing the “V” key before the map actually appears. On one occasion today it caused the game to crash.

I freshly applied new thermal paste to my 1080, my temp went from ‘limited’ to 82° C and (thus) throttling, down to 62°C and smooth higher overclock. Then did the same for my CPU, lost ten degrees, now running MSFS max 50%, computer now smoother, no CTD’s.

2 Likes

Well, finally I got the FBW A320 to not CTD on a route that consistently crashed for me before throughout the last few patches.

I forgot I had something called AORUS ENGINE installed, which was controlling the clock speed on my MSI 3070 RTX Gaming Trio. It was set to default, but I nudged it slightly down (1800mhz to 1779 on the GPU & 14000mhz to 13756 on the memory clock). Apparently that was enough to run stable flying on approach right over the busiest parts of NYC. I do have a 650W Gold eVGA PSU which is supposed to be enough for this setup. And haven’t had crashes or instability with any other programs. Make of that what you will, I’m just very happy to be back up and running.

1 Like