Repeated CTD's 1.18.14.0 & 1.18.15.0

Moved along with the glass cockpits to a separate core I think but you are right it shouldn’t take so long. At least it works but I’m guessing it is still open to refinement. We might get a fair few similar cases before they give the Microsoft compilers a free hand because the resulting code is a lot harder to pick apart (I read that once, it was a while back so any of you coders are free to correct me).

1 Like

This is garbage. My application will no longer launch. I have been a pilot since FS 1.0 and I tested Alpha for you Microsoft. I am a Premium owner and just requested a refund. Until you can fix your product, I will take back my wallet, spend my dollars on other flight products and watch from afar while you get your quality control, under control.

This post was flagged by the community and is temporarily hidden.

1 Like

I don’t understand why Asobo is not putting this as a high priority … I get CTDs all the time now … why are we getting mandatory updates and why is CTD fix moved to end of August? The game is Unplayable… I stream it as well, and now I can’t even do streams :frowning:

1 Like

Not high priority?? There’s been two hotfixes in quick succession since SU5 and Jummivana said she won’t rule out more … The end of August update is not a CTD hotfix but the DACH install that will also include improvements to aesthetics. In the meantime you must follow every advice to ensure that your PC or the software on it is not the cause of your problem.

Sorry if that comes across a bit short by the way but I’m sure that Asobo and Zendesk are working flat out

Im running:
i5 9600k at 5 Ghz OC
RTX 3070 (non OC)
32GB RAM

I had CTDs after SU5. Sometimes the game and hole PC freezes and reboots. After i read some statements here that some people tried to undo their OCs on CPU i tried it myself.

My CPU now runs at 4.6ghz stock clock speed and i limited frames to 30 fps.

I tested KJFK at 1440p ultra with stormy weather. No CTD this time so far in 30 minutes. Have to try longer though.

I think CPU OC was the problem.

SU5 and the scenery culling utilizes the CPU harder than SU4 did.

Well these two updates seem to have resolved vast majority of my CTD’s

1.18.14.0 fixed pretty much all the general sim CTD’s
1.18.15.0 and FBW A320nx 0.6.3 seems to have fixed CTD’s on loading aircraft

I’ve stilll had a CTD when slewing around a city at very high speed probably related to scenery loading / memory leak but otherwise I’ve been able to do a few stable flights without issues.

So good work from Asobo from my point of view - they also fixed the other 2 major bugs I was suffering since SU5 namely speedbrake toggle and weather ISA high-altitude which were major inconveniences so great fast response rolling out those updates as well.

And this is all on my ancient and highly overclocked / unstable original i7-920 @4Ghz with 12GB 1600Mhz RAM (not ofiically supported on old MB) and GTX-960 GPU overlclocked by 20% - so if you’re still having CTD issues I’m pretty confident they would not be related to overclocking !

(When I do get crashes due to the old overclocked system its a blue screen / freeze / instant reboot which I’ve always had prior to MSFS 2020 - not related to Asobo CTD’s)

1 Like

Yes and no … it’s the high end overclockers having problems simply because for one reason or another the scenery data doesn’t want to be pushed that fast. A pound to a penny most of their problems would stop with a manual cache (that’s if their system is correctly balanced which sounds a lot easier than in truth).

I have had more CTDs since SU5 than at any other time. Unfortunately I cannot recreate any of the CTDs consistently.

I’ve started using Discovery Flights for quality testing. Recently I chose one of the Discovery Flights as my first flight for the day. CDT occurred when loading the flight. After the crash, I rebooted to start clean. Used the same Discovery Flight for the first flight and it worked perfectly. Did MSFS magically fix itself? Exited MSFS and rebooted. Started MSFS and used the same Discovery Flight. It loaded fine but CTD occurred about 15 minutes into the flight. ■■■? I am not making any changes in an attempt to determine the root cause because sometimes it works fine. I am not going to try anything in a attempt to find a workaround because MSFS right now is very unstable.

yes for me too. I had also more CDT’S since Su 5 then any time before

Really scientific that is :upside_down_face:
However and I really have no sympathy because you won’t lower your OC but I suggest you load a large area into a manual cache onto your fastest drive and switch to offline. I would be interested to see if your PC handles it better? … or worse??
check fps at the same time.

Hardware over/under clock is automatically done dynamically since last August.

Nothing indicates that using a manual cache or going offline will fix anything. I’ve used rolling cache and on-line since last August.
FPS is zero when CTD happens before flying. When I am able to fly, FPS has dropped fro 30+ before SU5 to 20-25.

If there is a problem with overclocking or rolling cache, Asobo needs to inform everyone what changes were made in SU5 and the hotfixes and why. Speculation: Maybe there is new code which is very timing sensitive that doesn’t work with overclocking. If so, have a DANGER warning message at startup.

Bingo!!! … Quiz Asobo and you will undoubtedly learn that this is how some of us got such a boost with SU5

All your OC’s will have to be from scratch, currently the imbalance is too great

Just to add my experience: everything worked for a year up until SU5. After SU5 and each of the following two hotfixes I have not once been able to successfully enter a flight. I get an immediate CTD without error message as soon as I click on the Fly button. Attempting to change the weather in the world map also seems to trigger a CTD.

I have nothing in the community folder, all packages updated, all hardware running at factory clocks, and otherwise a stable and well-functioning computer.

Windows event viewe logs the following error:

Faulting application name: FlightSimulator.exe, version: 1.18.15.0, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version: 1.18.15.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00000000026b50b8
Faulting process ID: 0x4e24
Faulting application start time: 0x01d78dc4d01c1751
Faulting application path: D:\steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: D:\steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Report ID: 40b7443a-4173-4873-999c-9c16b944cdf6
Faulting package full name: 
Faulting package-relative application ID:
1 Like

I only had 1 CTD up until SU5 (approaching a bugged default airport back in 2020)

Post SU5 i’ve had 3 CTDs, all 3 on the menu/world map screen, when i quickly zoom-in or out or move the camera quickly when in high quality satelite view.

No mods for above CTDs (Clean community folder)

No OC, Stable system with Prime95 Mem and CPU stress tested, Furmark GPU stress tested and other PC games are stable.

Any other mods or 3rd party at all? anything non MS or Asobo needs to be moved out of official to test and anything in startup disabled and if they are not included in the latter G-Force Experience, AMD master, Aorus, MSI Afterburner, or whatever apps came with your mainboards and hardware should at least be temporarily disabled.

I think that’s probably one for Zendesk, Asobo changed the menus recently and genuine bugs are not always picked up.

I made the exact same find independently.

I never had a crash, before or after SU5, with my RTX 2070 running 2560x1440 at a mixture of High End and Ultra settings. Yesterday afternoon, it suddenly crashed soon after entering the plane with a BSOD indicating graphics card error four times in a row.

Remembering that I had cranked up a few settings shortly before the end of my last flight the day before, but unable to remember which ones exactly, I decided to use the global High End and managed to complete a 3 hour flight with no issues (and FPS above 50!).

I have always capped FPS to 60 in nVidia control panel to relieve GPU stress in the menus, but I plan to reduce it further to see if that’s another way of eliminating the crashes. In fact, removing a modest OC that I had forgotten all about may prove sufficient, and is the first thing I’ll test.

If only one could feel certain after a few hours of crash free flying…:cry:

Believe me it will all be worth it in the end. I’m CTD free so it’s easy for me to say but I am more than impressed at Asobo’s ability to manage an engine rewrite “on the fly” so to speak. Lots of [not too] unexpected problems but complaints have dwindled fast so it seems they are quickly getting their ducks back in a row although I’m sure there is still much to do. Of course this still doesn’t help those who are still suffering. :slightly_frowning_face:

Same worked fine for me until the .15 hotfix. Ryzen 3600. Rx 5700xt.