[Resolved] Atrocious FPS after the newest update

Downloaded the newest world update, and it’s time to see how many new bugs there are!
Previously I ran the sim at a decent framerate at about 18-20-22 fps ranging on custom settings (around low because I’m on a laptop currently, and my desktop has been getting a repair for a while now.)
As soon as I load into the menu I notice something is wrong and I realize it’s the framerate. The framerate is literally at around 3-8 fps. I check the settings, and I lower all the settings down to the lowest. Still no change. I lower the resolution! down to 320p or something. Still no change.
I’m beginning to get a bit frustrated.
But Wait!
I decide to go into the Usercfg to lower the settings to their LOWEST. The LOWEST OF LOWS. Still no change. In fact, I think the sim is ignoring what I wrote in the UserCFG, because instead, it still keeps buildings, grass, high textures, and whatnot. I try default aircraft, and still no change. The sim just flickers black randomly in the cockpit and rarely in the chase viewmode.
I’ve checked my drivers and even installed the latest version of windows. And the sim still run as it used to.

Can someone pls help?

Please join one of the MANY threads already open on this subject. Thank you.


Or consider this…



It looks like there was a referral to the main thread. Closing the topic.