Reverse thrust broken

Please tag your post with #pc and/or #xbox.
#pc

Are you on Steam or Microsoft Store version?
Microsoft Store

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
Throttle Idle is jittery, when pulling throttle to idle it may or may not go back to 0. (As if throttle peripheral idle is not at position 0.)
(see screenshot)

Hold Throttle Reverse Thrust functionality is broken.
Expected functionality: When throttle pulled back to 0 then pressing Hold Throttle Reverse Thrust, then pushing throttle forward, engines should go on reverse thrust.
Issue: Reverse thrust does not engage, instead throttle increases.
(Same is true if Toggle Reverse Thrust is used.)

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

  1. Map Hold Throttle Reverse Thrust to a button (either on throttle peripheral or keyboard)
  2. Load any reverse-thrust capable plane (e.g.: Cessna Caravan 208b or Airbus A320)
  3. Set throttle to 0.
  4. Press Hold Throttle Reverse Thrust button
  5. Increase throttle

PC specs and/or peripheral set up of relevant:
Thrustmaster TWCS Throttle

Build Version # when you first started experiencing this issue:
1.21.13.0

Workaround.

Decrease throttle - assign key or button

Press and hold “decrease throttle ” instead “toggle throttle reverse thrust”.

5 Likes

Excuse me, but how is “Decreasing Throttle” any kind of work-around for the LACK of reverse thrust?

8 Likes

Yup no reverse thrust control anymore. How is it possible that they keep breaking stuff like this.

21 Likes

Thank god, I thought I was the only one!

There is a jitter close to throttle zero, too, which makes me suspect that it wants to set idle at around 20%. But it’s inconsistent.

However, I set the reverse throttle on the FBW A32NX up previously after their 0.7.0 update, via the Flypad, and lo and behold, my FBW A32NX still has proper reverse throttle, just like I set it up.

But the Caravan, the default A320 and the others are screwed at the moment.


(And it looks like a bunch of community mods are not working as well.)

2 Likes

Yup, confirmed. Toggle reverse thrust is broken too, oddly it engages briefly if you put throttle to 100% then switch it, but as soon as you move the throttle lever it disengages again. It’s completely broken, game is near unplayable for me now as this is really important for me to land the bigger airliners decently.

Can’t believe this slipped through

9 Likes

Toggle Throttle Reverse Thrust is broken as well on any jet I tried (does still work on TBM). Will try the decrease throttle workaround but hope they fix the toggle method.

2 Likes

I submitted a Zendesk ticket - I believe everyone else should do the same. Hope this gets flagged ASAP

6 Likes

Yeah, toggle reverse thrust makes the thrust lever jump back and forth between max and min 5 times a second. The FlyByWire A320 has a “built in workaround” (see above), but it’s a pretty big issue for all the other reverse thrust capable planes, especially the jets.

It looks like changing time of day inside the game is also borked. (still testing)
Caravan mod makes the plane invisible from the inside… there’s a lot going on today.

2 Likes

I have the same problem, all jets. I mostly fly the Longitude and I noticed this is broken right away. I tried several changes to my controller, settings, etc. to no avail.
I also submitted a Zen bug report.

So, here we go again with these ■■■■ updates. Sure, add planes, all the updated airports (which???) and even “improve” functionality… but not test it.

2 Likes

Yep, it’s absolutely like they don’t have a testing team. Microsoft, please pay me a living wage to test all your aircraft before updates :slight_smile:

9 Likes

Same problem:-(

Same on Xbox

Par for the course unfortunately, first they broke autopilot, next it was altitude & speed tape, then flap drag, after that there was the issue with serious performance degradation, followed by broken Garmin systems, followed by trim that didn’t trim 100% and lets not forget the Crash-to-Desktop epidemic.

10 Likes

Same here… but on my Boeing 787 it is working fine… only my fighter jets it seems it is not working… also with the new F-18… i only get up to 80% power… any help with that as well??

1 Like

I don’t understand. It’s wild! They rushed to make money on DLC, but can’t fix the core game. Sounds like alot of sub-par game studios to be honest. I had my hopes up for Asobo and the like, but man… kind of making it hard to say MSFS 2020 is actually a good sim :frowning:

9 Likes

Yep same here. For now I’ve bound the same joy stick button to the ‘‘decrease throttle’’ function but that function lacks fine control. It’s like they don’t test all basic functionality of the sim with a check box list before pushing out an update.

3 Likes

I can confirm this issue on Xbox with the default A320… Haven’t tried the other default airliners

Edit… Issue also exists on the 787 and 747 as well

1 Like

Yep I did exactly same thing… It works at least but yes the lack of control Is quite anoying… Another update and bunch of newly broken things :frowning:

So if I understand it, you binded the button to both engage reverse thrust + decrease throttle?