RTX 4070 Ti - Quest 3 - Virtual Desktop question

Hoping somebody can help as it’s driving me crazy.

Brand new PC (specs below) running a new installed MSFS 40th edition on Steam (NOT MSFS X:Steam Edition) and I can’t get the graphics to look as good as what I expect them to look for the spec of my PC on VR using a Quest 3 with a dedicated and stable connection/router (see connection stats in the Virtual Desktop screenshots). MSFS on the PC looks amazing and runs great on Ultra settings so I assume it’s a Quest 3 connection thing

I have tried many, many different settings and software I have found on the internet and YouTube and after many tweaks it now looks good enough to use but still not as good as it looks on the PC or other videos I have seem on YouTube with VR using lower GPU’s.

I have attached screenshots of everything so that you can see my settings and hopefully someone will see if I am doing anything wrong.

PC Specs:

  • It’s a brand new PC and I have removed all bloatware and setup for gaming using Steam games only
  • Unlocked Intel® Core™ i7-14700K Processor - 14th Gen - 20 core - 3.4/5.6 GHz - 33MB cache
  • Graphics: NVIDIA GeForce RTX 4070 Ti 12 GB GDDR6
  • 32GB RAM (6000 MHz)
  • 1TB SSD + 2TB HDD (all game files installed onto 1 TB SSD)
  • Liquid Cooled

Broadband:
Sky WiFi Max - WiFi 6 with a wired dedicated TP-Link Archer Air E5 Wi-Fi 6 router just for the Quest 3 which is in the same room as the Quest 3

Software I am using:

  • Virtual Desktop
  • DLSSTweaks
  • OpenXR Toolkit

Thanks in advance.


OpenXR-Toolkit-and-Virtual-Desktop-In-Game-Settings
Virtual-Desktop-Connection-Settings

Virtual-Desktop-Streaming-Settings

VR videos on YouTube always look better than what the user actually sees through the headset because they do not include all the issues the headset lenses create on the way from display to the user’s eyes.

Couple of quick suggestions:

  • check ‘Automatically adjust bitrate’ in VD because wasting bandwidth just increases latency without noticeable visual quality gain
  • either use FidelityFX sharpening in MSFS or the VD sharpening but not both because double sharpening can cause shimmer
  • Set Gamma in VD to 0.75 because 1 is too overexposed in the Q3 and then also try unchecking “Increase color vibrance” to avoid cartoonish colors

While I’m sure you can get pretty good results with VD, I recommend you at least try Link with a decent Link cable. I’ve found that I always get the very best/smoothest results with Link (better distant clarity and 7-10ms less latency).

I have provided my Link (and Air Link) settings in a separate thread and you may want to review those and give them a go. I have a bit stronger rtx4090 gpu but since you have a bit stronger cpu (compared to my i913900k) I think you’ll find the setting should work out ok. With these, I haven’t found it necessary to use OpenXR Toolkit anymore btw. Also, I haven’t seen any significant differences for Air Link at 200mbps dynamic bitrate vs VD at 130mbps av1 (Q3) or 150mbps hevc (QPro) wireless clarity/performance.

Anyway, up to you if you want to try these.

Thank you for your quick reply and suggestions. I will try them and let you know how I get on.

Thank you! I haven’t got a proper Oculus Link cable but will try the one I do have that I have used in the past along with your settings from your other post.

I’ll let youi know how I get on.

1 Like

Link cable is always wayyyyy better
I have i7-9700 8 core
Nvidia 1070ti (not too good)
Using WiFi was always bad but when I got a link cable (Amazon knockoff cause I don’t want to pay an incredible amount of money for a special Oculus one) it’s ultra smooth. And looks pretty good.
I have a Meta Quest 2

1 Like

Great, thanks. I’ll giver it a go!

1 Like

Try other codecs for VD - I use H.264+ at about 150Mbps. Also, instead of SSW automatic, try “Always enabled” which should lock in at 36FPS.
Make sure you are really getting 5.6Ghz on the cores that are used for MSFS - actually use some tool like CPUZ to make sure and maybe Process Lasso. You don’t want to be using “ecores”
Some of your MSFS settings look maybe too high - try reducing some to make sure that when you set SSW to disabled as a test that FPS as shown by OXRTK is maybe at least 40 and above so you have some headroom for a locked 36FPS with SSW enabled always.
I switch to TAA in MSFS just long enough to see that my final resolution (no matter what I have set in VD and OXRTK) is at least 2500x2500 or so - that seems to me to be clear enough on the instrument panel - then switch back to DLSS if desired.

There will still be some stutter - particularly when looking sideways - but it should be mostly locked at 36FPS and smooth. MSFS just can’t give you the performance that maybe DCS World can - with it and your system, you can get at least 72FPS most of the time. Some folks set RivaTuner to 36FPS but I don’t get the improvement.

Thank you. Some good advice and settings for me to have a tinker with.