RTX3090 constantly at 85%+ even on main menu

msfs3090
I’ve got an AMD 5800x, 32Gb DDR4, RTX3090, 500mbps internet on Ethernet and load times are insane. In diagnosing it appears that from the startup of MSFS2020 the GPU gets hammered when loading and even when displaying the main menu sits constantly at greater than 85%. This never lowers, ever as long as MSFS is on the screen.

Performance is mediocre and choppy when actually flying in my Quest 2 with Oculus Link (hardwire USB3).
Any suggestions?

Edit to add that I’m running an updated Windows 10 machine with the latest World Update (USA) and hot fix. I have it set for DX11 and mostly high graphics not ultra.

The load times, stuttering performance, frequent hourglass pauses of greater than 30 seconds mid flight are essentially making me not use the game.

  1. Buy a Reverb G2, much better headset for MSFS, although I still love my Quest 2 for roomscale, active games. But a G2 will give you better visuals, clarity, audio, comfort and performance.
  2. Limit your max frame rate to 40 fps in the Nvidia control panel for Microsoft Flight Simulator.
  3. Learn how to use the OpenXR toolkit.
1 Like

Did you think you had a strong gaming PC? Well, sure you do, but Flight Simulator thinks otherwise. Welcome to the club, and to the forum.

2 Likes

Amazes me how many 3080 / 3090 owners have so many issues yet here I am with an 8700k, 1080ti and getting sold 30fps in 2k res with high-ultra settings (photogrammetry off), AIG traffic, no stutters.

I see this complaint not just from 3080 / 3090 MSFS users, but other titles like Elite Dangerous, Cyberpunk, Elden Ring … So it seems not something exclusive to MSFS for people with these high-octane systems.

That’s because even on the main menu, the sim is rendering full quality models in the background. I’m not sure that you noticed but behind the menu UI, you should see there’s a hangar fully rendered, with the latest aircraft sitting inside the hangar, fully rendered both the exterior and the interior as well.

So even when you’re just on the main menu, the sim still continuously rendering this.

In terms of your CPU, have you tried using the DEV Mode display FPS function? It will always tell you where the bottleneck is. I also had a few stutters and low FPS on my Intel i9 CPU. But when I followed this guide, it actually solved a lot of my FPS and stutter problem.

I believe there should be a comparable function in your AMD bios that can disable the same virtualisation feature.

1 Like

It’s all about balance and optimisation. You can have a 3090, but a Pentium 1 CPU, and your GPU won’t have anything to render. Same thing goes the other way too, you can have an i9 or a Threadripper, but without a good GPU, it won’t be able to render anything and your CPU will just sit there doing nothing.

It’s what they always say, your PC is only as powerful as it’s weakest component. So a GPU needs to be perfectly paired with a CPU that can match the performance of the GPU. And the CPU needs a GPU that can render as fast as what they can process. One component that’s imbalanced with another will just be a waste of money.

1 Like

Try another Nvidia driver, some of them tend to “overstress” the usage.
Some people say, the card must work at 100%, others, like me think;
When the FPS rate is ok and there are no stutters and a good visual quality,I
don’t bother about a card usage of 45-55%.

Scott

1 Like

Just what I say to clients I build systems for. Some have said they`re not bothered abou t a powerfull CPU if they are having a 3080/3090 installed. I have built systems that are balanced but less powerfull than top end mix and match ones bought in store. Mine will outperform them every time. So balance it, and take the hit by installing known good components. You wont regret it.

1 Like

This and not much else

2 Likes

This, and all of the replies have been super helpful. Thank you! My going in position was that rendering at 85% in the menu meant something was incorrectly configured or otherwise “wrong” but knowing that it is indeed rendering 3D models when I perceive 2D menus makes way more sense.

As far as my CPU, I’ll focus on it and try the virtualization optimizations. I hadn’t considered it as a bottleneck as it’s usage is never more than 40%, however it looks like that could be misleading.

Got to admit that I’m sitting here in awe that anything could destroy a 3090 like MSFS is… that takes serious talent :-).

It’s remarkable how helpful you all have been. On Reddit I’d be downvoted to oblivion by now. Will continue to hang out here as I increase my 400hours of FS time.

-Jim

3 Likes

Yup! There’s that.

sorry about posting about the wrong thing, i jumped to conclusions too early, i missed the problem of the Quest2 you are having.

Set the ingame graphics menu to 30 fps (which is a frame scaler to 50%)
The game knows three settings 20, 30 and 60 fps… but they aren’t FPS… it’s a scaler, turns out after some testing my computer is trying to produce more frames than it can manage at all at 60. My monitor is at 75hz, when i put the ingame to 30 fps, the devmod tells me it’s producing 37fps, and at 20, it’s at 25 fps. So basically, frying all of our systems at 60 fps. That’s part one.

Part 2: with the oculus app, set the device to 90hz and the slider to 1.2.
then get yourself oculus tray tool.

Go through the menu’s:
Game settings: Default super sampling 1.2, leave default ASW at off for now, (later try the 45 hz forced setting) Adaptive GPU scaling off… dont touch the rest of the game settings.
next up is Power options, USB selective suspend off (do this every startup of the tray tool, it just wont stick.)
next go to quest link tab: select the preset to start with at the highest, which is the rtx 2070+ and once expirimenting with this default, set the bitrate to 0 (as that is actually default)

Also, ingame, set your Scaling to 100 also the detail to 100 and restart flightsim. As these settings just wont stick with “save and apply”.

I’m running the rest of the ingame settings on ultra on a 1080… just a slight stutter when taxiing, when the whole world moves around, but overall a pretty good experience on monitor and in the quest 2.

Hope it helps, enjoy m8…

anyone do a trenchrun in the 146 yet? (south of Amarillo,TX there’s a nice one :wink: )

Woof ~ Woof & Salute!

Steiny

edit, once you get a smooth ride, just up the settings one by one, but please try to enjoy yourself when it 's not choppy, dont blind yourself on frames per second… i did that, and it anoyed the hell out of me. I now start up msfs to enjoy myself, not expiriment endlessly because someone has made a goggleset that makes us look through it in 3d, but failed to implement proper userfriendlyness concerning the titles we actually play)

1 Like

Yes the archaic 60 30 20 is actually full/half/third (*Asobo please add quarter!) and is an embarrassing example of old base code when we all had 40lb CRTs that ran at a max of 60hrz

Edit: in pancake mode (grr) I run my monitor at 120hrz and use the game vsync and the 20-1/3 setting for a 40fps cap

oh and meow

3 Likes

Update from trying your suggestions this morning. I first disabled virtualization in the bios. Then turned on dev mode to investigate further. I found that I was rendering the main menu at 238 FPS. (!!!)

Insanity. I then went to the NVidia control panel and limited the frame rate to 30 for background and 60 for max frame rate. This immediately brought the main menu use on my 3090 from 85% constant to 20% constant.

After playing with the in game frame limiting option, I found the same thing that you all mention above, that 60,30,20 doesn’t actually mean what it says, so I turned off in game V-Sync and used the NVidia control panel option alone.

I finally got into a game and the load time was dramatically reduced. It’s still long, but absolutely manageable now. Even more amazing is that all the suttering in the game just vanished. Stuttering I don’t even think I fully knew was there because it is so incredibly smooth now. The dev mode graphs show me locked in at 60fps solid in VR mode. I’ve got my Q2 set for 90Hz refresh rate in the Oculus app and while I could probably tweak further, I don’t want to touch anything.

The difference when it runs smoothly is hard to describe. It’s amazingly better now. No more hour-glass turning pauses, frozen VR, or even a micro-stutter. Just butter smooth.

I changed too many things at the same time to validate the actual solution but I suspect that it was the disabling of virtualization. I played around with the FPS limiting between native MSFS and the NVidia control panel and while I saw changes none of them made me go back to the stuttering I had before posting this thread.

So to future folks like me who think they have a high-end system. Spend some time doing the suggestions here and elsewhere for graphics optimizations and the difference will blow your mind.

Thank you again all!
-Jim

6 Likes

My suggestion, rendering the background model on the main menu is completely unnecessary. What players want is a fast loading game and a smooth and stable main menu.

3 Likes

This is why I troll this forum, glad you got something from my suggestions.

1 Like

Absolutely… but the Devs completely missed this point and created a “Low Power Mode”. I’m not kidding. Wouldn’t believe it if I hadn’t seen it for myself in the Live Dev Q&A from May 25th:

Live Dev Q&A - May 25th, 2022 - Community / News and Announcements - Microsoft Flight Simulator Forums

Note: that link will take you to a post containing a link to the video as well as a complete, written transcript of the entire Live Dev Q&A! Thanks so much to Moderator @N316TS for tackling the tedious job of transcribing the entire session!!! So much information would be lost if we only had video. Greatly appreciated!

Yeah, it was clear in the last Q&A that Seb did not undertstand the problem we have been complaining about.

1 Like

But there are several options to use a power use limitation (just not so adeptly named) you can use your video cards drivers or you can use the games V-Sync as described in my previous post.

not to be insulting but it’s I don’t like this and there’s a button I can push but don’t want to?

Maybe that’s because it’s so easily worked around that it’s a non-issue in the first place.
Limit your FPS to 60 or so and forget about it. :sunglasses:

Entirely not the point.

Most of the fan base has come out and said hey, this is stupid and we don’t want it.

OK low power mode.

NO. We said we don’t want it.

And this isn’t the first game to run up against this.

Think about what you are saying, the user should have to workaround the menu, the first thing you encounter should not need a workaround.