Rudder issue after recent update

On my XBOX I am seeing that the rudder controls have become wonky after today’s update. Using either my XBOX controller or my TB VelocityOne Flight the rudders will respond to the command input but then return to the neutral position regardless of me holding the rudder input on either controller.

In other words, when I hold the rudder full right (or left) on my controller it returns back to center in the sim. I see in the input screen (where you can change sensitivity etc.) that the controller input is read and held correctly but the control surface on the aircraft still goes back to neutral.

Anyone else seeing this?

Yes, on PC!
The rudder will initially go right or left, but the re-center very quickly even when I’m still holding right or left.
Forget trying to steer at all.

5 Likes

I found the fix via search, at least for me.
Try turning off Auto-Rudder under the Assistance options.

1 Like

Didn’t seem to fix it for me on XBOX - on the ground at least. Seems to be ok in the air now though.

At the end of my first flight after the update, my rudder developed a life of its own at the destination airport. When pressing my rudder pedals in either direction and holding it there, the rudder would randomly either try to center itself or steer in the opposite direction. On release of the pedal, the rudder position either got stuck or moved around randomly without any input. This issue only occurred while taxiing on the ground. When I used the rudder pedals while stopped or in the air, the rudder behaved normally with no uncontrolled movement. Disabling Auto Rudder did not change this behavior either. Restarting the sim magically fixed it for me. (We’ll see for how long)

2 Likes

I also tried a restart and there was no change to the issue

2 Likes

It only works if the Auto Rudder is turned off in the assistance settings and the aircraft is moving either on ground or in the air.

I had same issue. Checked to make sure Auto Rudder off then disconnected pedals and connected again, seemed to fix this for me.

And it’s back again. This makes me want to swear.

Solved - NO IT’S NOT - ONLY FOR ONE FLIGHT AND THEN IT HAS RETURNED
Powered everything down, waited a few minutes before restarting the system, and now all is working as before. I’m ashamed to admit that I forgot the first step in solving IT problems - ‘Turn the power off and on again’

Both rudder and throttle are unreliable for me. Rudder slowly auto centres regardless of whether auto rudder is enabled or disabled. Throttle shudders back and forth like it’s possessed. No additions in the Community folder so I’m a bit lsot as to what has caused a perfect flying experience 12 hours ago to end up in this mess.

Tried unplugging all peripherals, no change; reassigned key bindings, no change; reverted to default bindings, still occurs.

PC user
Basically, I have a nice decorative flight sim setup which is barely flyable, but then only if I remember to keep pumping the rudder pedals.

Sometimes in taxiing it just veers off in some random direction. Something is seriously wrong here.

6 Likes

Seems to have fixed itself here. Sitting on the tarmac I now have full control of the rudder.

I have the exact same issue. Was wondering why I couldn’t taxi to the gate. Could be two reasons: had too many drinks, or the rudder is broken. Seems to be the latter :stuck_out_tongue:

2 Likes

J’ai exactement le même problème j’ai essayé plusieurs choses avec l’assistance à décocher mais rien n’y fait franchement je regrette d’avoir acheté car à chaque mise à jour je passe plus de temps à dépanner qu’a volé de plus la mise à jour prend toute la nuit ce qui n’est pas gratuit aujourd’hui je laisse mon poste en français car j’en ai marre de traduire les gens je considèrent que quand on a pris mon argent on n’a pas cherché à savoir si j’étais français ou si j’étais anglais ou autre

1 Like

I had the exact same issue last night on Xbox Series S.

Noticed during the flight that the handling felt strange like something was over-riding my controls and it kept trying to self-center. Saw that all the Assists were switched on so I switched everything off (whilst flying) and it felt a bit more normal.

However after landing taxiing was impossible as the rudder wouldn’t work. Just kept trying to re-center itself. This is with all Assists off.

5 Likes

I am also having strange behaviors from the rudder on Series S using the joypad… Then I noticed that the rudder assistance info changed after SU7… Prior to the update it was only “Take Off Auto Rudder”, but now it seems that the Auto Rudder helps during take off and flying. Maybe this change has something to do with the issue.

Moderator Edit:
Hello
You have to go to options assistance piloting and disable everything except auto rudder for those who do not have a pedal and it works again dear me

bonjour
Il faut aller dans options assistance pilotage et désactiver tout sauf gouverne de direction auto pour ceux qui n’ont pas de pédalier et ça refonctionne cher moi

i need auto-rudder.
off is not solution.

All assists turned off and rudder still does not work correctly. Rudder re-centres when holding in full rudder deflection on controller. Planes impossible to taxi and fly.

3 Likes

I’m finding same issue with uncontrollable rudder since latest update: tried all 'planes in my “hangar”–all the same–checked on ground as part of pre-flight with rear camera–rudder just flicks to command direction, then returns to centre.
Going to try rudder pedal connection removal with power on with assist on then off.

1 Like

I eventually fixed this, after 12 hours of frustration, by removing the Rudder Pedals from Device Manager, and then unplugging the pedals from the computer. After restarting the computer, I plugged the pedals back in and waited for them to be recognised by windows.

Next I restarted FS2020 and found that the pedals were working once more.

Anyway, this has worked for me.

for me the pedals are working but they feel waaaaay too sensitive even with sensitivity allmost -100 at settings. Before they were fine but after the update this started…