Rudders on gamepad not analog

On the gamepad the left and right triggers are handled as digital inputs for the rudders. This means that if you press in lightly on the trigger, it gives input like the rudder is pushed in that direction to its maximum angle.

There is an entry for “Rudder Axis” under assignments, and this is an analog input. Unfortunately I can only assign either the left or right trigger as an axis assignment, and regardless of which I assign it will only input rudder left.

Is there a way to make the triggers control both left and right rudder using analog input?

12 Likes

unfortunately it’s been like this for a while I’m surprised they haven’t fixed this issue.

5 Likes

I reported this issue months ago and it is still not fixed even in release. holy ■■■■.

3 Likes

Really? Wow, so it is a bug?

That’s crazy seeing how this is a microsoft first party game with dedicated Xbox controller support.

It’s even more frustrating as the triggers can be seen as analog inputs when put into the “Rudder Axis” category… it’s just that you can only push the rudder left if you do that. I’ve actually been flying with only left rudder input, and aligning my landing approaches up to the right so I can actually use the rudder correctly.

Is there any file I can modify perhaps to manually enter the triggers as analog rudder inputs?

2 Likes

It is a bug. it used to work as expected in earlier versions of the game until they broke it.

3 Likes

interesting that was before my time.I find it incredible considering it is there native controller and they haven’t fixed it.

Believe me my blood pressure is rising as I type this. It’s unbelievable that they ship this game with a defect for a MICROSOFT controller, while it was reported months ago.

2 Likes

After doing some testing, it seems like the input is being read as both an analog and digital input when you assign it to the “rudder left” or “rudder right” input.

You can slightly press in on the trigger, and it will move only slightly then jam to full rudder then back to where it should be in analog. It does this constantly.

So yeah, I have it now set up so my left trigger is set to the rudder axis so I have great analog control on it. The right is set to right rudder, and is buggy like mentioned above.

I guess one rudder direction being right is better than none…

1 Like

This should have been fixed long time ago.
Please Asobo/Microsoft, this is standard controller input and needs to work!

2 Likes

Same problem. I’m baffled that a first party peripheral on a first party game doesn’t work and the devs seemingly haven’t acknowledged it, despite it being broken for a long time (from what I’ve seen other people posting, I just tried the game yesterday).

I’m not a “serious” flightsimmer with gear, but I was hoping to enjoy flying around with a controller. It’s the only real issue I have with the game.

5 Likes

@Jummivana please take note. Please tag the devs. We need this to work.

I submitted a Zendesk request, I’m sure others have. Hoping if enough pile up they’ll do something.

3 Likes

I hope it doesn’t get ignored like mine.

Send to zendesk.

I was so excited to play this game last night and now I have to wait for this bug to get fixed… I guess I can just fly without rudder, but I’m not getting the experience I wanted.

Hello @ll,

as per a request from a fellow beta tester I implemented this analog rudder on XBox controllers into AxisAndOhs a while ago. You basically just assign both analog trigger buttons to the rudder axis at the same time, and the app will realize that you want to split the rudder travel among the two controls.

Keeping in mind the current “stutter problems” with SimConnect apps, the app hasn’t been released yet. But you can try the demo version if you want, see if it does the trick.

Best regards
Oliver Binder
Lorby-SI

1 Like

So weird, This is like a basic, basic, basic problem. Xbox controller not working correctly with a Microsoft sim. Reported multiple times and listed as an issue in multiple threads…

And apparently nothing from Asobo, but a possible fix from a third party.

Seriously?

1 Like

Okay simmers,

here is a workaround to use the Xbox One and Xbox 360 (and maybe any other) controller’s LT/RT as the analogue z-axis to control the rudder as it is meant to be.

The basic idea is to install a virtual joystick and to remap the LT/RT z-axis to one axis of the virtual joystick. Then bind the axis of the virtual joystick to the rudder control axis in the game.

Step 1: Download vJoy from http://vjoystick.sourceforge.net/site/index.php/download-a-install/download an install it. After the installation a vitual joystick should be present in your device manager:

Step 2: Download UCR (Universal Controller Remapper) https://github.com/Snoothy/UCR and copy the files to a location on your device manually. Caution: Don’t use c:\Program… as long as you don’t want to start the application with admin rights.

After running the UCR.exe you have to create a profile first. Make sure you are choosing your controller device as the input device and the virtual vJoy device as the output device:

After creating the profile create an “Axis Merger” plugin with these settings:

Finally run the plugin by pressing the play symbol at the top of the window and do not close the UCR-Application.

Step 3: Bind the new settings in Flight Simulator 2020. First move to OPTIONS -> CONTROLS and unbind the LT and RT from your controller settings and apply your changes:

Then move over to the new VJOY DEVICE, bind the Joystick-Axis X to the Rudder Axis and don’t forget to apply your changes.

With these settings I finally managed to fix the poor implementation. Good luck to you.

3 Likes

Thanks for this workaround.

Unfortunatelly it doesn’t work.
I’ve gone through all the steps, but when I finally load MSFS, I am no longer able to choose my xbox controller as an input device. The screen in MSFS only shows Keyboard, Mouse and the new VJOY device. But no controller anymore.

Any advice?

Oh, and there is another difference to your screens.
In your Axis Merger screen, it shows Axes LT and Axes RT for Axis low and high. But when I press my triggers it shows Axes Z and Axes Rotation Z. But, after binding these in the Merger and pressing play, the trigger axes work, you can see it in the overlay on the blue axes fields.

Okay, let’s look into this. Do you see both (controller and joystick) in the gamecontroller panel (windows control center -> gamecontroller)? Like this:

image

With properties you can test input when you move the stick of the controller:

image

image

And if everything works properly, the LT/RT-axis is remapped to the vJoy joystick.
When this works we’ll look into the Flight Simulator settings in the next step.