Runway lights issue

I just checked it out: no problem without mods for me. Some screenshots - and please excuse the sloppy hand flying: I was more intent on the lighting and screenshots than I should have been!

And the airport looks pretty good at night! Have not done that flight before.

1 Like

Seems to be a fly tampa thing

What is the best way to let them know there is an issue?

Not necessarily a flytampa thing. Weather depiction, advanced airlines, terrain, and any high detail airport all add loads that fuel an out-of-memory (OOM) state due to memory leak and the resulting LOAD-SHEDDING once a threshold has been reached in order to prevent blackscreens and ctd.

Instead of blackscreens in the aircraft or ctd it is now blackrunway😭. Fairly sure this is caused by the sim in order to prevent OOM state. Load out distance, terrain detail, runway lights and PAPI all seem to be on the chopping block.

The only way to reasonably manage it is too start with a wall socket restart and 8GB rolling cache rebuild. Making sure any flight planning that required looking at navaids and zooming on the resource hungry world map is done prior to restart with a simple load pln and reselection of departure gate the only few actions on the world map prior to starting flight. In addition usage of exterior views and drone, along with flight tablet should be limited until after arrival at destination. It may just be the straw that broke the camel’s back.

2 Likes

I wish it was the straw that broke the camels back, but it happens every flight eek

Update: issue seems to be getting worse now, many lights are now floating and no runway lights at any airport I fly to. Runway does not even render properly when landing.

Does anyone please have a solution? I’ve had this working before and do not know what has changed

Its difficult to help because it works fine in the vanilla version. So an addon like flytampa is causing it. The only thing i can suggest is removing the addons one by one until you determine the guilty addon.

It didn’t work with vanilla either, that is my problem. It now doesn’t work at all. I uninstalled Flytampa

Have you tried starting in safe mode?

Will that help with MSFS? Is there anything I can also do in game?

If you start the game in safe mode it ignores ALL addons, be it Official Marketplace or Community folder addons.

Not sure how to start in safe mode with XBox. With PC, you have to start the game and then force quit MSFS with alt+F4 or end the process from Task Manager. You will then get the prompt to boot normally or in safe mode when you next start the sim. I am assuming XB has something similar

You see the vanilla version still has the same issue, anyone know an in game fix as I now never have PAPIs when I land

Honestly the game is getting unplayable for me and no solutions have worked.

does it work?

No, unfortunately nothing has worked @Matrixuss

I’m also experiencing this issue, I’m on Xbox Series S and every airport I try to land there isn’t runway and taxi lights. This is in all airports and everytime.

It is so frustrating and disgusting. It ruins all the experience especially the flight.

Thank you! Please can MSFS be aware of this as I’ve hardly seen any big reports on it

Had it yesterday at the default LFLL on the Xbox.

It’s been happening intermittently for months. Inconsistently the same airport could be fine on one flight yet shows the error the next time.

1 Like

Glad now it seems it is not just my issue

I uninstalled the whole game and reinstalled and this is now what my airport looks like :frowning:

After any flight now it seems there are now runway/taxiway lights at ending airport

I tried to change some of the settings on approach so I could see the runway and then I got black screens, but this was able to be fixed as it came back after some time, but the runway lights are frustrating now.

Anyone have any more temporary/permanent solutions?

I understand the frustration. Especially on a new install of the game. does the same thing happen in both DX11 and DX12?

I assume this should read “…there are no runway/taxiway lights…” as it seems the reinstall didn’t fix your issue.

Did you test with just a plain vanilla install after your complete reinstall of the whole game and before reinstalling any add-ons?