Saitek radio panel not working

I have scoured the web trying to find my current issue and i cannot solve it.

My Saitek radio panel is not working. When i reboot my PC the screens flash twice with all zeros. once for about a second. then again for about 2 seconds. then it goes blank never to turn back on. I have tried the following

  1. downloaded the flight sim plug in from the Logitech website
  2. tried the reg edit hack here
  3. tried stopping the plugin and restarting when the flight sim is open
  4. turned off all power saving for USB hubs
  5. tried multiple usb ports
    restarted PC multiple times and the issue is the same. 2 brief flashes of 00000000 on the screens. then nothing.

all of these fixes for the panel that I’ve seen here has been attempted to no avail.

my PC shows the radio panel in devices and says it is working properly. All other devices (switch panel, yoke, throttle, and rudders work fine)

Any ideas would be a huge help. thank you!

Download the Logitech Flight Panels Test Software to validate the panel works well.

1 Like

I ended up buying No issues now.

1 Like

You’ll have a lot more flexibility with that software, and can customise exactly how you want things to work.

Yup. The best thing is having profiles for each aircraft automatically selected by spad

1 Like

Did you actually load into the flight as it only turns on when I start a flight.

I did the same. everything works flawlessly now. I had to disable alot of the controls for the yoke, throttle and pedals as MFS 2020 recognizes these controls so i was having some double input issues. Well worth it imo

I did i loaded in multiple times and fired the cessna up and still nothing.

1 Like

Ill give that a try. i downloaded and everything works flawlessly now but im determined to fix the problem. hopefully i can fix it before my 14 day trial is over. :slight_smile: Thank you for the reply!

Ok no worries just making sure :+1:

tried all of the above, I still cannot get my switch panel or radio to work, they are recognized, using the Test software, and in SPAD, but they still will not work in the sim… :frowning: Just dropped $2000 on a new mother board, CPU, and RAM, and now my pnales wont work… grrr… Maybe my USB ports, they are ALL USB3 now…

I was frustrated as well when I got the panels a few weeks ago and they didn’t seem to work, but then I switched from a 3.0 USB port on my PC to a 2.0 port and a powered hub (2.0 only) for all three work now with no problems. Still deciding on (my demo expires tomorrow) as the default Logitech software works in most aircraft for me and I don’t really want yet another piece of software running to fiddle with if I can avoid it.

1 Like

Thanks. which USB hub did you get, I’d like to get the same if able

I got this one:

1 Like

Download and install Microsoft flight simulator plugin.
Downloads - Flight Radio Panel – Logitech Support + Download

Launch msfs and go to controls options.
Assign key or joystick button to Toggle Avionics Master

apply and save

Go to world map and select departure > fly.

Pre-Flight Checks (example below).

  • before starting engine
  • starting engine/s
  • press toggle avionics master key or button

Tried this too unfortunately, no go. :frowning:

Try without

Becareful with USB hubs these panels draw a lot of power i ended up burning two hubs (over time) out until i realised they couldnt cope with the panels now my panels are into the main pc and have other things like track ir and headphones on the hub (yes it was a powered hub)

What motherboard you have?

MSI Z690 Tomahawk w/ an i9-12k, 64GB DDR5