Saitek Trim Wheel support?

While I do not see it on the official list, can anyone confirm if the Saitek Trim Wheel works, or can be made to work properly?

My Flight Velocity trim wheel isn’t on the list, either. I just plugged it in and it recognized it. The control setup in the Sim isn’t the greatest. I have to spin the wheel a lot. In P3D I have it configured through FSUIPC so the amount of rotation is cut way down. Now that the beta of FSIUPC7 is out for MSFS, I’m hoping it’s advanced enough for me to do the same for me as it does in P3D.

I don’t have a specific controlled called a “trim wheel”, but I have a Saitek X-52 which has a couple of rotary knobs on it that can be set as analog axes. I used one of these for elevator trim axis and it works SO MUCH better than pushing buttons.

1 Like

I would also like to know. I have it plugged it and it is listed in the controls but is greyed out as if the sim does not know how to handle it. Really missing the trim wheel - such a pain using buttons to set trim.

I have the Saitek Cessna Trim Wheel and the Saitek Cessna Flight Yoke. I have the same Problem.

I have the Trim wheel and got it working.

It recognises it but doesn’t assign an axis. Go to the trim wheel in the control setup and select the ‘Elevator Trim +100/-100’ then assign the axis ‘Joystick L’ (or somethign like that) it may come up with a warning but ignore it. Don’t assign any of the other options that have + or - in the name.

You may also need to delete the already assignged trim on the Yoke if you have it. Following that works like a dream.


For me this exact same trim wheel was working fine in the alpha/beta. Now there is no way I can make it work. I assigned it to Elevator Trim Axis (-100 to 100%) and it is recognized. I noted that the name changed (I can also see a 0 to 100% but no luck either). The horizontal scrollbar moves when rolling the wheel. But it does nothing in the aircraft.

Did you create a bug report already?

1 Like

oh, just after my previous message, I noticed a Toggle Elevator Trim possible assignment. Assigned it to a button and I hit it. Now the trim works !!
I was in the C152. Seems like the trim function is OFF by default and you need to activate it by some way. I will enter a but report for that.

1 Like

Thanks for the follow-ups!

Mine worked in the beta and now turning it isn’t recognized at all although the game sees the device and windows device manager see the axis turning.

Game doesnt detect it as an axis

Cessna flight yoke and trim wheel here, neither were recognized but both were fully mapable (except for the three position switch on the back of the right hand yoke) and once set up are fully usable.

I have the flight velocity trim wheel. While I got mine mapped the sensitivity is way down. In FSX its spot on. Wish I could adjust the sensitivity to it.

1 Like

Can you provide more details? I looked for a “trim toggle” and could not find anything like that in the controls. I have the Saitek/Logi Cessna Trim Wheel and would love to be able to use it. Thank you!


I have the standard saitek trim wheel works fine only thing is - which is same as mine
Was in p3d you need to roll the wheel backwards and forwards when you first launch the sim. Another thing is some control options do not seem to appear unless you go to the control page from an aircraft. When I first tried to map the throttle axis on my go flight throttle quadrant there was no option to do it only appeared when I went to controls from being ‘sat in’ an aircraft propeller pitch was also like this

Did you see what I wrote about “Toggle Elevator Trim”?

It’s there:

What is strange is that now that the wheel worked once, I don’t need to toggle elevator trim anymore when I run the sim, even if I run into a new aircraft.

I have found the solution to this problem, you need to map the Cessna yoke and trim and it’s very easy

  1. Change the type to essentials and compress the list

  2. Look for all you inputs and map them by the axis

  3. Map trim to -100% to 100% axis and put it on the y axis not minus or positive as this will make it go either way

I have my yoke and trim all mapped up and everything works fine.


I’m having exactly the same problem. I got the trim wheel to work in alpha / beta but I can’t make it work now. The Saitek trim wheel is recognized and I assigned ‘Elevator Trim +100/-100’ axis but it doesn’t work.

Correcton. The trim wheel was assinged “Elevator Trim Axis 0 To 100%”. When I assigned it to “Elevator TRIM AXIS -100 to 100%” it worked.