San felipe del Morro Castle missing

After having downloaded the Caribbean update, I’ve noticed that the above title is missing. Has anyone else have this problem…?

Don‘t forget to also install the free content in the marketplace!

Nope, it’s there for me. Make sure as NixieLion said that you’ve downloaded it from the Market.

Is installed so am bit confused about this.

I’d just restart MSFS. If that doesn’t fix it…
Uninstall WU16 and reinstall it. If that doesn’t fix it? I’m at a loss. I’ve never had anything (that I know of) like that happen before.

1 Like

Will do that and let you know

If the above doesn’t cure it, and if you have the Rolling Cache on, you could try deleting the contents of the cache.

Still not there. Re-downloaded the Caribbean World update and deleted the cache contents but problem still persist. However, strangely the other landmarks are there.

1 Like

Do you have photogrammetry on, if so have you tried with it off?

1 Like

Have tried it off but still the same.

Have you checked for a mod conflict?

Checking the mods now

1 Like

This is weird as all the other landmarks are fine. Just this one is no show. Have deleted the last installed mods but problem still persist

I’m standing by seeing what the solution might be, because short of a mod trying to change/replace it at that location which I would think you’d remember… I can’t imagine what would cause it.

To rule out that the latest WU could have a conflict with an older mod, it may be worth a try to start the sim in “safe” mode.
Safe mode starts up the sim with just the core files.

If the issue still exists in Safe mode, you may want to consider filling out (from the Support tab at the top of any forum page) the Submit a Request form for Technical Support to Zendesk, explaining what happens, and include a reference to this thread.

I flew over the area as well and had no issues, the fort was there.

1 Like

Thanks for that. Will look into it tomorrow

1 Like

Update: The mods are not conflicting with the missing castle as I totally removed all the mods from the packages and started a new file in community. However bizarre, the landmark is still missing.

Start the sim in safe mode to completely make sure.
With the sim running, use Windows task manager to shut it down.
When you start the sim the next time, it will prompt you to use safe mode.

1 Like

I would say we have an issue with the POIs pack here. The same problem happens to me with Saba Rock resort. Terrain is empty and main POI building is missing. Only the small dock is displayed. However I´m able to see San Felipe castle properly.

Take a look at dev console log, where several duplicated GUIDs appear on caribbean and other POI packs. I bet this is the problem.


1 Like

Have this problem too

1 Like