Scenery and airport not loading at arrival

Depends on the airport you’re in and the surrounding airports.

So far the lowest I’ve had to go is for LFPG and EGLL.

IFR: 85
VFR: 0
Static parked aircraft: 6
Radius: 50 miles

You can increase the settings for smaller airports but there’s no way to know without trying first.

Also, I removed AIG models from my community folder so that FSLTL does not use them. I have no idea though if that has any effect yet

Thanks. I just had a good experience with following settings

IFR: 75 (before 85)
VFR: 0 (before 7)
Additional parked aircraft: 1 (before 4)
Radius: 100km (before 150)
Blocked aircraft removal time: 60

No idea if maybe VFR (considered beta) had anything to do with it or the reduced static/additional aircraft. I just hope Asobo will at least update their SDK and include a max. figure.

Running into this at a variety of airports recently (granted they are larger airports) with reduced settings in FSLTL. The last time was with reduced settings for FSLTL and without GSX running at all. Really hope they sort this out in short order.

1 Like

Same issue here; AMD 5950X, PNY 3090, 64GB DDR4 RAM, SSD drives. 3090 only running up to 30-40%, CPU avg 10-15%; only about 25% RAM.

Major airports on arrival flat, satellite, or missing most everything. Just “started” recently. Work fine w/o GSX and/or FSLTL. Also found the new E-Planes add-on definitely made a hard hit in my case.

Also, in my case, with all above running (smooth steady locked 36 fps), a flight of an hour or so is fine (e.g. iniBuilds LAX to LVFR KSAN), but anything longer and near approach = low FPS, little to no arrival airport, or the old “two stutters and CTD”.

Something’s up… no luck so far. About to “dump” and reinstall fresh, but may wait until new 40th release next week.

Best to All!

Same Issue here…

I filed a bug report on this issue a few weeks ago. Feel free to share your experiences/screenshots with the issue, and vote.

Arrival Airports, Traffic, and FPS Have Disappeared - Bug Reports / Scenery and Airports - Microsoft Flight Simulator Forums

Just experienced this last night on arrival into Justsim LTAI in the Fenix. It’s definitely weird since the default airport is completely suppressed indicating the addon is indeed active, but there’s just bare satellite imagery and PAPIs. ILS was also functional and fine. I do wonder if this is the SimObjects limit. I had AIG active and GSX.

If you’re using FSLTL, there is a way to know if the simobjects limit is reached and your arrival airport will not show up.

In the FSLTL window, it will say that it’s removing AI traffic due to the sim being in a sleep state. Once this starts showing up, no simobjects including airports show up anymore aside from the ones already spawned in-game. The only way to fix it is to restart the sim.

Anyone stumbling on this thread, please do head over to this link and submit your vote there as the bug has still not been marked as logged. Airports not loading due to Simobject limits is a pretty critical bug that needs taken care of.

1 Like

This seems like an important detail. Could you post this over on the thread linked above, with a screenshot if you can? Thanks.

Seems to me the fix for Asobo is to find a way to recognize the difference between AI planes and ground simobjects. Apparently they already do this as a holdover from FSX, as a long time ago when I asked a question about airplanes parked at parking spots and AI aircraft, they said the options for AI aircraft don’t work on parked aircraft (I was getting tons of Bleriot XI’s because it was ignoring the don’t be AI option).

Seems to me parked aircraft should become part of the AI system, and then they could calculate the ground simobjects in any given area, give them priority, and reduce the AI aircraft population accordingly based on what memory is left over.

Granted, things might be different now than my example as the AI code has been significantly rewritten since I had that issue, I was just using the example to talk about the logic that might keep airports populated appropriately.

This happened again to me during last nights flight from KORD-KMIA. Left an add on airport used FSLT to one at another add on airport. No issues until final approach airport not loading and severe drop in FPS. This has happened 4-5 times now over the past month. While it never happened before. I will go in a vote for the Asobo bug request!

I7-1100/3060Ti/1T SSD / 32G RAM

Meanwhile, is the only solution not to use FSTL then due to object limitations? I have my FSTL settings on pretty low.

Hi There,

I also have the same issue sometime.
Today was a flight from KJFK New York (Deluxe) to Denver KDEN. With iniBuild A310
When I have arrive, I had no building.

FSTIL was well activated during that flight

It would be so nice to be able to have a tools that clean the cash (clear all object) and reload the scenery.

Is there a reason people feel the need to say that they are experiencing a known problem?
There is an object limit in MSFS, and when that limit is reached, no more objects appear.

The answer is to lower the number of objects being produced for the sim which can include either lowering the options for FSTL, or turning it off altogether, and also looking at what other addons you are loading. We won’t likely see a “fix” for this until SU12, and maybe not even then.

Yes absolutely, the first is the need to feel understood.
The second, more people share the issue, more the developers can consider a solution for this.


It appears the bug thread is now marked as “feedback logged,” which is a step forward. Absolutely agree with both of these points.


Hello everyone. I just wittnessed this exact problem after doing KORD-KMIA-KDCA.

KORD-KMIA was completely fine with no issues at KMIA after arrival. However, when I requested pushback for my 2nd leg to KDCA, things started to get a bit weird: first, GSX pushed back without showing any vihicles, even though the deboarding and boarding animations worked just fine. I wasn’t worried to much and continued my way to KDCA. Everything was completly normal until I descended below 7000ft. I started to get massive FPS drops - we are talking from 50 to a locked 10 fps here. I couldn’t see what was going on because it was pitch black. Buildings and street lights were totally normal and loaded in correctly, but I don’t know if ground textures were blurry like it was mentioned in a previous comment. It was only 30 ft above the ground where I realised that the airport has not loaded and I am about to land on grass with runway lights installed…

I didn’t use FSLTL or any other traffic injection. Just the Fenix, the three sceneries and GSX. So in my case, traffic addons had nothing to do with it and in this scenario I suspect GSX being the culprit due to its weird behaviour at KMIA. Closing the sim and loading back into KDCA everything was normal again.

I have same issue landing FDST EGLL and Fenix a320 and FSX Pro. Only run dx11.

Should add i dont run fstl or aig - however do run aerosoft simple traffic. Will try running without it to see if this resolves it

In case you missed it, GSX now has a “reduced clutter” mode you can use to limit the number of objects spawned into the scenery. You might try that to see if that resolves your specific scenario.