Seeing generic models instead of actual plane models/livery lotto - in flight only

Brace for a long read.

I have several payware/freeware add-on planes and liveries in the Community folder of my MS Store version of MSFS.

The planes show up in the plane selection and are displayed correctly as static planes on airports. As soon as I start a flight I am seeing only generic plane models. Yes, I have disabled “Use generic models for AI and Multiplayer Traffic”. :slight_smile: The problem is not specific to SU9, I am battling this for several weeks now. A couple of times I thought I had solved the problem but on the next flight it reappeared.

A short list:

  • Stock Asobo F-18/E shows up as Airbus/Boeing
  • Flightsim.to F-18 Super Warrior mod is not installed (not compatible with SU9)
  • Marketplace F-22 shows up as single engine prop plane or Airbus/Boeing
  • Marketplace Su-57 is displayed correctly
  • Marketplace F-35 shows up as single engine prop plane or Airbus/Boeing
  • Freeware F-22 shows up as single engine prop or Airbus/Boeing
  • Payware F-22 shows up as single engine prop or Airbus/Boeing
  • FBW A320 may or may not show up correctly, depends on the the day and/or weather
  • Concorde shows up correctly

The same goes for the liveries. They are displayed in the Liveries selection for the corresponding planes but in group flights on my side they are not matching what the other players have selected and are seeing on their side. The files are identical on my side and on the side of the other group flight members.

My sim is not installed on the C: drive, for disk space reasons I have to use drive H:. Both game and packages are located on H:.

The MSFS install put “H:\Games\Msfs202\Packages” in UserCfg.opt’s InstalledPackagesPath - result: see above.

Since other threads mentioned problems with planes not showing up at all in the game when MSFS is not installed on the C: drive or install and packages are on different physical drives I soft linked “C:\Users\foobar\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages” to “H:\Games\Msfs2020\Packages” and changed the InstalledPackagesPath accordingly - result see above.

I even did a complete reinstall (wiped InstalledPackagesPath Community and OneStore clean and uninstalled MSFS) since originally the game was installed on C: and the Packages were on H: - result, see above

My Community folder contains only Mugz UI mods, a couple of liveries, Tatami marks and the aforementioned planes. I can exclude Mugz UI mods and Tatami marks as the culprits since the problem persists when I remove those packages. The skins were all converted by the FBW installer to match post-SU-7/8 (?) requirements and as I said, they work for other players.

I am at my wit’s end and I hope someone here can help.

PS: LongFilePaths is enabled in my Wndows installation.

1 Like

The group of friends I play with have been having this issue since SU7.

Planes that came with the game most of the time show up in our group as a single engine prop plane. Though I have to admit, today we were in a group and were using the TBM30 and it actually showed all of us in the TBM30.

I feel your pain on this one as when I am flying around solo, or with the two other friends that I play with, we get buzzed by a F22 that shows up as a single engine underwing prop plane, even though we all own the F22. It is super annoying and really takes the reality/fun out of the sim.

I really hope someday we will be able to see the planes whether we own them or not, and they need to fix whatever the issue is of us not being able to see planes that came with the game! I would go on with more details but I do not have the time right now. If anyone has a fix, I would LOVE to hear it.

Just to clarify, we are all on Xbox Series X.

1 Like

Hi @ShierPond399248. I moved your post here to the #self-service:atc-traffic-navaids subcategory where AI liveries and multiplayer are discussed. I also added “livery”, “multiplayer”, and “ai” tags to assist with searchability. Hope this helps you find a solution soon.

1 Like

Hey @SRLMJ23, welcome to the forums! Glad you are here where you can not only find help but can be of assistance to others. Be sure to check out the Code of Conduct and ToS to get a good feel for the rules of the road here in the forums. And for some help with using the forums, check out the Forum Guide where you will find helpful tips. Again, welcome!

Hey has anyone figured this issue out. Im on Xbox and have been seeing this issue a lot lately. Even the Pelican and f-18 are flying around as a generic airliners. I say 90-95 % of planes i seen yesterday were generic. Xbox doesn’t have the traffic model option.

1 Like

I don’t think is a fix yet, it does suck that there isn’t even an option to turn off Generic models. I have the exact same experience with the amount of planes being generic.

Yeah I think this issue is getting confused with “how to”. The moderator moved this to the help section but this is more a bug. I understand if the person doesn’t have the aircraft or livery but this is more than that .

It is very annoying…

EDIT: I read the moderator notes wrong. Thought he was categorizing as help. Hopefully developers are aware of this.

1 Like

Can a mod please move this to the Bug reports section?

1 Like

Do we need to file a new Bug report for this?
Seems like the generic plane issue is downplayed as a help issue. I can only see the plane I’m flying in multiplayer. This isn’t because I do not own the plane or missing the livery. If I see a person in the f18 they show up as an airliner. If I hurry and switch and come back that same person plane shows an f18. Same with every plane including the Pelican. I can only see them if im currently flying. All I see are airliners.

Hey there, my friend. There is already a bug report for this issue here and I see that you have posted there and added your vote. There’s no doubt this is an issue so hopefully others will vote on that existing bug report.

Hi, I searched and found that one after. Should this one and the other be combined to increase votes, This is a pretty old report and I don’t see this on the road map . Whenever someone mentions this issue I always see responses “ Oh you probably don’t have the plane or the Livery”. While that may be true it, it equally may not be as there is clearly a bug here. .It’s possibly an Xbox only issue.

After digging a bit deeper, the other thread I linked to you above is specific to the Xbox whereas the OP in this thread refers to the MS Store installation on PC. I did not recognize that difference when I posted the link earlier.

Although the problem is similar on Xbox and PC, I don’t think it wise to mix the threads because the OPs in each refer to different platforms.

OK Thanks for looking into it.

1 Like

Bump.

The problem can be partially fixed (for me) by setting Traffic to “No traffic” in Flight Conditions. This fixes some of display issues but I still get generic models for planes I have bought/installed.

A small percentage of these are liveries that I don’t have installed, The rest are installed planes that either are displayed as generic models or change their appearance during the flight from correct model to generic model and/or vice versa.

I still have to test if “No Traffic” has to be set by all players in the group flight (not a closed group flight but players flying together in Multiplayer) in order to “fix” the problem completely. The downside is that the skies are empty, no contrails and random encounters with other planes. I miss those.

Hopefully SU10 will bring improvements in this department.

Has anyone tested SU10 wrt this problem?

Bump to keep the thread open. No change in SU 10 as far as I can tell.

There is another thread with a vote box for this. Weird I haven’t seen anything in the Bug updates list about it.

I’ve been on PC about a month now and I haven’t seen this problem. I’m guessing since this problem is only affecting XBOX the Devs are missing it.

Nope, I am on PC. If there is another thread with a vote box please post the link.

Moderator posted it a little further up when I had a hard time finding.

1 Like

I see several topics expressing concern about this issue, but I don’t see any acknowledgements, resolutions or suggestions from Asobo or any Devs. Inquires to Zendesk aren’t getting replies. Did we ever get an explanation for this issue?
I would want to try ask about it on the Dev Q&A streams but I keep missing it, they stream at the wrong times for me.

I don’t understand, when it comes to default planes there shouldn’t be an issue, since we all have those planes. And for payware planes we do own, we should be able to see them in world also, even if we are not currently flying them. Generic AI airliners should appear with liveries local to that region.

I even bought a few livery packs for the A320, 787 and 747 thinking that would help, but it didn’t. These still show up as the ugly yellow and orange generic planes