Server.exe not Connecting to SIM

When I open the server. EXE file, I go through the printer settings, then it says waiting for simulator. I can’t get past this screen. I’m in the sim an I have the browser open on my tablet waiting, why won’t it connect?

Hi Superman,

Have you tried turning off your firewall temporarily to see if that makes a difference. I have not used this new feature of the FlybyWire Airbus yet. Do you need to run the program as an Administrator? Try waiting and starting server.exe from the MSFS Menu and not before the simulator starts.

Make sure your device is connected to WIFI and that your portable device is connecting to your PC. Check IP address?

I just happen to know what it is you are trying to do, not everyone will realise that there is a new toy to play with with for the A32NX, (MCDU on remote tablet/cell phone). You should explain that in the title of your thread.

There will be a support forum for the A320 and possibly a dedicated thread for it here in this forum too.

Happy new year to you, and have a great one!


Hi Charles, thank you so much for the quick response. I have just now tried most of the things you said in your post, I turned off my firewall nothing changed, I ran the program via the nothing, but I am currently in a flight so I will have to try and start it in the menu after. Everything is on the same IP address and all on the same Wi-Fi, unfortunately it’s still doing it. Let me know if you have any other ideas. Thanks again!

1 Like

In case this helps: I had issues getting the server to work as well. I finally found what my issue was – I had a software Ethernet adaptor (I’m not sure why) as one of my network adaptors. The server was using that as its DNS server. So while my main router is a 192.168.1.whatever like virtually every router I’ve ever used, the software adaptor used 169.125.something something as the IP address, which is what came through as the address to use to connect from a different network device. I disabled that connection (as far as I can tell it isn’t being used by anything), and blammo, the server is now giving me a 192.168.1.something address, and everything worked perfectly.

The difference is that the server.exe app still connected to the sim when I was having the issues. It just wouldn’t let you access the MCDU screen remotely. (Localhost worked on the main computer.) You’re not getting to that point even. I’d see if something is using port 8080 on your system, which is the one that the server uses to access the sim, or if that port is being forwarded or something. Or unblock it in your firewall. Might help…

1 Like

I figured it out, here’s what I had to do. When I went to the plane in the game I went over to the tablet, I went to settings, SIM options, and the 4th thing down it says external MCDU server port. Mine was set to 8125 but I changed it to 8080.
Thanks so much for the help!


I’m having a slightly different issue. The server is connected to the sim ok, but when I go to type in the IP address given by the server into my Samsung tablet it won’t connect, keeps timing out. It says ‘this website can’t be reached’ on chrome. Both devices, PC and Tablet are on the same Wi-Fi network.

Still getting waiting for simulator with Defender off. Have no idea what Superman is talking about. My guess is that I will have to change the web socket. That should be fun.

Hi, unfortunately I did the same as you but it still does not work. Firewall is off, IP address is matching. Not sure what to do next