Sim doesn't load anymore

After updating with the World Update 3 my MSFS 2020 doesn’t start anymore. Never had a problem before.
After several helplines, incl MS self, nothing worked and I reinstalled via the MS Store. It installed the first Gb, and then when I start up the game (via desktop and via gamestore), to download the rest, the screen stays black. This is the same issue why I had to reinstall.

I already looked at a lot of forums, maybe some one here knows what to do?



First check is that you don’t have any Mods in the Community folder, this can cause the program to stall/slow.

Did you try deleting the entire MSFS folder from the PC?

Same problem, community folder empty!

I used the uninstall feature from the app, and everything was deleted.

Have you used the MSStore troubleshooter?

Its a fresh install, but even before the comm was empty ;-(

Yep, I did, still nothing ;-( Had several re-installs now, on diffrent drives, still the same thing: starting up from the Store, seems to start for 5 sec, and then the screen is black and nothing happens …

I saw this thread.
Any help in there?


I finally found it :wink:. Once I got started today I noticed that the sound of my Creative box-set wasn’t working as well…All sort of checks in the services-menu etc…then I unplugged the plug from my boxes out of the PC…and MFSF2020 started working and is updating now.

Thanks for your help!

1 Like