Sim Update 5 G1000 and G3000 Instruments Inoperative

Is anyone having problems with the glass cockpit airplanes? I rotate heading or altitude knobs and nothing happens. I advance power levers and tach, MP or torque does not respond. Any thoughts.

update any Working Title addons you have. Old versions do not work. The G1000 has not been updated yet by Working Title, but a Preview build of the G1000NXI should be available by tomorrow, from what they have said.

I just flew my two test flights using the G1000 (stock - Working Title has not released NXi or advised what they plan to do with 0.3.7) and everything was working (such as it is since the G1000 stock leaves a lot to be desired). But all instrumentation was displaying and working in the PFD and MFD.

Make sure your Community Folder is empty. Something might be stepping on the instruments from there.

Alternatively, for the G3000, Working Title did release an update to it - I believe it’s 0.7.4, so use that in lieu of the stock Garmin.

I downloaded 7.4 and have been trying it in the Longitude for a few hours, but the throttles don’t work. I don’t think the WT mod is the problem, but after reading some other threads, I deactivated both Dakfly’s mod and the WT mod but I can’t get back online because the servers are so slow.

Since the update, I’ve tried the longitude, which is about the only thing I run on the sim right now, both with and without the WT mod (including the updated one they put out, v7.4 or so)and with and without Dakfly’s mod (he says he’s looking to see what all they changed and if any other work needs to be done to his mod); to say it’s a mess is being kind. In all versions, the thing won’t climb to altitude; after engine start, the starters won’t disengage; at about 19,000 feet high, the thing just jumps from side to side, the speed spikes to 290 or so and then drops back down almost as fast, then it simply starts losing speed (while the engine RPM’s exceed 100%) the higher you go, no matter how slow you climb. Right now it’s unusable. Will work on it more tomorrow and see if things change…

That happened with the bonanza last night. I removed all my addon liveries and the g1000 worked. Now that’s odd

G1000 range knob not working after Sim update 5 (Mod Version 4.0)
Hope update for stock G1000 available soon ! Also the Prop Sync switch
is no longer operative with or without the Mod. I don’t know whether it did anything…but I always switched it on.


There is already a issue about that opened:

But I would suggest to report this to zendesk anyways

The G1000 NXi autopilot not working after Sim update 5 here either. A couple of pictures say it better than I can. I took these on a route I’ve followed many times, from Watsonville (Calif.) to the nearby Monterey airport.

First, notice where the plane is on the VFR map compared to the magenta line; nowhere near it.

Second, I should be on approach to the Monterey airport here, but instead my G36 is headed out to sea.

Some context: I earlier ran into some serious problems with the sim crashing every time I clicked “fly.” To resolve this, I had to uninstall/reinstall MSFS twice. I won’t go into detail about that, except to note that the sim has been running fine since the second reinstall. But could that have conceivably affected the G1000 Nxi, which downloaded and installed (twice) with everything else?

For additional context, I use a Logitech multipanel to turn on NAV, ALT, and adjust other autopilot settings. I have never encountered any problems between the Logitech panel and the panels in the sim. Whatever I do in the multipanel – flight-level, heading settings, and so forth – always translate to the glass panels in the sim.

I have questions about the compatibility of the latest available Working Title G3000 mod (v0.7.4) with Sim Update 5. After the update, MSFS started crashing when I clicked “fly” after setting up a flight plan in the World Map. I’d already been through two successive uninstalls/reinstalls – because of CTDs that seemed coincidental with my attempts to use Navigraph; the first reinstall didn’t help, but the second one did after I got rid of all the remaining Navigraph files on my hard drive. I didn’t want to do another one. Instead, I went into my community folder and removed the Working Title G3000 mod. Other than a mid-flight CTD I ascribe to the failure of the G1000 NXi to load properly (the MFD map’s background came up solid black instead of the usual greens and blues), I haven’t had any click-on-fly CTDs since then.

I had problems with all the propeller planes + cessna caravan 208 turbo prop, after installing SU5 update, in that the GPS in the cockpit was not reflected in the external view and I could not use IFR flying. I have now fixed this problem by removing the G1000 NXi update. Hope this helps anyone with the same problem.

The 0.7.4 is not the latest version and not compatible with SU5. See WT GitHub for the latest version. It works for me in the TBM.

If there’s a later version of WT’s G3000 mod, I would really like to know where/how to find it, because I’m not seeing anying later than 0.7.4 on WT’s website.

Go look on their GitHub. They haven’t updated the webpage. If I get around I can send a link later, but google should get your there. I have edited my post above to avoid people getting confused.

You’re wrong :wink:

Go to

Right click on download latest version and select copy link


Paste into web browser

Go to github

Click releases - scroll down and click g3000-v0.7.4a
Scroll down and right click on
Select copy link
Paste into web browser


1 Like

Thanks for providing the link. I was on my mobile and on the run.

I just clicked the link the previous poster provided but was on the run and did not check closer.

Yes 7.4a works for me with SU5 already since last week but as these guys are so quick you never know if they already published an even newer version.

1 Like

I found g3000-0.7.4a on GitHub. Working Title’s own “release highlights” say that 0.7.4 is “Now compatible with game patch (Sim Update 5).” There is nothing on WT’s website about 0.7.4a or where to find it, which is pretty confusing. When I click on 0.7.4a at GitHub, it takes me to “Download from the Github release page,” the same mod that coincided with CTDs on my PC, at least circumstantially, because when I removed it from my community folder, the CTDs stopped. So regardless of what WT says about 0.7.4’s Sim Update 5 compatibility, I’m still gun-shy about it.

This is the link to 7.4.a.

Scroll down to assets and download the
zip file. Yes it seems to be missing the “a” in the file name, but this is it.

Is this zip file download actually different from the download on the Working Title website (packages), which is also “v0.7.4”? I may hazard a try; I can always remove it from the community folder again if need be. But other than the cooler map screens, how does it add to the sim G3000’s functionality?

It might, I did not check… just try the link I provided. You will find out quicker than writing another response :wink: Worst thing, you CTD… so.