Sim Update 5 Oculus Rift Issues

Prior to sim update 5 my Oculus Rift worked pretty good and always was able to keep up with the game. Now sim update 5 is out I get an hour glass and the game freezes for about 30-45 seconds and then resumes every 10-15 seconds. If I suddenly look left or right it freezes in which it didnt do prior to sim update 5. My PC is 64 gb ram I-9 processor and RX6900XT

All worked great until now!


This is probably not the same problem you are having, but worth a try: I have a Rift S too and was getting a massive freeze and then it would work for a bit too, then freeze, the work for a bit. Oddly, my Oculus home running in the background had popped up the “you haven’t set up guardian yet.” I set the floor and ignored boundaries, then all was smooth again in the sim. No more freezing.

Thank you, I will take a look and see if that’s happening.

Same issue. Im running a very high end PC. This happens even when game is paused. I suspect this has something to do with InputMapper and my PS4 controller. I think I got it fixed by connecting by wire instead of bluetooth

Same, in addition i got an Oculus update just before SU5. By experience, each Oculus update have bad consequences for me.

Same for me as well. I am hoping that so many people are downloading Update 5 the it is because the servers are overloaded. It has nothing to do with the rift, because it happens when viewing on the screen. There is no hourglass, but the game freezes. In addition, it freezes sometimes when there is no flight, and I select an item from the menu - it used to react instantaneously, but now sometimes freezes for a few seconds

I was starting to wonder if it was just me or my Rift-S was starting to go faulty.
I have found probably since the last couple of Oculus updates, which seem largely to target Quest users my Rift has become more and more unstable. Oculus dash would detect it fine. Put it the headset on see anything. Close Oculus and re-launch now its complaining it can’t detect it.
Unplug and plug back in, now there’s a problem with my USB or display port. Unplug and try again.
After 10 minutes of repeated unplugging, restarting Oculus and maybe a PC restart it might might work. Launch FS and fly for a bit then randomly will crash particularly if you toggle between VR and desktop modes.

Back to the start for me too using a Quest 2. My system can now run this sim without too much effort, so Update 5 is a success for me from that perspective. VR mode doesn’t seem to go well no matter how for I turn down the resolution and settings, it will always get a bit of a jerky/juddering appearance. Before I was able to mostly get rid of this by setting the desktop resolution to 200% but that trick doesn’t seem to work anymore. There must be something horribly wrong with the Oculus implementation.

Now I did read that Oculus will fully embrace OpenXR, so that might change things soon, I’ve got my hopes put on this:

I don’t think this is the case. I have a Rift S, and since SU5 I’ve been able to increase the graphics settings and push the LoD sliders to 200 (VR) while maintaining good performance. The sim is looking and performing far better than it was for me personally. Last night I was doing aerobatics in a stunt plane over my home city without any stutter, something I couldn’t have dreamt of doing pre-patch.

Intel i9 10850
RTX 2060
Rift S


Hmmm strange, I can run the sim flawlesly in 4K using high and ultra settings and can lock framerate at about 40fps in areas like Manhattan. Whenever I enter VR I can do whatever I want, but there is persistent glitching when turning the plane in circles or just while taxiing. It’s not as severe while flying, but you can still notice the strange hickups. This is even with every setting/resolution to as low as I can get it in areas without complex scenery and with a lot of sea around it.

Worst is that this was greatly reduced with the 200% render scale trick which made it perfectly usable. Now it’s only usable whenever I disable ASW, but that doesn’t make it as smooth as it could have been. Anyway, I will start again tweaking all settings, maybe there is a new hidden gem to be found :smiley:

Exactly the same here. Everything tried. Waiting for Oculus beta fix. Please post here when solution available.

Use the stable release version instead of the beta. I’m always seeing people reporting issues in VR games that end up being caused by some bug in Oculus beta, so I really don’t understand why people insist on using it for general gaming. That’s not what it’s there for.

All my problems solved. Asobo issued a patch for update 5 and I no longer have the hourglass and freezing. With my new 3060TI graphics card, overclocked using MSI Afterburner, I have been able to turn most of the settings to Ultra and am getting a very smooth result on the Rift S. The detail and the whole experience are quite extraordinary. Buildings and landscape are almost photo accurate. This is without question the most astounding piece of software I have ever used. Well done Microsoft/Oculus/Asobo


Both, stable and beta doesnt work, freezing every 10 seconds for 10 seconds. Have SU5 and latest update.

1 Like

Solution for my freezing every 10 seconds found. It was Bullguard Game Booster. Turned off and no more freezing

Could you please list your settings? I have a comparable system and rift s. When I play everything is blurry until I get up high. Should I change from 4k to 1080p also? Thank you.

Of course. :slight_smile:

Using Oculus Tray Tools I have MSFS set to 1.0 SS, 30Hz ASW, GPU Scaling off, CPU Priority at Above Normal.

In-game, I am running TAA with Render Scale at 100 and both LoD sliders to 200. Nearly all other settings are on Medium. The exceptions are Volumetric Clouds, Texture Resolution, and Glass Cockpit Refresh Rate which are all set to High. Anisotropic Filtering is x16, Texture Supersampling is 8x8, Shadow Maps is 1024, Terrain Shadows is 128.

In the wilderness that gives me about 35-40fps which results in dead smooth performance. Over a decent sized city I get 28-32fps which is almost dead smooth. Over New York I was getting 25-30fps… that can get a bit stuttery, but temporarily lowering ASW to 18Hz (which you can do on the fly) sorted that out.

Thank you very much, hopefully this will give me an enjoyable experience. Also what do you have the resolution set to in regular mode? Does it make a difference?

I have it at my monitor’s native resolution of 1920x1080. Whether it makes much of a difference often depends on the game. Most mirror the exact same image that is being sent to your HMD, but cropped down to fit. It requires minimal resources to do that so not much performance impact most of the time.

That said, 4k is higher res than the Rift S so I’m not sure how that’s handled when in VR mode. If it’s upscaling the image for your monitor view then you might gain a few FPS by lowering it to 1080.

I tried your settings in-game and it crashed the game lol. I’m guessing oculus tray tool is critical for the success or running smoothly. I will try with the tray tool later.