Sim Update IV ( is not downloading/installing

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.


Are you using Developer Mode or made changes in it?


Brief description of the issue:

Neither the Windows Store of the Sim itself will download and install the latest update.

Provide Screenshot(s)/video(s) of the issue encountered:

Not required? It simply doesn’t update the sim.

Detail steps to reproduce the issue encountered:

  1. Open Windows Store
  2. Go to Downloads and updates
  3. Click “Get updates”
  4. No MSFS update is downloaded


  1. Open Sim
  2. Wait for it to check for updates
  3. No MSFS update is downloaded

PC specs for those who want to assist (if not entered in your profile)

RTX 3080
i9 10400
(Alienware R11)

Build Version # when you first started experiencing this issue:

Current build

Are you on the Steam or Microsoft Store version?

Microsoft store

Did you submit this to Zendesk? If so, what is your ticket #?


same here. Had that before. Seems the update is not rolled out simultanously worldwide

Had that, did a cold restart and it fixed it for me.

Thanks for the input! Another user pointed this out as well, but I would like to confirm this is the case if possible. Hopefully I can get some kind of official reply on the Zendesk ticket.

I’ll try that. To confirm you powered the machine down and then back on instead of simply rebooting? Thank you.

Yes, I held the power button down for around 10 seconds just to make sure. After startup it appeared on the windows store.

That’s a waste of time. Until someone reads that Zendesk ticket, the problem will be over. As I said: not the first time and probably intentional.

Thanks for your speculation and opinion.

Topic moved into #bugs-and-issues:performance for installation problems.

They responded and said nothing about a staggered download. They gave me a list of troubleshooting instructions. If your theory were true they would have mentioned it there. The problem isn’t over and someone read my Zendesk ticket. You should probably do some research before making false statements or saying others are wasting time trying to solve problems.

Speculation based on experience since I had that same problem with the last three updates which only started automatically about 12 hours later. And I also have never ever gotten a reply for a Zendesk ticket. Also cold start never worked for me. Glad if it works for you.

1 Like

Mine as stuck on a file at the start of the update, I just shut it down and restarted and it seemed to then pickup where it left off and completed pretty quickly after that.

I’m having an error message when I launch the sim saying my content manager isn’t available and to check my internet connection. My internet connection is fine though. The only option is to quit which then brings me to the XBOX live sign in page and “press any key to start” menu.

Yeah, I am starting to get frustrated. Nobody at Microsoft or at MSFS support seems to be able to resolve this. I keep getting canned responses like “Log out of your store account and log back in”. I have the ability to Google. I have been trying to solve this all day. I have done everything they have suggested and nothing is working. If the download is being throttled/staggered, they should just tell the community that.

1 Like

Holy ■■■■ I fixed it!

Here’s what I did:

  1. Go to Add or Remove Programs
  2. Go to Gaming Services
  3. Go to Advanced Options
  4. Click Reset

After doing that, the store instantly downloaded the update from Settings → Downloads and updates → Get Updates!


Thank you! That’s what it took to kickstart my download too.

Nice!! I’m glad it’s helping others.

Good morning. Hum… it doesn’t work with me. Any other suggestion?

Good morning. Sorry to hear that didn’t work for you. A few other things have been suggested to me that didn’t work.

Log out of the MS Store and log back in
Restart the Gaming Service service

Reset the Xbox Live Service:

  • Force the Xbox Live connection to reset …
  • Click on the Windows icon in the bottom left corner of your screen.

  • Click on Settings.

  • Go to Gaming.

  • Go to Xbox Networking.

  • Wait for the diagnostic to finish running.

  • Click on Fix it to force refresh the connection.

Reinstall the Gaming Service using the following process …

  1. Close Microsoft Flight Simulator
  2. In the Windows search bar, type Windows PowerShell
  3. In the menu, select “Run as administrator”
  4. In the Administrator: Windows PowerShell screen, type the following command and press Enter:

get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers

  1. In the same window, type the following command and press Enter:

start ms-windows-store://pdp/?productid=9MWPM2CQNLHN

  1. Click Get to install Gaming Services (select Yes if you receive the User Account Control (UAC) prompt)

  2. Restart your device and try again

I hope you can get this resolved!

Thank you. I will try that. I’ll keep you informed :crossed_fingers: