Sim Update V (1.18.13.0) Bug Megathread

None of the aircraft in my community folder work properly anymore. Salty B747-800, B787Heavy, A320 Fly by wire, cj4, Longitude. A lot of switches in cockpit are not controlled by the mouse. Landing lights for example are on all the time cant be turned off. I hope they can fix this. Very depressing

maybe we should all take a 2-week break from MSFS and let them fix everything :slight_smile: I admit it would be hard for me at the moment, I’m kinda hooked on it. It’s like caffeine :crazy_face:

1 Like

Why I also own XP11 and DCS. I think this is going to take a while.

1 Like

After the update none of the clickable items on 3rd parties and default aircrafts work.
PDGM DC-6 tablet is not clickable. While holding the right mouse button to look around the cockpit, all the flight controls freeze.
The patch released today did not change anything.
Anyone with similar issues?

After reinstallnig the game due to some bad tip I received in this topic to force feedback on joytstick Force feedback support - #286 by TripsyTipsy
The game has been crashing on me too. But not all world updates are installed yet .It does always seem to happen when I plug in the joystick. I disconnected the joystick just to be able to download all the world updates agani without crashing while its downloading,will pug the stick again once i downloaded all additional content & hope that will fix it. I so regret following the recommendation in that topic.More specific ,this recommendation Force feedback support - #279 by MSFSRonS

I think everyone is getting this issue. Please upvote this!

1 Like

i haven’t, i got similar problem with mouse stick on joystick, but it has big increment, so it’s normal, even when i use cursor in windows by this minimousestick i can see how it appear disappear every 1/3mm, in sim it looks like i have very high frequency parkinson’s shaking

There a huge frame drops when you look inside the cockpit and then back to outside.
Maybe you didn’t notice it because you don’t have locked the FPS; or maybe you are playing with a low LOD settings.
This happens every time in the same way; it’s specific CPU call issue.
Try this test: A320 Neo at LFPG gate, look all way down to the seat and then back. If you open the dev fps counter you will see a drop about 10-15 fps for just a second. That produce a big stutter.

Might want to update your first post with all the details that others have provided in the later posts… that way even devs browsing will have a decent understanding of what the hell they broke now instead of browsing through 399 posts with probably the majority being copies of the original posters… or else dont make a " megathread" without keeping it informative, hihihi, (and put a (Solved) behind your Orbis quest to update the thread. :wink: ) Great thread though, going to see what faults i’m missing out on now!

Anyways… i’m sure someone beat me to it as i have yet to read the entire 399 other posts, but:

  • Before update i could hit the enter-key twice to get my flight started when loaded in, now it only works by mouseclick.

  • Axis on flaps (trimwheel on my joystick) seems to malfunction because some airplanes are deadset to use a button for trim.

Now for nose down trim, i need to turn the twimwheel all the way forward, then rock it back and forth several times to halfway and back forwards to full forward to get the ingame trim to move the nose down… reversed procedure to trim the nose up… But after it starts moving the ingame displayed trim, i need to put it back to neutral, or it just keeps on dropping/rising…
Think it’s time for the dev-team to separate button and axis code for trim from eachother, and write some fresh code for use with the xbox-controller, instead of just linking them to existing code.

But yeah, “change one line of code to support Xbox controllers, screw up 10 lines of old code that actually worked before” -story of a codie

Good luck on a hotfix, devs!

Woof ~ Woof & Salute

Steiny.

1 Like

Ok updating windows & checking for updates fixed it for me.There was a big optional update to improve quality of windows,as well as several other updates for nvidea etc… if you keep getting crashes without warning,look for upgrades in the start menu of windows…All seems to run smooth now.Thx goodness

This entire forum, along with scores of other forums, and zendesk are all one gigantic bug mega thread. There is a need for a staff of 10,000 just to mange the forums, and a need of 100,000 to fix the bugs - 10 years will go by fast and the stagnation will be obvious.

At the current rate, basic bugs and missing advertised features will exist well past 20 years, but we’ll have a DC10 eye hospital to tour around in. :confounded:

2 Likes

The logbook not updating bug might be back,especially during landing this causes issues for me.
This lovely person brought a bug topic to my attention on the logbook not updating properly

I think this bug might be back, flew to DTTR El Borma because previous time the "taxi to parking"didn’t pop up there. But even now ,with 2 landings ,one with no objectives at all & a go around with same end result;not able to end flight.Took screenshots here:

i close to never use outside when fly, so can say nothing about this, but i was check myself couple a minutes ago, and everything work ok with my ministick view around, may be this only some time, and may be that’s stutters was after i get in cockpit on the ground from external view, dk…

  • after update MSFS is adding control assignments to buttons that don’t exist on the Honeycomb Bravo Throttle. (ex: reduce flaps on button number 4, when they’re is no button 4 on the throttle)The button assignments can cause button conflicts which end up making them unusable in game.

  • something about the honeycomb Bravo Throttle is making certain light knobs unscrollable with the mouse. I know this because if you clear all assignment for the bravo, the knobs become scrollable with the mouse.

The Aerosoft CRJ is not flyable for many users after SU5. The Aerosoft Devs have identified all issues and notified Asobo about what fixes are needed in the core sim for the CRJ to fly again, but was not included in the latest fix.

Like many simmers, I believe the CRJ is the best quality jetairliner so far, and a fix is needed asap.

Please upvote here if you feel the same: Make Aerosoft CRJ flyable again

Wanted to fly& try the cool new free McDonnel Douglas Orbis Flying eye Hospital ,but the fly button is disabled in the world map , if I have the plane selected :sob:

Sorry, I don’t mean external view… I meant to look at the instruments, and look outside from the cockpit…

2 Likes

It’s not meant to be flyable. Read the news section in game.

1 Like

Good point. I’ll be away from my computer for 4 weeks starting on the 10th August, and am looking forward to putting this thing back in its box and regain some sanity.

oh just for touring inside then. It could be kind of fun though, repatriating people who got sick or mixed up in accidents etc with it.Maybe they could add the Falcon 7x or 8x I suggested in this topic instead;

Autopilot is a bit off,always flying about 500 ft below assigned altitude.
Thought i’d fix this by requesting 1000ft decrease,but the problem remains


Message keeps spamming ATC & pilot keeps confirming back & forth on autopilot
Disabling auto pilot & climbing to assigned altitude doesn’t fix it either.The plane descends again to an altitude that is off the moment you put auto pilot on again.
After each time the ATC requests “expeditte your climb” the message “engaging autopilot” keeps following too