Sim VR thoughts.. Sim Update 3

It is no longer possible to switch from 2D to VR since installing mandatory update 1.14.5.0. The screen is swapping in a strange manner, the sim does not react to any input and can only be shut down via task manager. I am using the MS storebought version.
I have tried updating nvidia driver from the in this forum mostly recommended 457.something to latest 461.72 - no luck, same problem.
Submitted to zendesk, but any ideas would be appreciated - I miss VR!!
Regards

Processor Intel(R) Core™ i7-9750H CPU @ 2.60GHz 2.59 GHz
Installed RAM 32,0 GB
System type 64-bit operating system, x64-based processor
Display adapter NVIDIA GeForce RTX 2080 with Max-Q design
VR headset HP Reverb G2

Edit: Solved. Same problem as JoseJacobUK and his solution worked for me too:

Thank you very, very much JoseJacob - you made my day!!

2 Likes

The thing Aerofly does to keep things smooth is to just have a simple mesh with textures on it, and relatively simle lighting. There’s no such thing as water, roads, traffic, other players, simple planes with simple systems, etc.

So yes, it is smooth, but there’s a lot you sacrifice for that.

2 Likes

I’m getting pretty horrible stutters in VR in some instances, usually around cities or dense forest areas. I didn’t get these stutters before the update, so something seems to have changed.

I’m on a Rift S, 2070 RTX, I5 9600K, 16 GB.

I’m getting these stutters outside of VR as well, but they’re maybe not quite as frequent.

1 Like

Update: I reverted back to Oculus version 24 just to see if these weird new stutters were still there, and they were! So it seems that it’s not the Oculus drivers fault this time. Looks like update 3 is to blame. I hope Asobo finds and addresses the cause of this soon!

The Asobo guys hinted that they did find something in the last MSFS show, so hopefully they won’t wait with their hotfix for too long.

XP11 even with the Vulkan update can still barely run any 3rd party addon scenery in VR
Prime example…St Barts XP scenery still can’t run well even after Vulkan
sucks because that scenery package is beautiful

Quest 2 here. Have been getting a ‘usable’ experience using Virtual Desktop but since the latest update I cannot get VR to work at all. I keep getting the warning to assign ‘space’ to reset the camera. It IS ALREADY SET! I have also set a key on my HOTAS as well. The keyboard and Hotas show the keys are bound but for some reason they are not being picked up. Very frustrating!

Reverb G1 - 2080ti VR Great.

Same thing here! unable to use the G2 any more!
nice solution workaround but how to fix it when I dont have a second monitor?
This cant be the problem…

For me too, nameplates are certainly more blurry, bordering on unreadable, but I’m guessing that will just be one of the sacrifices for better performance.

Even worse than how XP11 was at launch?

IIRC, XP11 didn’t have VR at launch and had to rely on FlyInside XP until they eventually caught up.

I guess our recollections must vary. :slight_smile:

I gave it another try with sound in VR deactivated… it works now but with only 3-10fps and random blackouts every 20-50s. With sound activated I dont even see a picture… just bluescreen in cam!

So for me it cant be any opened window!

When Xplane introduced VR it was still very much in its infancy and new technology, with a steep learning curve.

The programming techniques have been available for quite a few years now so when ASOBO incorporated VR into the game, VR was well-established.

It’s just a sloppy implementation; one that I expected would be based on best experience and practice and I don’t think it uses that best industry-wide experience.

Shoddy programming plus poor documentation equals a negative experience. This is evidenced by the multitude of topics about how to get it working properly. And by all accounts, it still doesn’t.

3 Likes

VR in X-Plane 11 - X-Plane.Org Forum (x-plane.org)

From the large number of recent threads/posts, it would appear that despite native VR arriving in XP11 in 2018, there is apparently still a bit of a way to go, before everyone is happy with VR in XP11.

I guess simmers on all platforms can be very tough to satisfy.

1 Like

They can indeed. Never a truer word…

I confirm they changed the way all labels are displayed (airport,cities, etc.) and it’s now very blurry, sad, a new regression…
In any case this last Sim update killed any VR sessions on my machine. Even the simplest airport with simplest plane (to be fps friendly) is full of stutters, with GPU at only 78% usage, so possibly due IMHO to one CPU core nearly always at 100%. Today I switched from 4.9 to 5.1Ghz all cores my 10700K, very stable (it’s one of all configs I tested and prepared months ago with 4.9, 5.0 and 5.1 stables) but no, it’s not enough for MSFS, so I get back to my 4,9 OC, cooler.
Just being patient I should…

1 Like

If this blurriness was intentional and therefore not to be fixed, then I’ll probably have to skip playing in multiplayer or just turn the nameplates off, as they are of very limited use as they are.

On a positive note, it seems that HDR has been enabled in VR. I am getting now richer colours and also a better contrast. It looks stunning on the Rift S. Before, when activating HDR in the Windows settings and swapping to VR, you just saw black or yellow. It is interesting that only very few mentioned the better colours so far, as it makes a difference the VR immersion.

I’m surprised by what you said… AFAIK The Rift S don’t manage HDR. I know a bug have been fixed when you have an HDR monitor and HDR is turned ON in Windows settings, but the fact you see a difference inside the headset is brand new for me…

See what SlidHydra647449 has written regarding clearer sky colours. I also noticed that also for sea colours. I just have the sensation colour scheme with the Rift S is better now. I don’t know if the Rift S fully supports HDR, maybe it does it only to a certain degree, like between SDR and HDR. Interestingly, there seems to be little to no information on this topic on the net. Besides this, Asobo has mentioned it in the patch notes of Sim Update 3 that HDR has been enabled for VR.

1 Like

The main thing bothering me is, sometimes i get those microstutters, but also the resolution in the distance, at the horizon is a bit blurry. It makes it hard when flying VFR to eyeball an airport thats a few miles out. ALso makes it hard to see the airport beacon because the resolution is so poor. I have tried with and without the Oculus Tray tool.

any hints on what your OTT settings are, and what resolution/ options you have when you fly in VR ?