Slow download of updates and game files - Data Limit Override Needed

For some time now there has been a bug in the DATA BANDWIDTH selection in options that has caused problems for people downloading updates.
It seems that if you select a data speed limit while in the DATA section in OPTIONS then that data speed limit will be enforced when updating the sim. As you cannot enter the sim to make changes to your settings until the download is complete, this can cause extremely slow downloads even if the user has fast internet.
In discussion with other members, we suggested a selection in the installer that would give the option of overriding the data speed limit selected in-game while doing updates.

This would also apply to the DATA LIMIT as having a cap on your total data will stop your download if that cap is reached.

I believe this is already happening, if you have the simulator Data Options set to Unlimited or 40/20/etc… then the installer also uses that setting.

  • I had problems with the installer always restarting half way through a big file, if I had 20MB/s set in the Data Bandwidth limit option in game. But today, it’s set to Unlimited and my installer is running at 130MB/s just fine.

RECOMMEND: leave Data Bandwidth on Unlimited during installs.

FINAL THOUGHT: Allow the installer to have different bandwidth settings than the in-game experience.

1 Like

I agree. This should be implemented either by some sort of checkbox on the installer screen to by-pass those settings. This gives the user a choice to use their pre-set setting or not.

I have unlimited set, and I still got throttled to 1Mbit/s during the download of WU3, but only at the end for the “fs-base-gl” archive. VPN was the workaround for me.

It had happened before, for previous updates, but never as bad as that.

Me, too. I have no cap and my download was getting 1 Mbit/sec, as well.
(And I downloaded the patch days after it was released, when there should not have been many people downloading it.)

1 Like

What @ScorchedCone02 posted here is some good examples of what should be done:

Hi,

in my opinion it is more a bug and not a ‘feature’ ( or at least wrong thinking in design ).

I assume that absolutly nobody in the world expect that a in-game data-limit setting ( data- , bandwith ) affects the update-process/downloader.

I voted for, but I think more the developers not need to implement a checkbox, instead implement what all installers/updater’s in the world do: "the updater have nothing to do with in-game settings and thus it have allways “no limits” :slight_smile:

PS.: of course there exists also limitations where seemingly the ISP limit data-traffic. But this is not meant within this topic.

1 Like

When it comes to overall data limits, it sometimes is forgotten that there are users out there that have VERY limited data available on their plans. Overages can be expensive. Those users should be tracking their use and need to make a decision about doing a download or not.

At least if there was a step involved during updates that gave them a choice to override their selected data cap maybe they would give it some thought. Might have to hang up MSFS and do the update next month if they are near their data limit. Or explain to the family why they can’t stream Netflix for the rest of the month so they can do the update now.

yes… this is a new possible feature “postpone an update”. But I assume, because possible side effects with multplayer-code, this might be not allways possible. Then users have only the choice to stop the update and can not play.

At least that would then be a choice.

If the updater would prompt,

"You have 50 GB selected as your Data Limit.
You are currently at 45 GB.
This update will consume 25 GB.
Do you want to continue?

If you select, YES , your Data Limit will be ignored and you may incur additional charges from your service provider."

then the user can decide if they want to blow through their data or not. Currently the update is just going to go ahead. If the data limit is exceeded the update will fail. If it automatically ignores the preset limit the user may not even realize they have smashed their limit until the monthly service provider invoice shows up.

1 Like

sounds good… like an extended “choice”.

PS.: I realy wonder how many users have in 2021 a data-limit… I assume I need per month 1 TB ( PC with all the updates, game updates, games itself, the all the video stuff, handy, … )

With some MMO the loader provides you a chance to change your (Options) in-game graphics and other settings before you launch.

With the download bug they have going on that locks your download speed to whatever you had set last has resulted in it taking THREE and FOUR days for some people to re-install with no way to ‘clear’ their previous settings stored in the cloud first. They have to just endure it until they can get back in and change it.
This is a known bug on Zendesk.

Anyway it has me thinking that is probably WHY other MMO’s in the past have also added in the ‘Options’ in the launcher.

No idea if they will fix the download bug but having the ability to make sure your download speeds are max first would sure help.

Cheers.

How long does it take to download the new update? So far its taken about 23Hrs and it has only downloaded 4.65GIB out of 22.22GIB. My internet download speed is 85.90 Mbps and my DATA is set to unlimited

On My 4th day of re-downloading, searched high and low in the install folder and I can’t find the setting file with the data cap or speed limit. Can set the graphics up for the game I can’t yet play though. Awesome.
Tried pulling ethernet out but get an error off xbox and a loop denying access to settings.
Cleared store, deleted cloud data, which refreshes anyways as selecting ‘local’ downloads something and keeps the 20Mbits/s cap. I’ve tried all the netsh commands =disable makes speed start at 0 and climb to 20 then cap, =normal makes it start at 40 then crawl down to 20 cap and bounce up to 30 and down to 20 and up to 25 and back to 20. So stupid. Somewhere there’s a “20000” limit that I can increase to stop the bungeeing.

I’ll probably install it, crash once, and uninstall as my patience is gone. Worst installer I’ve encountered since home brew cassette’s.

I can’t believe it has been nearly a year since I first downloaded this sim, and downloads are still a miserable experience. MS won’t actually assist with the problem as they’ve pawned it off to communities. Why can’t I download an airplane I purchased that is a mere 579MB? It starts downloading, stops, starts again, stops, starts again then completely stops. Why doesn’t it remember where it stopped downloading and start again? I have about 10 items I’ve purchased and am unable to download them. Why can’t MS fix this awful system?

Good luck. It took me literally 7 days of trying to finally get the latest update. I had to uninstall, turn off anti-virus, firewall, flush cache and do a dozen other command prompt items and it still took more than 18 hours to download 171.22GB. I have about a dozen items purchased in the marketplace that won’t download. MS won’t help. They only point me here or to another forum and expect me to read dozens of user generated entries and figure out which one applies to me.

Got it downloaded. Changed DL settings. Saved.

Decided the entire Windows install could do with being nuked so wiped the lot and started over.

Game re-DL’ed in two hours, all 160 whatever gigs + setting up the cache.

Awesome.

PS. Now it crashes if I try and click general settings and my new stick has a mind of its own. Honestly… :joy:

I thought the ‘crash on general settings’ issue was related to the sim’s ability to write to your hard drive (permissions). There were two solutions, first, reboot and go straight in, no problems. Otherwise, start the sim as Administrator to see if it’s a permission thing.

Oh god I thought I was the only one. Can’t believe it’s been a year and no fixes for this. I’m making an install on my new PC and I just can’t remove the speed cap because I need to update before I can edit the settings.

I can’t delete the save file either because xbox will download the cloud save right after I open the game.

Anyone got a workaround or know a way of deleting the game pass cloud save?

Had to finish the whole download to access the settings and change the dowbload limit. Super frustrating.

Since the fresh reinstall of Windows and MSFS20 clicking general settings crashes everytime. Can’t access general settings to try changing rolling cache path or graphics settings.

Got a flight stick and both it and xbox pad have a mind of their own as if there is always some force being applied pulling the stick back and left.

Single worst gaming experience of all time.