So many CTD’s…

Often there are crashes caused by the cache after an update. See 2 posts up.

If you’re flying OnAir while experiencing the CTDs try turning off Live Weather. That seems to have minimised the problems for me. That said, yes I too have experienced a lot of CTDs since the Sim Update, however the beginnings of the problem were following the last Windows Update a couple of weeks ago for me.

I never had any problems with the community folder….All files behaved themselves…….My system is in the ideal category for MSFS and have always enjoyed smooth flying……

I wonder if a reinstall would correct the CTD’s….I would rather not if I don’t have too…

I said cache not community.

Delete the cache in the MSFS options, under Rolling Cache and if you are using Manual Cache, delete that too.

I strongly recommend against uninstalling. Causes more issues if not accomplished in the right steps.

EDIT:
@Oldmansimmer FYI, updates to the sim have, in nearly every update, broken one or more add-ons. Many of the files in the Community Folder require updates to retain compatibility with the sim, post SU/WU. Just because everything was well behaved yesterday does NOT mean it won’t crash your sim today.

1 Like

There are definitely some add on airports that are causing CTD’s. Move the contents of the community folder temporarily. That will simplify any troubleshooting at least.

SEARCH mode CTD

Before creating new topics in this category, please use the search function to look for existing topics

We will let a moderator lock it

The more topics there are on CTDs, the less likely we will be to see them one day be resolved.

One of the oldest with 1023 votes is the topic Crash to desktop without error message

Knowing that the title is wrong, because there is still an error in Windows Event Viewer

Yes, there is a KB patch that causes problems and Microsoft has removed it. If it was installed and you have problems in some games since the date of installation, it is recommended to simply uninstall it.

Other than that, and once you have ruled out mods, it can also be that some profile files are corrupted. I once had lots of crashes and couldn’t figure out what was happening, even a complete reinstall of the game didn’t solve the CTDs. But when I deleted my profile directory, the game recreated the files and everything went back in order.
I used the automatic method to clean up that directory (“repair” or something), I didn’t do it by hand, and unfortunately, it automatically reinstalls the game itself. But at least it solved my issues.

Upgraded Motherboard and Cpu last week.
Fresh Windows install and Msfs install via Ms Store.
Still have random stutters and Ctd-s when i’m flying.

11900K
3080
32Gb
Reverb G2

YEP…CTD since this update with FSTramp again. Last time it was to do with resolution by putting the map to my TV in my office as my Z35P being new was faulty and I lost a monitor. Now it has been working well until this update with my new monitor a LG UltraGear 34" (which by the way is awesome and trashes the ACER Z35P). The developers at FSTramp have given up with Microsoft/ASOBO as I e-mailed them with the problem and they have confirmed that with these updates it screws with 3rd party addons. So now what next? :confounded:

New setup looks nice ! Did you check NVidia driver version and driver updates ? Here’s a happy customer running a previous NVidia driver version 457.30 in VR with a 3080 and a CPU slightly slower,

1 Like

Right now i have all latest drivers.
Maybe i should try roll back to 457.30.
Thanks for tip.

1 Like

Let us know your results !

Everyone who has constant CTD‘s should also have a closer look at their addons. Latest release? Still compatible? GNS 430/530 airspace messages turned off?

The latter reason caused crashes here. It ws the only reason ever.

Any idea how to identify which patch to remove?

1 Like

Well, after removing the contents from the community folder and adding the files one by one, I was still having CTD’s. I have uninstalled the program and am now reinstalling it……I hope I can get this to work….Wow……I didn’t think that this last update would have caused so many challenges…….

I too am getting CTD’s right after the flight loads. Didn’t used to happen. In fact it didn’t happen immediately after the SU4, just started today. Nothing in Community folder. I also noticed that right after the SU4 there was a splash screen while waiting for the sim to show it is loading but today it is gone. In addition, after the update my joystick controls changed ! I reassigned them but today they had changed again, right before the CTD. What is going on??So something definitely changed on their end. So frustrating. This has been out close to a year- we should not still be dealing with this.

The update FAQ says, do not use / tick?
“Use latest preview OpenXR runtime”

With version 1.0.34 the airspace messages are disabled per default because of that. So updating is sufficient (and necessary for SU4 compatibility anyway).
Solved my CTD issues as well, flying smooth since then.

oh thank for mentioning… I’m on 1.0.33. No CTD’s so far but will update right after landing!

I found the solution to all my challenges of CTD’s……I uninstalled MSFS and reinstalled it without anything in the community folder. Everything is back to normal, in fact better than it was before the last update…Everything is back in the community folder and I am a happy pilot :grinning::grinning: