Solution for Stutters & Pauses (updated for SU5)

Sorry but in my experience there are only 2 solutions :grin:

  1. Stop using MSFS 2020, or
  2. Ignore them and keep using MSFS (and hope Asobo fix them later). ← My choice

I have encountered stutters since I first started using MSFS, although long pauses seem to be something new. So I have tried just about everything anyone has suggested. I thought I would list everything that didn’t work for me, but I have probably forgotten a few.

Now I might just be unlucky, as there are plenty who swear by these solutions, and some of them cured other problems people were experiencing. So please keep the ideas coming as I appreciated every suggestion.

WINDOWS 10 CURES

    1. Turn HAGS (Hardware Accelerated GPU Scheduling) on or off – no cure
    1. Turn Gsync on or off – no cure, but after getting this working correctly did no harm.
    1. Set your monitor to (insert number here) Hz – no cure
    1. Insert Affinity Masks in MSFS cfg file (after all it worked for FSX) – no cure
    1. Change windows performance option from “Programs” to “Background Services” - no cure
    1. Put focus onto second monitor when running MSFS – no cure
    1. Shut down all those programs hiding in the system tray – no cure
    1. Fresh Windows 10 installation – no cure, but only did this on an older PC
    1. De-bloat Windows 10 – no cure, but only did this on the same older PC. At least it made Windows faster.
    1. Disable Steam in game overlay (thought of this myself) – no cure
    1. Disable Windows game bar – no cure, but my gut feeling was this did help MSFS.
    1. Disable simconnect – no cure, but then I wasn’t using it anyway
    1. Use task manager to set priority to low for MSFS.exe after MSFS starts – no cure

NVIDIA SPECIFIC CURES

    1. Change power management from “Optimal” to “Prefer performance” in Nvidia settings. Had no effect on my RTX2060 but did increase GPU utilization on my GTX970 – but no cure.
    1. Limit the frame rates in Nvidia settings to (insert number here) – no cure
    1. Set threaded optimization to On in Nvidia settings – no cure
    1. Turn Vsync on (or off) in Nvidia settings – no cure
    1. Use older (or latest) Nvidia driver – tried a couple but no cure, some older drivers causes MSFS to crash, so went back to the latest.
    1. Tune MSFS using Nvidia experience – no cure, but a good way to quickly optimize your MSFS setting quickly, just don’t use Nvidia’s recommendation of which of the 9 presets it has available that you should use.
    1. Install Nvidia drivers without HD audio – no cure
    1. Only install Nvidia driver by itself – no cure
    1. Turn triple buffering on in Nvidia settings – no cure

CURES ACTIONED INSIDE MSFS

    1. Turn Vsync on (or off) in MSFS – no cure, but MSFS seems to work better with this off.
    1. Set frame rates to 30 or 60 in MSFS – no cure, using 60 does no harm but using 30 sees frames drop to about 20 in detailed areas even though you were getting FPS in the 40s when using 60.
    1. Fly in less detailed scenery – sort/kinda works but not really a cure. Stutters still occur but long pauses are definitely reduced.
    1. Fly less detailed aircraft – no cure, but a little like the one above.
    1. Disable all online services in data area – no cure
    1. Pre-download your scenery using the manual cache – no cure, and this is just a variation of the one above.
    1. Increase your rolling cache size – no cure
    1. Run rolling cache on different drive to MSFS – no cure
    1. Use no rolling cache at all – SUCCESS (sort of) no cure for stutters during flight, but will remove the long period of stuttering at less than 10 FPS while MSFS FPS stablises after loading a flight at a major airport.
    1. Run only in 1980 x 1080 resolution if your monitor supports higher res – no cure
    1. Run MSFS in windowed mode – no cure
    1. Increase (or decrease) MSFS graphic settings (insert any setting here) – no cure, but fine tuning MSFS graphic settings definitely makes it smoother between pauses and stutters.
    1. Disable VFR map – no cure
    1. Undock VFR map – no cure
    1. Disable all options in the bar at the top when flying – no cure
    1. Disable Windows Spatial Sound – this did cure sound stutters but had no impact on visual stutters and pauses.
    1. Turn off all AI – no cure

HARDWARE CURES

    1. Use HDMI cable instead of DP cable – no cure
    1. Use DVI cable instead of HDMI (thought of this one myself) – but no cure
    1. Disconnect Xbox controller – no cure and a bit inconvenient as I use this for drone control.
    1. Turn on (or off) multithreading - no cure, my gaming PC doesn’t have this option and made no difference to my other PC which does have this option.
    1. Upgrade your PC to the latest CPU and GPU – no cure, haven’t tried this one myself, but there are enough who have these systems and still get the stutters and pauses.
    1. Upgrade your memory – no cure, went from 24gb to 32gb with no change, and anyway 32gb should be enough.

Edit

    1. Disable “Windows dynamic thread priority boost” using Process Lasso - SUCCESS (sort of) the jury is still out on this one. Before the 3 Sept patch, this definitely had a positive impact. After am not so sure, but keep it enabled anyway
    1. Disable HPET (High precision event timer) - no success, but Asus MB is one of those that has no BIOS control for this. Was able to disable it in Win 10 but got no benefit.
    1. Disable 1 cpu core using task manager. - no cure
    1. Set priority to high for MSFS.exe using task manager. - no cure
    1. Turn on IVT Intel Virtualization Technology in bios. - no cure. Not all CPUs have this option but mine does. Tried it and saw no improvement.
    1. Fly aircraft without an EFIS cockpit. SUCCESS This one also works with stutters virtually eliminated, and not just because these aircraft fly slower.

Edit - after patch 1.8.3
. Disabled any fixes previously applied in Windows.
. Stutters are much improved everywhere. Process Lasso no longer has any observable benefit. Large pauses/stutters no longer noticeable flying around LA. Some minor stutters in this area still but a big improvement. Sydney is a big improvement.

Edit - after patch 1.18.13.0 - 27 July 2021

Went from mostly smooth to a big stutter fest after SU5. Tried everything like HAGS on/off mucked with most MSFS graphic settings, new/old Nvidia drivers. Even replaced my power supply, but nothing worked.

Then thought back to this post and the one thing that worked in the past - Project Lasso. So used Process Lasso to disable “Windows dynamic thread priority boost” on Flightsimulator.exe. WOW what a difference. Smooth as silk now. See my post of 28/7 below for details.

Edit - 3 August 2021
After I installed Windows gaming update fix KB5004296, MSFS performed the same with or without Porcess Lasso. Performance after KB5004296 was the same as performance before the update using Process Lasso. See my post below of 3 August for more details.

36 Likes

Micro stuttering stopped for me since I’m “clicking” with my mouse on my second screen. I can’t use my mouse then in FS2020 but controllers still working- Windows setting the FS2020 as inactive window then- stopped all micro stutters…

4 Likes

Didn’t work for me see number 6 above.

1 Like

Have you tried disabling windows dynamic thread boost?

1 Like

Under Windows advanced settings>performance. Set priority to background tasks. Restart pc.

When in the game open up the task manager and, find MSFS exe right click and set priority to low.

Butter smooth for some reason, I can play at high 1440p with a 2nd gen i5.

12 Likes

Ahh you have to set task manager priority to low for it to work? I did change my setting to background tasks and didn’t notice any difference. I wonder whether that is because MSFS priority is set to high?
EDIT: Wow, I think it is alot smoother now, I had set priority to high in Process Lasso so I think that’s where my conflict was, thank you!

2 Likes

Hope you get it sorted

I know it doesn’t make sense to anyone but if you don’t set it to low it has like micro stutters

1 Like

Yes, mean I did try that solution earlier but I didn’t restart my PC, nor did I set priority to low! Lol It now is a lot smoother but I still get some stutters when if I suddenly/abruptly turn the aircraft left or right - doesn’t bother me as you don’t usually fly with such sudden movements but am interested if you notice the same?
Also do I have to set priority every time I start the sim or is the selection saved?

1 Like

Mine is completely smooth except for half a se one pauses where it seems to load maybe scenery.

1 Like

Is this the only tweak that you applied, I also have a i5 (7th Gen) no HT so I’m interested in knowing what you did to help with smoothness! Thank you

It’s the only tweak aside from lowering terrain detail the rest is set to high for most part at 2500x1600.

Remember to close most background tasks.

I don’t have HT either since I have an overClocked old i5 2500k.

1 Like

And I presume you have V-Sync on in game? BTW what have you got your terrain detail set to?

1 Like

Oh no no no v sync off absolutely. If I turn it on it’s a lag fest.

Terrain detail is at 60 and render scale at 85 with TAA.

2 Likes

Thank you, I will see how I get on with these settings!

Don’t you experience high CPU usage when V-Sync is turned off?
EDIT: Having now tested the various options, my system works best with V-Sync at 30HZ, 30FPS, having reduced the the terrain level of detail to 50. I get smooth performance even when controlling the aircraft aggressively, at terrain level of detail 75 it is still smooth but there are small ‘hiccups’.

@BilingualHarp7 have you tried turning off all the in game tabs in the toolbar at the top of the screen?

It stopped my stutters and pausing.

I do have threaded optimization on I’m nv control panel but nothing else.

1 Like

Why do you have to follow 45 points to fix something that shouldnt be fixed in the first place to play a simulator again? And why is it that fsx and fs2020 can´t run properly no matter what you do?

it´s just weird that you as a customer have to deal with a payed product from such a giant company who should be able to produce and develop a at least somewhat functional game. at least no gamecrashes midflight would be awesome…

28 Likes

I was having terrible stuttering with v sync on but I’m also having an absurd amount of cpu usage.

2 Likes

Thank you having done further testing, I also get increased stutters when V-Sync is on, my hope is that when they ‘fix the V-Sync’ I’ll be able to lock FPS to 30 or 60, thus reducing CPU usage

1 Like